View Single Post
Old 26 June 2017, 20:47   #15
DamienD
Global Moderator

DamienD's Avatar
 
Join Date: Aug 2005
Location: London / Sydney
Age: 40
Posts: 9,252
Heya Shatterhand,

Nice work and well done!!!

Attached is a new disk for you that runs on KS 1.3. It's as Tomislav said, you needed to use some files from WB 1.3.

Also, as Tomislav mentioned, the game will not work from Workbench. Tried 1.3 / 2.0 / 3.1...

Always get "Program Failed (Error #87000004)". Looked on EAB and there's similar stuff going on in this thread: Please help

As Thorham mentioned in the above thread:

Quote:
Originally Posted by Thorham View Post
Do you mean it shows a requester with the error message and the options 'suspend' and 'reboot' ? If so, then there is probably a flaw in your code. You could attach the source code to your next reply, so we can take a look at it, as it's pretty much impossible to tell what's wrong without looking at your code.
...followed by:

Quote:
Originally Posted by Thorham View Post
Before looking at any of your code, I tried the hello world program, and guess what, I got the same error. After taking a look at the code, I came to the conclusion it should be run from the shell. When I tried that, it worked just fine. Under amiga os, only programs which take the workbench in account should be run from the workbench, otherwise you have to use the shell. I've tried with one of my own programs, and it does exactly the same.
Attached Files
File Type: zip Quasarius (2017)(Raliza Software).zip (101.3 KB, 20 views)
DamienD is online now  
 
Page generated in 0.13910 seconds with 10 queries