View Single Post
Old 27 January 2017, 21:57   #4
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Thanks, drive is now detected, but twice. What follows probably isn't specific to the type-7-drive issue.

With a disk in the drive, WinUAE's drive scan reports:
opening device '\\?\usbstor#optical&ven_hp&prod_c1113m&rev_1.19#7&12db4270&2#{53f56307-b6bf-11d0-94f2-00a0c91efb8b}'
device id string: 'HP C1113M 1.19 332058 '
IOCTL_DISK_GET_LENGTH_INFO returned size: 1303563264 (0x4db2cc00)
BPS=1024 Cyls=79 TPC=255 SPT=63 MediaType=11
device size 1303563264 (0x4db2cc00) bytes
1 MBR partitions found
0: num: 1 type: 04 offset: 0 size: 1303563264, type not 0x76 or 0x30
non-empty MBR partition table detected, doing RDB check anyway
hd accepted, not empty and not mounted in Windows
...
opening device '\\.\J:'
device id string: 'HP C1113M 1.19 332058 '
IOCTL_DISK_GET_LENGTH_INFO returned size: 1303563264 (0x4db2cc00)
BPS=1024 Cyls=79 TPC=255 SPT=63 MediaType=11
device size 1303563264 (0x4db2cc00) bytes
1 MBR partitions found
0: num: 1 type: 04 offset: 0 size: 1303563264, type not 0x76 or 0x30
non-empty MBR partition table detected, doing RDB check anyway
hd accepted, not empty and not mounted in Windows


And there are two entries in the drive list, see attached pic.


Also, is the "1 MBR partitions found" message produced by WinUAE, or is that (faked) info given by Windows? You can tell it's fake because the supposed MBR partition covers the entire disk.


Finally, is there any way to tell WinUAE to re-scan drives? If you click Add Hard Drive... with no disk in the drive, it appears in the list as [NO MEDIA]. After inserting a disk you have to (it seems) quit and run WinUAE again in order to have it recognise the disk in the drive.
Attached Thumbnails
Click image for larger version

Name:	DriveDetectedTwice2.png
Views:	28
Size:	15.3 KB
ID:	51836  

Last edited by mark_k; 27 January 2017 at 22:03.
mark_k is offline  
 
Page generated in 0.07986 seconds with 10 queries