View Single Post
Old 16 October 2016, 20:14   #34
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,476
Quote:
Originally Posted by JZon View Post
Here is the config I chose for all versions..
...
(I think they are all the same..)
Yep they are all more or less the same. See below for some suggestions.

Quote:
Originally Posted by JZon View Post
Judging from this pc (HP2000/Win8.0), I'm not sure if there is any acceleration available. I think ReadyBoost got taken out from Win7 to Win8, I can set priority (I think) possibly move WinUAE up the list (never tried), and I think I have some RAM modification apps. I left them out on this latest clean Win8 install as the things I was reading online seemed to suggest it's already optimized. (Aladdin 4D wants real memory. ((Not virtual)) It said) Not sure, maybe the pagefile size I'm using is a stock Win8 amount. (Haven't gone there either on latest install)
You can probably leave Windows OS settings alone. Except for the power mode, try setting that to High Performance if you're not running on battery.

As far as Amiga programs are concerned, they have real memory. (You're not running an Amiga-side virtual memory program like GigaMem.)
Quote:
Originally Posted by JZon View Post
Was the A4000T(ower) ever emulated? I think, if I'm not mistaken, it would require it's special own individualized rom.
WinUAE does support A4000T emulation. You'd need to find an A4000T Kickstart ROM and Workbench disks. In terms of emulated machine speed there will be no difference.


Back to your configs. I took a look and...

CPU and FPU:
CPU Emulation Speed: The CPU Idle slider is set all the way to the right. Try moving it (almost) all the way to the left.
Advanced JIT settings: Change cache size to 8MB (not sure that would make much difference, but it's the default setting).

Chipset:
Check Immediate Blitter. For OS-legal programs that could/should speed up graphical operations.
Change Collision Level from Full to None. Almost no programs (just a few games) use collision detection. Emulating it fully just wastes CPU time.

RAM:
You have 512MB Z3 fast RAM configured. Do you actually need anywhere near that amount? Try reducing it to 64 or 128MB.
You have a 256KB Zorro II fast RAM board configured. Not sure why. See "Z2 Fast Ram #2 [256k]" entry under Advanced Memory Settings.

Expansions: You have CD32 FMV cartridge configured, remove it. It can't coexist with the 8MB chip RAM you have.

RTG board: You could change Buffer mode to Triple buffering to see if that makes any difference.

Display:
You have "Blacker than black" checked. You probably don't want that since it makes normal Amiga black grey, not black.

You're using triple buffering. You could experiment with the other options (No buffering and Double buffering). Also, try disabling forced vsync if that's an option in your Windows graphics driver (e.g. Nvidia control panel). And try using full-screen mode for native and/or RTG modes.

Sound:
If you won't be using any programs that play sound, you can disable sound emulation to improve performance a little.


To try to get a useful benchmark of config changes, you could time (using a stopwatch) how long the emulated machine takes to render a scene in Aladdin 4D.
mark_k is offline  
 
Page generated in 0.07653 seconds with 9 queries