View Single Post
Old 18 June 2016, 18:26   #1
mark_k
Registered User
 
Join Date: Aug 2004
Location:
Posts: 2,480
A2024 refresh problem with frame skip = 1, 3, ...

[I half-remember reporting this before, but in case I'm mistaken...]

I noticed a problem with A2024 modes (at least the four-pane 15Hz one) when frame skip is set to 1, 3 or 5 etc. [With the Refesh slider in Display settings all the way to the left, that's 0 frame skip, i.e. every frame is rendered. Frame skip 1 means every other frame is rendered etc.]

Set Refresh to frame skip 1. Boot to Workbench, set Workbench to A2024:15Hz and open a CLI/Shell window. Resize the window so it occupies most of the screen. Move the mouse pointer to near the bottom left corner.

Type stuff in the CLI, e.g. Type S:startup-sequence, press return several times. You should see that only part of the screen is refreshed.

Repeat with Workbench in A2024:10Hz and you should see some parts of the window are not refreshed for any frame skip > 0.

I'm not sure what the best way to "fix" this would be. There is a benefit to skipping frames (lower CPU usage), but perhaps ignore the Refresh setting for A2024 modes by default? Or show a warning to the user the first time an A2024 mode + frame skip is used?
mark_k is offline  
AdSense AdSense  
 
Page generated in 0.05273 seconds with 9 queries