View Single Post
Old 23 April 2016, 23:06   #13
Registered User
Join Date: Jan 2010
Location: Kansas
Posts: 875
Originally Posted by desiv View Post
Are there any? I know that the Kickstart (The A600 came with 2.x?) can cause some issues but that would be the same for 2.x on an A500.. I wasn't aware of any issues related to the A600 itself.. except for...
Yes, the kickstart change was one of the problems. I believe the address location and type of memory was another. Even the HD, PCMCIA slot, and newer custom chips could cause problems in rare cases. Some games made very poor assumptions about the hardware they ran on. C= should have upgraded the Amiga 500 to the newer kickstart and added IDE much earlier which would have sold more 500s and made the jump to newer hardware easier.

Originally Posted by desiv View Post
I do wonder if there were ever any A600's shipped to the US, other than maybe some special orders or something...

Were there shops in the US that had A600's?
I don't remember seeing them.. I saw the 1200's (and got one), but not the 600.. I know the 600 was in Canada, so some would have made it down. And combine that with some special orders..
But was it ever shipped to retailers/computer stores as a US product??
I don't remember seeing any Amiga 600s in shops (not many shops in the Midwest) but there weren't many shops here that had Amigas. I remember seeing the 500, 1000, 2000, 3000 and 1200 only (and not all were for sale). The only 600 I have seen was at an Amiga show but that doesn't mean they weren't available. Lantus360 lives not far from me and I expect his was not brought from Australia/Europe since it is NTSC. I ended up with a NTSC CD32 from a friend's connections without ever seeing one before. C= had some weird marketing channels.
matthey is online now  
Page generated in 0.08844 seconds with 9 queries