View Single Post
Old 10 April 2015, 18:23   #267
Registered User

Dejavu's Avatar
Join Date: Apr 2015
Location: İstanbul/Turkey
Age: 38
Posts: 29
Send a message via ICQ to Dejavu
Thanks for information.

I've already had a power issue when i added Indi.ECS Scandoubler on the top of ACA500 & ACA1233 combination.

I changed my old ATX PSU to a new one which can provide 20A current on +5V rail. Please see the table below link.

According to this page an A1200 with 68060 card , 2xHDD & SCSI card consumes 3A on +5V rail.

so (roughly) my psu should still have 10-15A@+5V margin to provide required power for Rapidroad.

since i have no electrical&electronics expertise, i am not sure that is the correct approach/calculation for the situation.

What do you think?

Originally Posted by Schoenfeld View Post
Since there is no sufficient power supply that can handle A500, ACA500 and ACA12xx in addition to USB devices, I recommend not to use RapidRoad on the ACA500 at this point.

The Delfina/Silversurfer side would be the correct side. However, I have to reapeat: I do not recommend to operate all this without a good power supply. Since ATX power supplies are no good due to their main rail being the 12V line (not the 5V line as required by the Amiga), you risk the life of all components on that setup.

My current plan is to include a DC-DC converter with the X-Surf-500, so you can add power for USB using an off-the-shelve 12V DC supply.


Last edited by Dejavu; 10 April 2015 at 18:40.
Dejavu is offline  
Page generated in 0.05242 seconds with 9 queries