View Single Post
Old 06 April 2015, 17:14   #1
Brick Nash
Registered User

Brick Nash's Avatar
 
Join Date: Mar 2015
Location: Glasgow
Posts: 146
asm code file errors and external file locations

Hmmm hope I'm in the right bit here, please feel free for any admins to move this post if I'm in the wrong bit.

I've been downloading some .asm examples and I have a nice bunch of them in a zip file which I've been looking at with asm-one but I'm having a slight problem when assembling.

It keeps bringing up file errors (mostly something called vsi.i) here and there but I'm pretty sure that it is looking for a file or files that were bundled with the examples that the code references and just can't find.

I've had a look in the bundle in windows and yes the parts that bring up the errors in the assembler seems to be files in themselves that asm-one can't locate but have been placed in zip files within the original zip file with other stuff such as graphics, music etc.

I have the zip bundle mounted as a directory in Winuae so I can access it but I'm guessing asm-one has trouble reading the zip file, either that or I haven't set something right to point to it within the program but I'm wondering if I should copy the whole contents of the zip bundle to a drawer on my virtual hard drive so that asm-one can locate the referenced files in the same environment as the source code I'm reading or is it something I'm going to have to point to manually within the preferences?

I hope that made sense......I'm not sure it did to me either, but any help would be great!
Brick Nash is offline  
AdSense AdSense  
 
Page generated in 0.05695 seconds with 9 queries