View Single Post
Old 11 February 2015, 16:11   #76
Toni Wilen
WinUAE developer
 
Join Date: Aug 2001
Location: Hämeenlinna/Finland
Age: 42
Posts: 19,518
Quote:
Originally Posted by mark_k View Post
Thanks, it gets further now, in fact installation seems to complete. I continued accepting the defaults and the installer created two 25MB partitions, formatted them and copied files to one. Then it created a boot floppy disk. After that it tells you to reboot with the boot floppy in DF0:. (Archive with HDF and boot floppy attached; remove .zip extension before unpacking it.)

[I think I forgot to enable RDB mode for the HDF in the config I attached above. You should do that before running the installer, if you want to run it yourself.]

On booting the boot floppy, its startup-sequence runs BindDrivers (which loads the driver, which automatically mounts the partitions) then transfers control to the HD. After a short while though the startup sequence is interrupted, saying SYS:gvpscripts/tstGVPscsi failed returncode 20

I'll look at the tstGVPscsi code to see what it might be doing. But the last SCSI lines in the log were:
-> DATAOUT=512 ST=0 SENSELEN=0 REPLYLEN=0
SCSIEMU HD 0: 08.00.68.C4.01.00.00.00.00.00.00.00 CMDLEN=6 DATA=067A0C18
-> DATAOUT=512 ST=0 SENSELEN=0 REPLYLEN=0
SCSIEMU HD 0: 08.00.68.C5.01.00.00.00.00.00.00.00 CMDLEN=6 DATA=067A0C18
-> DATAOUT=512 ST=0 SENSELEN=0 REPLYLEN=0
SCSIEMU HD 0: 1B.00.00.00.01.00.00.00.00.00.00.00 CMDLEN=6 DATA=067A0C18
-> DATAOUT=0 ST=0 SENSELEN=0 REPLYLEN=0

So it looks like it issues a START STOP UNIT command.
I get same error without any START STOP UNIT commands (or any SCSI commands) when booting from installed HD (with enabled autoboot ROM).

START STOP UNIT is "supported", it always returns immediate success.
Toni Wilen is online now  
 
Page generated in 0.14258 seconds with 9 queries