English Amiga Board


Go Back   English Amiga Board > Search Forums

Showing results 1 to 37 of 37
Search took 0.01 seconds.
Search: Posts Made By: mark_k
Forum: support.WinUAE 24 February 2013, 14:56
Replies: 230
Views: 142,773
Posted By mark_k
Nice work, NetBSD 6.0.1 now seems to boot fine...

Nice work, NetBSD 6.0.1 now seems to boot fine without FPU. (Can't start X, but that applies with FPU too, so not related to this issue.)

More test results without FPU...
Pre-installed NetBSD...
Forum: support.WinUAE 23 February 2013, 21:27
Replies: 230
Views: 142,773
Posted By mark_k
I wonder if the underlying cause is somehow...

I wonder if the underlying cause is somehow MMU-related? Anyway, I've attached logs from booting the NetBSD 6.0.1 installer (illegal instruction message when it reaches creating filesystems stage),...
Forum: support.WinUAE 23 February 2013, 18:38
Replies: 230
Views: 142,773
Posted By mark_k
So I guess there must be some other problem...

So I guess there must be some other problem causing the illegal instruction messages with NetBSD 6.0.1. You can see them either booting the pre-installed HDF, or running the installer when it fails...
Forum: support.WinUAE 23 February 2013, 12:47
Replies: 230
Views: 142,773
Posted By mark_k
strim: Would you be able to build a NetBSD kernel...

strim: Would you be able to build a NetBSD kernel which gives more information than just "Illegal instruction"? Maybe the instruction opcode and address and anything else which might help figure out...
Forum: support.WinUAE 21 February 2013, 17:38
Replies: 230
Views: 142,773
Posted By mark_k
I tried that after starting the NetBSD 1.6.2...

I tried that after starting the NetBSD 1.6.2 installer and got this for the LINEF EMU code:d 022de
000022DE 52b9 001d 64b0 ADD.L #$00000001,$001d64b0
000022E4 42a7 ...
Forum: support.WinUAE 21 February 2013, 16:51
Replies: 230
Views: 142,773
Posted By mark_k
With the latest winuae.zip and A3000/noFPU config...

With the latest winuae.zip and A3000/noFPU config there are still some Illegal instruction messages on booting the pre-installed NetBSD 6.0.1 HDF.

And running the NetBSD 1.6.2 installer, there is...
Forum: support.WinUAE 21 February 2013, 16:36
Replies: 230
Views: 142,773
Posted By mark_k
I'll check the latest winuae.zip. With the...

I'll check the latest winuae.zip.

With the previous winuae.zip, I just tried running the NetBSD 1.3.3 installer (as opposed to booting the full pre-installed OS) using loadbsd netbsd with...
Forum: support.WinUAE 21 February 2013, 14:47
Replies: 230
Views: 142,773
Posted By mark_k
In case it might help figure out what's going on,...

In case it might help figure out what's going on, the code which prints messages like Illegal instruction seems to be in src/sys/arch/amiga/amiga/trap.c...
Forum: support.WinUAE 20 February 2013, 16:30
Replies: 230
Views: 142,773
Posted By mark_k
I thought that might have been the reason for the...

I thought that might have been the reason for the problem. Perhaps the NetBSD installer installs an FPU-only kernel when run on a machine with FPU. So booting an already-installed NetBSD HDF on an...
Forum: support.WinUAE 20 February 2013, 15:52
Replies: 230
Views: 142,773
Posted By mark_k
This mailing list thread...

This mailing list thread (http://groups.google.com/group/muc.lists.netbsd.port.amiga/browse_thread/thread/f1e75e6483a9f73a) is from someone with an A600 + ACA630 accelerator (with no FPU) who says...
Forum: support.WinUAE 20 February 2013, 14:39
Replies: 230
Views: 142,773
Posted By mark_k
Since I got the problem with 68030 + no FPU...

Since I got the problem with 68030 + no FPU testing NetBSD 6.0.1, I thought it was possible there has been some regression with NetBSD and no FPU, if all the NetBSD devs' machines have FPUs.

But I...
Forum: support.WinUAE 05 February 2013, 21:03
Replies: 230
Views: 142,773
Posted By mark_k
Ah. If you look at the a34kbbc.c history...

Ah. If you look at the a34kbbc.c history (http://cvsweb.netbsd.org/bsdweb.cgi/src/sys/arch/amiga/dev/a34kbbc.c?only_with_tag=MAIN), scroll down to revisions 1.4/1.5/1.6. Commit comments for those...
Forum: support.WinUAE 05 February 2013, 20:12
Replies: 230
Views: 142,773
Posted By mark_k
Strange. The configs I tested with are attached,...

Strange. The configs I tested with are attached, I get a crash with both A3000/060 and A4000/060. (Did you try unpacking the HDF archive again? Maybe not using a fresh copy could cause some change in...
Forum: support.WinUAE 05 February 2013, 19:29
Replies: 230
Views: 142,773
Posted By mark_k
NetBSD 1.2 and later support 68060 CPU...

NetBSD 1.2 and later support 68060 CPU (ftp://ftp.netbsd.org/pub/NetBSD/NetBSD-archive/NetBSD-1.2/amiga/INSTALL):
Forum: support.WinUAE 05 February 2013, 19:23
Replies: 230
Views: 142,773
Posted By mark_k
Up to now I've only been testing various NetBSD...

Up to now I've only been testing various NetBSD etc. images with 68030/040. I just tried the NetBSD 1.3.3 image I uploaded before with emulated 68060 CPU, and early in the boot sequence there's an...
Forum: support.WinUAE 03 February 2013, 13:37
Replies: 230
Views: 142,773
Posted By mark_k
Host to drive transfers would be needed if you...

Host to drive transfers would be needed if you were to add generic ATAPI removable drive emulation. With that feature it should be possible to change HDFs on-the-fly in NetBSD, Linux etc. (At the...
Forum: support.WinUAE 01 February 2013, 21:06
Replies: 230
Views: 142,773
Posted By mark_k
With the config I'm using (A4000/030 or...

With the config I'm using (A4000/030 or A4000/040, IDE HD and IDE CD-ROM) NetBSD doesn't mount the CD drive reliably (though it does detect its presence). WinUAE 2.6.0b5 is similar, I just tried once...
Forum: support.WinUAE 01 February 2013, 20:43
Replies: 230
Views: 142,773
Posted By mark_k
Which version of NetBSD are you using?

Which version of NetBSD are you using?
Forum: support.WinUAE 01 February 2013, 17:37
Replies: 230
Views: 142,773
Posted By mark_k
NetBSD has FPU software emulation so it should...

NetBSD has FPU software emulation so it should work with no FPU. However on booting the 6.0.1 test image with A3000/030/noFPU config, there are errors early in the boot sequence. If it's relevant...
Forum: support.WinUAE 30 January 2013, 20:15
Replies: 230
Views: 142,773
Posted By mark_k
The not enough ptys message was what I got trying...

The not enough ptys message was what I got trying to start X with my NetBSD 6.0.1 HDF with 68030 config too. I might try and re-install the OS, in case some maybe-now-fixed MMU bug caused a problem...
Forum: support.WinUAE 30 January 2013, 18:41
Replies: 230
Views: 142,773
Posted By mark_k
I tested today's winuae.exe with A3000/040 config...

I tested today's winuae.exe with A3000/040 config and the NetBSD 1.3.3 hardfile I uploaded (http://eab.abime.net/showthread.php?t=67534). Things are definitely much better than before. The system...
Forum: support.WinUAE 25 January 2013, 22:24
Replies: 230
Views: 142,773
Posted By mark_k
I re-tested my NetBSD 6.0.1 HDF...

I re-tested my NetBSD 6.0.1 HDF (http://www..com/file/kfNmf5cG/NetBSD_4GB_HD_after_install_A3.html, ~84MB) with today's winuae.exe, emulated A3000/040 config.

On booting WinUAE the first...
Forum: support.WinUAE 18 January 2013, 20:52
Replies: 230
Views: 142,773
Posted By mark_k
I set up a hardfile for installing OpenBSD 3.2....

I set up a hardfile for installing OpenBSD 3.2. It's similar to the NetBSD HDFs I uploaded, except instead of booting directly into the installer the FFS partition is bootable and its...
Forum: support.WinUAE 15 January 2013, 22:20
Replies: 230
Views: 142,773
Posted By mark_k
Booting an A4000/040 config with the NetBSD 1.6...

Booting an A4000/040 config with the NetBSD 1.6 install HD image, the WinUAE log reports:
IDE0 recalibrate
IDE0 drive multiple mode = 64
(those two lines repeated another 10 times)

NetBSD...
Forum: support.WinUAE 15 January 2013, 18:57
Replies: 230
Views: 142,773
Posted By mark_k
Hmmm, the NetBSD 1.6 install document says a...

Hmmm, the NetBSD 1.6 install document says a minimal configuration requires 6MB RAM (excluding chip RAM). I wonder whether it's actually possible to install 1.6 on a real Amiga with 8MB fast RAM?
...
Forum: support.WinUAE 15 January 2013, 17:29
Replies: 230
Views: 142,773
Posted By mark_k
You can browse the NetBSD 1.6 source at...

You can browse the NetBSD 1.6 source at http://cvsweb.netbsd.org/bsdweb.cgi/src/?only_with_tag=netbsd-1-6-RELEASE. For different versions change the release tag in the URL. Probably...
Forum: support.WinUAE 15 January 2013, 15:09
Replies: 230
Views: 142,773
Posted By mark_k
Also, booting that HD image with a 68030 A1200...

Also, booting that HD image with a 68030 A1200 config results in this log output:
MMU: page fault (logical addr=0A020000 SSW=5066 read=1 size=2 fc=6 pc=0a020000)
[that line repeated many times]...
Forum: support.WinUAE 15 January 2013, 14:57
Replies: 230
Views: 142,773
Posted By mark_k
I set up a NetBSD 1.6 install HD image and tested...

I set up a NetBSD 1.6 install HD image and tested that with A3000/040 emulation. That shows a problem much earlier. After some initial text the installer repeatedly prints
Process (pid 1) got signal...
Forum: support.WinUAE 13 January 2013, 13:10
Replies: 230
Views: 142,773
Posted By mark_k
With the 2013-01-13 09:57 winuae.exe (but not...

With the 2013-01-13 09:57 winuae.exe (but not with 2.6.0b1) I get this error output on booting my just-installed NetBSD test image. A4000/030 config. There was this line in the log output:
MMU: page...
Forum: support.WinUAE 12 January 2013, 23:09
Replies: 230
Views: 142,773
Posted By mark_k
Not sure this is the best thread for it, but...

Not sure this is the best thread for it, but NetBSD 6.0.1 seems to install correctly when the emulated machine has 68030+MMU. However after installing, when I boot the system with 68040 CPU, the...
Forum: support.WinUAE 02 January 2013, 16:43
Replies: 230
Views: 142,773
Posted By mark_k
Thanks. That allowed me to use SnoopDOS and see...

Thanks. That allowed me to use SnoopDOS and see ENV:MMU-Configuration was being read shortly before the hang. It turns out I had an entry to write-protect $200000-$27FFFF. The Kickstart image was...
Forum: support.WinUAE 01 January 2013, 21:25
Replies: 230
Views: 142,773
Posted By mark_k
Would you be able to build a winuae.exe which...

Would you be able to build a winuae.exe which pauses emulation or halts on a double bus error?

Hopefully I can use something like SnoopDOS to figure out what system functions are being called...
Forum: support.WinUAE 30 December 2012, 21:24
Replies: 230
Views: 142,773
Posted By mark_k
Could the files /usr/sys/amiga/alien/a2091.c and...

Could the files /usr/sys/amiga/alien/a2091.c and /usr/sys/amiga/alien/a3091.c in the AMIX kernel configuration package (conf.cpio) be of any help there?

I'll try testing the MMULib tools when...
Forum: support.WinUAE 30 December 2012, 20:30
Replies: 230
Views: 142,773
Posted By mark_k
I tried out mmu.library and some programs which...

I tried out mmu.library and some programs which come with it: http://aminet.net/package/util/libs/MMULib

It seems that running anything which opens mmu.library (MuScan, MuFastROM, MuForce etc.)...
Forum: support.WinUAE 29 December 2012, 18:31
Replies: 230
Views: 142,773
Posted By mark_k
Nice work! I'll try testing that with SetCPU...

Nice work! I'll try testing that with SetCPU FASTROM/KICKROM/CARDROM options and the MMULib tools MuFastROM, MuFastZero etc. Could possibly also be tested (by someone else :)) with Emplant and/or...
Forum: support.WinUAE 12 March 2011, 11:39
Replies: 230
Views: 142,773
Posted By mark_k
Hi, In the MAME 0.141u3 changelog there is...

Hi,

In the MAME 0.141u3 changelog there is this:

M680x0 updates [Hans Ostermeyer]
* Instruction cache emulated on '020 and later
* Fixed interaction between MMU and bfextu/bfexts/bfins
*...
Forum: support.WinUAE 10 September 2009, 21:25
Replies: 230
Views: 142,773
Posted By mark_k
[I guess this is getting off-topic for this...

[I guess this is getting off-topic for this thread, but...]

Rather than SCSI CD-ROM drive emulation, is there any possibility to "own" a real SCSI device connected to the PC's SCSI controller? In...
Showing results 1 to 37 of 37

 
Forum Jump

All times are GMT +2. The time now is 13:35.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.
Page generated in 0.07737 seconds with 10 queries