English Amiga Board


Go Back   English Amiga Board > Search Forums

Showing results 1 to 25 of 25
Search took 0.01 seconds.
Search: Posts Made By: Hannibal
Forum: Retrogaming General Discussion 02 February 2020, 00:34
Replies: 42
Views: 2,798
Posted By Hannibal
Banshee used 63 colors, with 2 semi-transparent...

Banshee used 63 colors, with 2 semi-transparent layers (used for fog, and for transparent bullets/polygon lasers) and 15 colors for sprites (hud and bosses), so 205 used but technically 256 color...
Forum: Coders. General 11 November 2019, 15:47
Replies: 274
Views: 11,775
Posted By Hannibal
(Sorry I posted my reply in the wrong thread - if...

(Sorry I posted my reply in the wrong thread - if there's an admin, feel free to move my comment and replies to it to the fixed point maths thread.).

Yeah, you should be able to approximate as a...
Forum: Coders. General 11 November 2019, 06:46
Replies: 274
Views: 11,775
Posted By Hannibal
First up, great progress on your ambitious goal,...

First up, great progress on your ambitious goal, Deimos, it's inspiring reading about how far you came in such a short time. Best of luck finishing it some time

Here is my take on the original...
Forum: Coders. Asm / Hardware 08 November 2019, 10:18
Replies: 156
Views: 18,285
Posted By Hannibal
My config looks like this. { ...

My config looks like this.
{
"amiga-assembly.cstool": "buildtool\\cstool.exe",
"amiga-assembly.vasm": {
"enabled": false,
"file": "buildtool\\vasmm68k_mot_win32.exe"
...
Forum: Coders. Asm / Hardware 07 November 2019, 07:00
Replies: 156
Views: 18,285
Posted By Hannibal
I have now integrated this in with my current...

I have now integrated this in with my current project, and it all works. It is increasing the joy of coding :-) A couple of things I discovered
1. Like multiple people I use a separate build system...
Forum: Coders. Asm / Hardware 22 October 2019, 08:03
Replies: 156
Views: 18,285
Posted By Hannibal
after updating the bin files it works perfectly,...

after updating the bin files it works perfectly, thank you for fixing it so quickly
Forum: Coders. Asm / Hardware 21 October 2019, 21:44
Replies: 156
Views: 18,285
Posted By Hannibal
I tried 0.18.1, but I still saw the same problem....

I tried 0.18.1, but I still saw the same problem. Is there anything else I have to do other than let VS.Code install the update, and then restarting VS.Code? Do I need to restart my PC? clean and...
Forum: Coders. Asm / Hardware 20 October 2019, 23:28
Replies: 0
Views: 294
Posted By Hannibal
Change in behavior in recent VASM upgrade

I've been trying to upgrade to a more recent vasm, and it generally was smooth, except one regression is blocking me:

reg/equrl statements now cannot override a previous statement. For example,...
Forum: Coders. Asm / Hardware 20 October 2019, 04:11
Replies: 156
Views: 18,285
Posted By Hannibal
Yay, it is not just a bug on my machine :-) ...

Yay, it is not just a bug on my machine :-)

Now for me to figure out how I can configure my code to work with it
Forum: Coders. Asm / Hardware 19 October 2019, 04:35
Replies: 156
Views: 18,285
Posted By Hannibal
I finally got around to try this, and it is very...

I finally got around to try this, and it is very impressive, thank you for doing all this work.
I ran into one issue - not sure if this is just me: using the sample workspace, I can place/remove...
Forum: Coders. Asm / Hardware 02 May 2018, 04:43
Replies: 17
Views: 1,292
Posted By Hannibal
I think I can guess what you are doing, and have...

I think I can guess what you are doing, and have considered the same thing. I concluded the cleanest solution was to add an extra back buffer, so the CPU can draw to buffer x-1 while blitter draws to...
Forum: support.WinUAE 22 March 2018, 05:38
Replies: 3
Views: 866
Posted By Hannibal
Yes, I meant breakpoints using w command. I...

Yes, I meant breakpoints using w command.

I also haven’t gotten a solid reproducible case, but in some cases when I hit a breakpoint and step with t, it seems to actually skip to the next memory...
Forum: support.WinUAE 14 March 2018, 05:12
Replies: 3
Views: 866
Posted By Hannibal
Two minor debugger bugs

I have a couple of debugger bugs - maybe not a big deal to most, but if they are quick fixes I would love to see them
1. When I create a memory breakpoint in slot 4, it doesn’t get hit - but if I...
Forum: support.WinUAE 04 February 2018, 23:23
Replies: 4
Views: 643
Posted By Hannibal
Hmmm I can’t repro it now. If I get it again I...

Hmmm I can’t repro it now. If I get it again I will try to get a sample and config to you. This was on a500, in fake fast ram.

thanks, the mul/div explanation makes perfect sense. I appreciate...
Forum: support.WinUAE 04 February 2018, 20:47
Replies: 4
Views: 643
Posted By Hannibal
Thank you for the super fast reply. Good call, I...

Thank you for the super fast reply. Good call, I had both harddrives and RTC enabled. I didn't think it mattered because I was doing trackloading from a bootblock, but maybe kickstart 2.04 accesses...
Forum: support.WinUAE 04 February 2018, 19:06
Replies: 4
Views: 643
Posted By Hannibal
Can you force winUAE to be deterministic

I am trying to debug something with WinUAE, and it would be much easier to investigate if I could force it to be 100% deterministic. Right now I would think maybe disk access and/or system timers may...
Forum: Coders. Asm / Hardware 31 May 2016, 05:53
Replies: 34
Views: 6,969
Posted By Hannibal
I think minterm should be $3c, not $14 - 14...

I think minterm should be $3c, not $14 - 14 assumes blitter c data is 0, and it looks like it is not
Forum: support.WinUAE 28 December 2015, 17:46
Replies: 6
Views: 1,086
Posted By Hannibal
Thank you :-)

Thank you :-)
Forum: support.WinUAE 28 December 2015, 02:24
Replies: 6
Views: 1,086
Posted By Hannibal
Heh, it isn't the first time an undocumented side...

Heh, it isn't the first time an undocumented side effect became a useful feature :-)
Since it is consistent across all kickstarts, i can understand why the author took advantage of it.
I think...
Forum: support.WinUAE 27 December 2015, 18:07
Replies: 6
Views: 1,086
Posted By Hannibal
built-in rom crashes client and host on shrinkler-packed executables

While trying to run octorubber (or other demos packed with same packer), on a4000 default config, with the replacement rom, the amiga-side emulator crashes, and then the host system crashes.

Repro...
Forum: support.Games 14 December 2015, 06:36
Replies: 12
Views: 1,691
Posted By Hannibal
Kannijade Krew was not a tracker musician from...

Kannijade Krew was not a tracker musician from the past - it was just a mangled merge of the demoscene nicknames of the two main creators. (Jacob and me). I guess we made a tracker module or two but...
Forum: Coders. Asm / Hardware 27 May 2015, 04:52
Replies: 37
Views: 11,849
Posted By Hannibal
I would imagine it would be easy to set up launch...

I would imagine it would be easy to set up launch and run from pretty much any decent text editor - it is just calling a bat file to build and run. I don't know sharp develop but it is probably easy...
Forum: Coders. Asm / Hardware 25 May 2015, 18:31
Replies: 37
Views: 11,849
Posted By Hannibal
Very strange. Do you have vs2013 update 4...

Very strange. Do you have vs2013 update 4 installed? The menu item Help->About Microsoft Visual Studio should list it next to the version number (for me it is "Version 12.0.31101.00 Update 4")
Go to...
Forum: Amiga scene 20 May 2015, 08:41
Replies: 227
Views: 37,118
Posted By Hannibal
Hey y'all, one of the suggestions on here was...

Hey y'all,
one of the suggestions on here was a full toolchain with everything pre-configured (just add Kickstart roms).
I've just released such a thing - check it out here:...
Forum: Coders. Asm / Hardware 20 May 2015, 08:39
Replies: 37
Views: 11,849
Posted By Hannibal
I've finally finished V5 of this package. All the...

I've finally finished V5 of this package. All the details are here: http://www.pouet.net/prod.php?which=65625 - for feedback, post it there, on ADA (http://ada.untergrund.net/?p=boardthread&id=666)...
Showing results 1 to 25 of 25

 
Forum Jump

All times are GMT +2. The time now is 11:09.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.
Page generated in 0.12410 seconds with 10 queries