English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   News (http://eab.abime.net/forumdisplay.php?f=29)
-   -   AWeb APL Lite Released (http://eab.abime.net/showthread.php?t=91454)

AMIGASYSTEM 22 March 2018 01:18

AWeb APL Lite Released
 
1 Attachment(s)
http://eab.abime.net/attachment.php?...1&d=1521677752


AWeb APL Lite: New version of the famous Amiga Browser, these are the news:

Adds support for AmiSSL 4, and is compiled with gcc 5.4

And AWebJS has support for sending ARexx commands to a host, so you can use it as a standalone ARexx replacement. See the tests in the src directory for example code.

AWeb is a fast standards complient (by that I mean it complies to the standards it supports, not that it supports all standards...) HTML4.01 browser for AmigaOS. It has a powerful AREXX based scripting engine, and in local mode can execute commands from with html pages. This makes it very suitable for a documentation viewer, or GUI for a scripts etc.

AWeb APL Lite 3.5.12: Download

LICENCE

This software is released under the AWeb Public Licence, please read the file apl.txt included in this archive for more information.

INSTALLATION

AWeb 3.5 may be installed by using the Installer script provided. It is recommended that you back up any previous installations of AWeb or install in a separate directory, but actually there should not be any real problems.

malko 22 March 2018 01:42

:great

gulliver 22 March 2018 02:33

That is great news. Now where is the 68k build?

ma693541 22 March 2018 21:35

I wonder that too, 68K build.

kolla 22 March 2018 22:28

The sources are in the archive, build away for whatever platform you like.

kolla 22 March 2018 22:34

Quote:

Originally Posted by AMIGASYSTEM (Post 1229195)
and in local mode can execute commands from with html pages.

Local mode, such as content from "file://TCP:192.168.2.44/1050" and the like :)

AMIGASYSTEM 23 March 2018 17:40

Kolla, i'm not the author i just did the news ;)

grelbfarlk 23 March 2018 23:52

So has anyone tried compiling it?

Retrofan 24 March 2018 00:47

Quote:

Originally Posted by ma693541 (Post 1229365)
i wonder that too, 68k build.

+1

Minuous 24 March 2018 08:41

@grelbfarlk:

Tried a few years ago with a somewhat older version. However, since the initial open sourcing of AWeb, most of the SAS/C support has been removed for no apparent reason, so it was going to be far too much hassle. Maybe some GCC user can try.

TuKo 24 March 2018 09:31

did a quick try with gcc 2.95.3, no luck

pipper 26 March 2018 20:36

I tried compiling with Bebbos gcc 6, no luck either.
The AWeb code seems heavily dependent on OS4.

kolla 28 March 2018 00:38

Then this is more of an OS4 fork of AWeb than actual AWeb.


All times are GMT +2. The time now is 21:38.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.04115 seconds with 10 queries