English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   News (http://eab.abime.net/forumdisplay.php?f=29)
-   -   HippoPlayer v2.47 (http://eab.abime.net/showthread.php?t=108116)

koobo 01 September 2021 05:29

HippoPlayer v2.47
 
Updated Hippo available:
https://aminet.net/mus/play/hippoplayerupdate.lha

In this one: new exotic music formats, favorite modules feature, enhanced kickstart 1.3 support, and some fixes. Check out the details here:
https://aminet.net/mus/play/hippoplayerupdate.readme

Viceroy 01 September 2021 15:41

Thanks for the up ;-)

Warty 01 September 2021 16:34

Awesome!

A500 01 September 2021 18:08

Great, will test this at the weekend! Thanks!

koobo 01 September 2021 21:12

If you have some feature ideas you'd like to see in Hippo, let me now :spin

mihcael 02 September 2021 09:45

Really awesome, loved Hippo player

pcotter 02 September 2021 12:11

Thank you for keeping Hippo alive :-)

tomcat666 02 September 2021 12:29

Thank you. When using AHI as output device I always get the error "Trouble with the player group". I have copied the new .group file too, of course.

PerspexSphinx 02 September 2021 23:37

It would be nice to be able to change the interface’s display font size to something larger than 8 point…
Great to see it being updated.

tygre 02 September 2021 23:49

Thanks a lot, amazing! :)

Zoltar3.1 03 September 2021 13:17

Hello there;

There may be a bug in this version, because when I select the path of the modules to load (quite a long list, but it worked perfectly even in the old version), it takes a huge time to load (which never happened) and then , a guru meditation.

Tried running Hippo outside Workbench, but same result. This time it loads the list of modules (after a long time) and the module is empty, but the program seems to detect the modules, since it tries to load them, but shows an error every time.

Another problem is the Favorite modules implementation, which does not work. Since always, when you press the right button, you minimize the window, so there is no possible way to mark any module as favorite.
Hope this can be fixed as it is my main reason for updating :-)

Personally, I would feel very comfortable if pressing the right button did not minimize anything and did something more useful for the program.

Another possible features would be:
-Allow the tracker window to be larger, as for tracker musicians like me it would help to see important information :-)
-Right-clicking on a module in the list of modules might be enough to play it, without having to select the module and click Play or Enter.

Thanks for keeping the program updated! It's my best Amiga player!

koobo 03 September 2021 16:24

Quote:

Originally Posted by Zoltar3.1 (Post 1504655)
Hello there;

There may be a bug in this version, because when I select the path of the modules to load (quite a long list, but it worked perfectly even in the old version), it takes a huge time to load (which never happened) and then , a guru meditation.

Tried running Hippo outside Workbench, but same result. This time it loads the list of modules (after a long time) and the module is empty, but the program seems to detect the modules, since it tries to load them, but shows an error every time.

That sounds quite bad! Could you describe in detail what exactly you did to make this happen?


Quote:

Originally Posted by Zoltar3.1 (Post 1504655)

Another problem is the Favorite modules implementation, which does not work. Since always, when you press the right button, you minimize the window, so there is no possible way to mark any module as favorite.
Hope this can be fixed as it is my main reason for updating :-)

Personally, I would feel very comfortable if pressing the right button did not minimize anything and did something more useful for the program.

Just to be sure, is the "Favorite modules" checkbox enabled in prefs?
I agree that the RMB window minimizing feature is very silly and should be removed.

Quote:

Originally Posted by Zoltar3.1 (Post 1504655)

Another possible features would be:
-Allow the tracker window to be larger, as for tracker musicians like me it would help to see important information :-)
-Right-clicking on a module in the list of modules might be enough to play it, without having to select the module and click Play or Enter.

- Having larger tracker scope window is a good idea!
- You could maybe enable double clicking in prefs, so you can double click to play.

koobo 03 September 2021 16:51

Quote:

Originally Posted by tomcat666 (Post 1504392)
Thank you. When using AHI as output device I always get the error "Trouble with the player group". I have copied the new .group file too, of course.

You could maybe try removing S:HippoPlayer.prefs, too, and retry.
I think this error message should not be related to AHI settings at all :confused

koobo 03 September 2021 16:53

There's now a debug version of v2.47 available here:
https://github.com/koobo/HippoPlayer...dist/HiP-debug

It has a debug log window that displays a lot of messages. It might help in pinpointing problems mentioned in this thread.

tomcat666 03 September 2021 19:35

Quote:

Originally Posted by koobo (Post 1504685)
You could maybe try removing S:HippoPlayer.prefs, too, and retry.
I think this error message should not be related to AHI settings at all :confused

Removed S:HippoPlayer.prefs - same problem. If I use the HiP that is on the aminet everything works fine.

On the debug i only get

Probing
Normal load 143030
Identify module
Load player group
freemodule obtain data
freemodule release data
No action for key
No action for key

Zoltar3.1 04 September 2021 10:41

Quote:

Originally Posted by koobo (Post 1504681)
That sounds quite bad! Could you describe in detail what exactly you did to make this happen?

It never happened before untils this recent version.
I'm a musician, so have lots of drawers and mod files, plus XM's, IFF's...etc.
I have a unique drawer which contains all these subfolders and files, so, I click on "New" and double click on that drawer, then selecting "All".
In the previous versions, it took about 5-8 seconds or so, but in this version it takes around 15, at least, making strange things, like guru meditations, showing a requester requesting an inexistent volume which name is formed by simbols and numbers, or just an empty box, with the blue bar selecting "nothing" and trying to play it. After 2 seconds the program tries to play the next, and so on until the fourth or fifth, when an error shows up and the search is stopped.
However when I select a drawer with less files in it, it works OK.
Something was modified which avoids to load a huge files list (which always worked)


Just to be sure, is the "Favorite modules" checkbox enabled in prefs?

Ok... That was not mentioned in the Aminet doc... yeah, fixed! :-)



- Having larger tracker scope window is a good idea!

Yes! The PATTERNSCOPE, as, the bigger the window is the more time you have to see the sequence and commands. With only a few lines is too difficult to see what's being played :-)
I think the size of the other scopes are more than enough.


- You could maybe enable double clicking in prefs, so you can double click to play.

Ok, also done. Thank you. I didn't know this :-)

koobo 04 September 2021 10:58

Quote:

Originally Posted by Zoltar3.1 (Post 1504803)
Ok, also done. Thank you. I didn't know this :-)

Could you please try to reproduce the bug by testing the "HiP-Debug" version mentioned above, to see the logs Hippo outputs, and also run SnoopDos at the same time to see what it says?

Zoltar3.1 04 September 2021 11:00

Quote:

Originally Posted by koobo (Post 1504686)
There's now a debug version of v2.47 available here:
https://github.com/koobo/HippoPlayer...dist/HiP-debug

It has a debug log window that displays a lot of messages. It might help in pinpointing problems mentioned in this thread.


This is even more strange! My modules are in DH1: but the program starts scanning my DH0! :-o
After a few seconds it begins scanning the directory in DH1:... I see the debugging process moving too fast, but I recognize my modules.
After 4 or 5 seconds, strange simbols appear in the debugging window...
When the process stops, there's no way to scroll up to see the previous messages.

Could the fact that its a directory as a HardDrive instead of an HDF have something to do with this error?
Because of this, some of the disk repair utilities I used in the past don't work anymore, but it makes no sense today.

Zoltar3.1 04 September 2021 13:32

Quote:

Originally Posted by koobo (Post 1504805)
Could you please try to reproduce the bug by testing the "HiP-Debug" version mentioned above, to see the logs Hippo outputs, and also run SnoopDos at the same time to see what it says?

I don't know what's happening... It always ends in guru meditation everytime now. I disabled JIT in the emulator and notice it first performs a normalizing process, and starts checking DH1:, but, after a few seconds, the debug window clears automatically and starts scanning DH0... When it reaches the font drawer, it hangs in the AON font (don't know why), and crashes.

Besides that, when I open the Hip.debug program, I try to copy the content of the window to paste it in a word processor (Golded, Finalword, etc...) and only copies the first letter... there are no export optios, so I don't know how to copy it (in case I find the way to avoid the guru)

I think the program would work OK if it didn't insist on checking DH0...

Zoltar3.1 04 September 2021 13:41

The scanning finishes succesfully outside my HD workbench but, again, the list is empty, though it detects the modules, as it's trying to play them one by one.
I try the copy the debugging window content (CTRL+C,ALT+C...) and paste it elsewhere... But only copies the firts selected character.


All times are GMT +2. The time now is 16:07.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.06143 seconds with 10 queries