English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   WinUAE 3.0.0 beta series (was 2.8.2/2.9.0) (http://eab.abime.net/showthread.php?t=74263)

Toni Wilen 03 July 2014 17:19

WinUAE 3.0.0 beta series (was 2.8.2/2.9.0)
Read following instructions before posting http://eab.abime.net/showpost.php?p=861456&postcount=1 (Most important: Always test with 2.8.1, if 2.8.2 works the same -> not 2.8.2 problem -> post in new thread)


All kinds of random updates. May not be normal beta quality yet but change log had become too long wall of text..

Beta 1:

- Debugger TR command didn't handle linked resident lists correctly (inverted mask..).
- TO debugger command also lists FileSysStartupMsg and DosEnvec of mounted devices.
- Slow down 68EC020 RTE instruction, fast clock rate multiplier modes could have executed MOVE to INTREQ + RTE combination too quickly (before Paula had cleared the interrupt) causing interrupt to re-trigger immediately after RTE.
- Added SCSI controller selection to GUI and config file. ("SCSI (Auto)" does same as old plain SCSI selection = use first enabled SCSI controller).
- More than 1 SCSI controller can be now active simultaneously. (For example A4000T + A4091)
- Added support for two A590/A2091 and two A4091 boards, both (or even all 4) can be active at the same time.
- Secondary A590/A2091 and A4091 share primary board's boot ROM by default. a2091_2_rom_file and a4091_2_rom_file config file entry can be used to select other ROM version.
- 280b7 sprite update missed AGA bordersprite condition, causing clipped sprites in some situations (Silicon Graphics 2 / WFMH)
- Rewritten directory filesystem Examine Next logic, now returned fib_DiskKey always have file/directory entry specific unique value. Some programs check fib_DiskKey and (incorrectly) assume that it is unique value and may also assume file must be same if both file's have same fib_DiskKey. Now also C:List KEY output looks "correct". This needs testing because original (Tripos?) directory enumeration packet design is not that good..
- AGA border sprite bit set and if same scanline had at least 1 sprite that was outside of playfield and at least 1 bitplane was active and BPLCON4 palette XOR value was non-zero: wrong background color was visible in some situations. (Nexus 7 / Andromeda "shade cluster" part)
- Some BEAMCON0 programmed mode emulation updates. VBSTRT/VBSTOP register values only affect screen if VARVBEN bit is set.
- Use also value stored in VBSTRT (vertical blank start) register when setting up programmed mode vertical size, some weird modes can have (much) smaller VBSTRT than VSSTRT (vertical sync start). (Jtxrules by Illusion)
- HBSTRT/HBSTOP register values are only used if BPLCON3 EXTBLKEN bit is set. (Demos Contactro and Jtxrules by Illusion)
- BEAMCON0 HARDDIS bit also disables DDFSTRT hardware limit. (Weird stuff, VARBEAMEN disables it too, even superhires mode disables it..)
- Fixed "CPU trace blahblah" error after 68020+ state file was loaded and loaded program used bitfield instructions later.
- Split ROM images didn't load (again..) correctly if relative path mode was active.
- Added support for missing Z2 RAM board sizes (64k/128k/256k/512k). Note that small boards (256k and less) can be mapped at IO autoconfig base (0xe90000+) which makes predicting final address difficult: JIT (if enabled) can't use direct mode to access this RAM board.
- Added support for second Z2 fast RAM board. Size must be smaller or same as first board. (Makes JIT board address calculation simpler)
- Above two changes mean it is now possible to have total 6M of Z2 RAM in 24 bit addressing config with 2M gfx board config (4M + 2M and 2M gfx) or less useful 8M fast + extra 256k of fast config...
- Z2 gfx board JIT direct calculation didn't correctly align the board base address if Z2 RAM size was less than Z2 gfx board size.
- Implemented no-hack Z3 memory mapping, lets OS handle Z3 autoconfig without patching base addressess from >=0x40000000 to >=0x10000000. This mode is not JIT Direct compatible. Option in Memory panel. Do not enable unless you know what are you doing and you really need 100% matching real hardware Z3 address mapping.
- Use no-hack Z3 allocation automatically if all configured boards fit in official Z3 space, fully JIT Direct compatible. Requires 64-bit Windows and available space will be about 300M to 500M. RAM panel text string shows free space. 32-bit Chip RAM does not count, it is not Z3 board and it is always located at 0x10000000.
- Added 384M and 768M 32-bit Chip RAM size options. (768M fits perfectly at 0x10000000-0x3fffffff)
- Added Z3 autoconfig advanced chipset option. If ticked (or A3000/A3000T/A4000/A4000T chipset extra selected), Z33 boards will now appear at Z3 autoconfig space (0xFF000000), previously Z2 space was always used. Z2 space is supported by AOS but most real, but not all, Z3 boards use Z3 space. Optional because not all KS ROMs (for example A1200) support Z3 autoconfig space but do support Z3 boards.
- Try to keep number of cylinders under 65536 when generating default geometry even if partition hardfile is very large (>100G) for better old AOS compatibility. (Helps my big partition PFS3 testing..)
- Hardware (Cirrus Logic) RTG board emulation incorrectly required UAE boot ROM.
- 68030 MMU update from Previous, fixes some supervisor/write protect edge cases.
- Added "history" menu to filesystem, hardfile and tape path selection text boxes.
- Added portable mode (.ini) on/off state to Paths panel. Read-only, enabling it on the fly would cause all kinds of side-effects. Unsupported warning removed.

Mclane 10 July 2014 09:19

My goodness Toni, you have stunned everyone into complete silence, was there some mind altering code in the last beta :)

Toni Wilen 10 July 2014 10:01

Probably too much technical stuff only but next beta will surely generate more replies :)

turrican3 10 July 2014 10:25

cd32 fmv ?
When can we expect next beta ?

B14ck W01f 10 July 2014 14:44

And here I was thinking that Toni was planning to go on a holiday after he finished 2.8.1

That's a lot of features.

Toni Wilen 10 July 2014 15:05

Only CD32 FMV is "holiday special feature". Above features are "normal" that were queued during 2.8.0 and 2.8.1 (Features that I didn't want to add until now)

I usually design some bigger feature during holidays and then finally code it in few days (It was either better 68020 CE emulation or CD32 FMV. FMV win because it is totally different and I got bored with all the recent CPU stuff)

Toni Wilen 10 July 2014 16:30

EDIT: Do not use this beta due to chipset extra bug. Use b3.


Beta 2:

- Pointless CD32 Full Motion Video cartridge emulation! (Check notes below)
- CD32 FMV 40.22 ROM image rom scanner checksum fixed (was from byteswapped image). ROM rescan required.
- Added CD32 FMV option to Expansion panel.
- Added CD32 FMV to ROM scanner result dialog.
- GamePorts panel autofire always-option crashed.
- CD image emulation didn't support 2336 to 2352 sector size conversion.
- CD image emulation didn't return correct data if image had 2 data tracks back to back and tracks from second data track was requested. (Cannon Fodder CD32 FMV track)
- Debugger MOVES instruction's source and destination was swapped.
- Quickstart CD image selection text box become empty after image was selected (b1)
- RTG scale options didn't work on the fly. (2.8.0)

CD32 FMV notes:

- ROM requests won't be allowed and will be deleted. ("Find" it yourself or get AmigaForever or something)
- Only supports CL450 MPEG decoder commands that basic playback needs.
- VCD quality is not that good: MPEG-1 with 352x288 (PAL) or 352x240 (NTSC) resolution, MPEG-1 layer 2 audio.
- Requires at least null filter. (Automatically enabled)
- Requires 32-bit display mode, 16-bit will work in future. (Not automatically enabled)
- Tested with CD32 FMV 40.22 and 40.30 ROM versions.
- Tested only with Cannon Fodder CD32 video track and one VCD movie.
- Rewind or fast forward hangs the player software. (No idea why. No CL450 commands sent.)
- AV sync may not be that good.
- Sound buffer underflows will happen.
- CL450 video window size and position values ignored, video window is always centered and automatically 1x/2x/4x scaled.
- Video is 1:1 pixel mapped, aspect ratio is ignored.
- Before reporting anything: make sure your Cannon Fodder CD32 image is correct. It must have 2 data tracks, check .cue file using any text editor. Plain iso also can't work.
- Config must be based on Quickstart "CD32 with Full Motion Video cartridge". Do not load old CD32 config and tick CD32 FMV expansion option. If you do it, you are on your own.

- Only obvious bugs (very jittery video, nothing happens etc..) will be accepted. Everything else will be ignored until I get my own FMV cartridge. I won't pay for it. Exception is getting enough donations.

Most important: WinUAE is not a video player!

B14ck W01f 11 July 2014 09:26

Nice job!

Toni Wilen 11 July 2014 11:23


Beta 3:

- Selected chipset extra didn't match what dialog box shows (b2). This broke many configs..
- CD32 FMV 16-bit display mode support.
- A590/A2091, A3000, A4000T and A4091 SCSI was not initialized unless at least one device was connected (b1).
- Added Picasso IV flash rom v7.4 image to rom scanner. It does not need to be called picasso_iv_flash.rom anymore.
- Added Blizzard 1230-IV and 1240/1260 Boot ROMs to rom scanner. (Coming soon Blizzard 1230/40/60 unique memory layout and maprom emulation. It can be useful for developers and for testing without real board. This was supposed to be implemented in this beta but chipset extra bug required quick update)
- .bin extension added to ROM scanner.

Arling 11 July 2014 23:58

Toni wrote:
> Beta 2:
> - Pointless CD32 Full Motion Video cartridge emulation!
> - Tested only with Cannon Fodder CD32 video track and one VCD movie.

Wauw. That's sounds cool :-)

To My knowledge the game "Banshee CD32" should also make use of the FMV Module.


Usually I don't post here, beause I know myself so well that I can't follow The Rules.

turrican3 12 July 2014 20:53

The only games i know who use fmv is cannon fodder and the final gate, never heard that banshee used fmv.

turrican3 12 July 2014 21:57

ok, i tested the fmv
1)it works well with cannon fodder, just freeze if you go to the end of the intro.
2) demo disc 2.0 doesn't work well... the fmv's videos doesn't launch, the screen stay black, but it recognize the fmv module, because without it you have cdxl.
ps: i tested the demo disc 1.1 too, same problem.If you need more info, tell me.
ps2:OT:It could be great to add intros to amiga cd32 games in fmv !!

Toni Wilen 13 July 2014 19:47

Demo disks fixed (CD access problem, not FMV). http://www.winuae.net/files/b/winuae.zip

AnnaWu 13 July 2014 20:31

"Cannon Fodder" just tested and the first impression about the FMV support is great. :)

turrican3 13 July 2014 22:56

Hi Toni,
now i have the sound of the videos but not the pitures, the screen stay black !!
demo disc 2.0 quickstart mode cd32+ FMV.
ps: cannonfodder works now perfectly !

Toni Wilen 14 July 2014 08:32


Originally Posted by turrican3 (Post 964159)
Hi Toni,
now i have the sound of the videos but not the pitures, the screen stay black !!
demo disc 2.0 quickstart mode cd32+ FMV.
ps: cannonfodder works now perfectly !

Works for me and that was quite useless report.. (What are "videos"? Where is the log?)

Mad-Matt 14 July 2014 12:05

1 Attachment(s)
I to just get a black screen and just sound when trying to play the mpeg videos (Creation / Killer) on the demo 2 cd. I downloaded a couple of different cd images to try, but still the same.

Cannon Fodder CD working fine and the mpeg Advert on the Dangerous Streets/Wing Commander cd is also working great.

Toni Wilen 14 July 2014 12:18

Your image CUE is different, later tracks have wrong starting point. Video decoder needs header data to initialize correctly, audio does not care.

I think your image is simply bad.


29-022 [0 000=000]:  1:      0 00:02:00 DATA    4          0  648512256
29-022 [0 000=000]:  - image.img
29-023 [0 000=000]:  2:  219280 48:45:55 CDA      0  515746560  648512256
29-023 [0 000=000]:  - image.img
29-023 [0 000=000]:  3:  237832 52:53:07 CDA      0  559380864  648512256
29-024 [0 000=000]:  - image.img
29-024 [0 000=000]:  4:  247147 54:57:22 DATA    4  581289744  648512256
29-025 [0 000=000]:  - image.img
29-025 [0 000=000]:  5:  264630 58:50:30 DATA    4  622409760  648512256
29-026 [0 000=000]:  - image.img
29-026 [0 000=000]:  6:  270254 60:05:29 DATA    4  635637408  648512256
29-027 [0 000=000]:  - image.img
29-027 [0 000=000]:      275728 61:18:28

EDIT: or for some reason cd image support does not parse it correctly. Please attach your .cue.

EDIT2: easy test is to mount it using some virtual CD program instead of UAE built-in.

Mad-Matt 14 July 2014 12:46

2 Attachment(s)
These are the .cue files for two different downloaded images I have.

EDIT: Neither work when using a VirtualCD mount so its safe to say there are some bad rips out there! ;)

Toni Wilen 14 July 2014 12:59

Second cue seems to be same as my version (from eab fileserver). I can't find any other images.

All times are GMT +2. The time now is 16:13.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.07217 seconds with 11 queries