English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   Coders. Releases (http://eab.abime.net/forumdisplay.php?f=115)
-   -   DGen for Classic Amiga WarpOS (http://eab.abime.net/showthread.php?t=95246)

grelbfarlk 25 November 2018 03:28

DGen for Classic Amiga WarpOS
 
1 Attachment(s)
Here's a build of DGen 1.31, a Megadrive/Genesis emulator for WarpOS. Works fine for me but unlike Amidog's better Amigenerator, it supports LE screens, so Sonnetlib folks who only have a Radeon might be in luck.

nexus 25 November 2018 08:17

50fps on harrier @450mhz

grelbfarlk 26 November 2018 02:50

If anyone has the issue where it doesn't seem to be saving whatever Crap TV Mode or Scaler settings, that was because just before I archived it, I added >NIL: to the IconX batch. If you launch from CLI and change your settings, when you exit they will be saved and you can then use the IconX batch again, or remove the >NIL:.

AMike 26 November 2018 20:59

Sadly my 604/366 is to slow - but thanks again for your work.

grelbfarlk 26 November 2018 22:38

Quote:

Originally Posted by AMike (Post 1287355)
Sadly my 604/366 is to slow - but thanks again for your work.


Did you try with launch options -G 320x240? Also change crap TV mode and Scalers to none. Though at that point it's really not much different than AmigeneratorT.exe. Also it uses AHI Unit 0, set that to Paula 8-bit DMA.

Or in dgenautorc, edit these lines:
Code:

ctv_craptv_startup = interlace
scaling_startup = "stretch"
emu_z80_startup = cz80
emu_m68k_startup = musa
bool_sound = true
int_soundrate = 22050

To:
Code:

ctv_craptv_startup =
scaling_startup = ""
emu_z80_startup = cz80
emu_m68k_startup = musa
bool_sound = true
int_soundrate = 11025

Also there's:
key_cpu_toggle = "F11"

If you change that to a key you actually have on your keyboard you can cycle different 68k cores, maybe one of them works better for you.

esel 29 November 2018 16:33

Tryed it on my Killer M1 but it just crashes after startup ( Amigenerator works fine ) do i need more thern 64 MB PPC Ram ?

grelbfarlk 01 December 2018 01:33

1 Attachment(s)
@esel yes it appears to be allocating somewhere around 80 MB of RAM, which is not so much really, I mean the Megadrive had what 128MB? Seriously though, I'm rebuilding with a lot of the extra stuff stripped out, maybe that will help.

For low spec systems, you're probably better off just using the "T" version of Amigenerator which as I recall only needs an 8-bit mode.

The point of this was for Sonnet(or better)+Radeon/Voodoo4 users to have a Genesis emulator that supported LE modes and for some of the fancy scaler/scanline effects.

For LittleWeenie and CSPPC users, try the attached version, lots of fancy stuff removed, perhaps it will work better, it at least uses only about ~20MB.

In the config file dgenrc.auto you can try playing around with these settings:

int_soundrate = 22050
int_soundsegs = 8 16 or 32 will be faster but use more memory
int_soundsamples = 0 (1024 is the default with 0)

And remember to set AHI Unit 0 to Paula 8-bit DMA.

esel 02 December 2018 04:27

Now its working thx !

Hedeon 10 December 2018 13:04

1 Attachment(s)
Quote:

Originally Posted by grelbfarlk (Post 1287102)
Here's a build of DGen 1.31, a Megadrive/Genesis emulator for WarpOS. Works fine for me but unlike Amidog's better Amigenerator, it supports LE screens, so Sonnetlib folks who only have a Radeon might be in luck.

:confused

grelbfarlk 10 December 2018 23:19

Quote:

Originally Posted by Hedeon (Post 1289993)
:confused

:guru


I was going by this thread, they must have updated the Radeon driver?

http://eab.abime.net/showthread.php?...id=4&styleid=1

I only see 8, 15pc, 16pc and 32bpp modes.

Anyway for above wherever I said Radeon, replace with Voodoo 4-that doesn't support BE modes, unless that driver has finally been updated.

amigoun 11 December 2018 00:33

Confusing, I do not see any update on Radeon driver lately. Does BE stuff actualy run or not?

grelbfarlk 11 December 2018 01:52

Quote:

Originally Posted by amigoun (Post 1290116)
Confusing, I do not see any update on Radeon driver lately. Does BE stuff actualy run or not?


Maybe I must have made the same install mistake you did.
Well I don't know, that was one of my little goals here. From what I remember there were a few main applications which required BE modes, Amigenerator and MAME, both of which I have replacements for now, but I guess it was all a big waste if Radeon supports them, I guess for all the Voodoo 4 and 5 users (both of you), could find some slight benefit.

amigoun 11 December 2018 02:32

For me BE was not working on my Radeon (no full screen for FPSE, wrong colors for Amigenerator etc). I even wrote to Elbox if they will implement it in driver, but maybe I had done something wrong during install (previously I had Voodoo3 installed). Would be nice if anyone with Radeon could test these progs to confirm.

BULI 08 July 2019 19:58

This is good emulator (high level compatibility, opposite to AmiGenerator).
DGen for WOS could be litle faster, but I have about above 40FPS on RAGNAROK (sounf 11khz), and Alladin and MK2 works very well - thank you :-)


Quote:

Originally Posted by grelbfarlk (Post 1287102)
Here's a build of DGen 1.31, a Megadrive/Genesis emulator for WarpOS. Works fine for me but unlike Amidog's better Amigenerator, it supports LE screens, so Sonnetlib folks who only have a Radeon might be in luck.


grelbfarlk 11 July 2019 01:53

Quote:

Originally Posted by BULI (Post 1331369)
This is good emulator (high level compatibility, opposite to AmiGenerator).
DGen for WOS could be litle faster, but I have about above 40FPS on RAGNAROK (sounf 11khz), and Alladin and MK2 works very well - thank you :-)


You might find that the small version works a little faster, but you lose some of the advanced scalers. Personally I don't like the scanline emulation, inferior to Amigenerator.


All times are GMT +2. The time now is 01:53.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04687 seconds with 11 queries