English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.ClassicWB (http://eab.abime.net/forumdisplay.php?f=61)
-   -   ClassicWB v28 - Assign-Startup and 2nd partition issue (http://eab.abime.net/showthread.php?t=90504)

Tomarkus 27 January 2018 19:57

ClassicWB v28 - Assign-Startup and 2nd partition issue
 
Hi all,

I'm pulling my hairs off trying to add a couple of drives with games to Assign-Startup and then generate GamesMenu.menu via AddGames script :banghead
Maybe some will be able to help me and point me what I'm doing wrong here. Here are the details:

1. I Have a ClassicWB3.9 (v28) with BB1&2 installed.
2. I have created a couple more PFS3-AIO RDB HDF <4GB drives for demos, games and other stuff:
  • 500 MB - Backup
  • 2000 MB - Programs
  • 3500 MB - Games1
  • 3500 MB - Games2
  • 2000 MB - Demoscene

Partition "Games1" contains "Games" folder with WHDLoad games (A-P folders)
Partition "Games2" contains "WHDLoad/Games" folders with WHDLoad games (Q-Z folders)

My Assign-Startup file looks like this:
Code:

;ClassicWB Assign-Startup
;------------------------
;GAAE 68K LITE FULL ADV ADVSP P96 OS39

Assign >NIL: A-Demos: Demoscene:Demos
Assign >NIL: A-Games: Games1:Games
Assign >NIL: A-Games: Games2:WHDLoad/Games ADD
Assign >NIL: A-MyFiles: SYS:MyFiles
Assign >NIL: A-Programs: SYS:Programs
Assign >NIL: A-Temp: SYS:Temp


After booting up the machine, when I run "assign list", I can see that assign ADD was successful:

Code:

Volumes:
Ram Disk [Mounted]
Demoscene [Mounted]
PC [Mounted]
Games2 [Mounted]
Games1 [Mounted]
Programs [Mounted]
Backup [Mounted]
System [Mounted]

Directories:
MUI            System:System/MUI
AWEB_APL      System:Internet/AWeb_APL
VMEM          System:T
LAUNCH        System:System/BMenu/Files
A-Temp        System:Temp
A-Programs    System:Programs
A-MyFiles      System:MyFiles
A-Games        Games1:Games
            + Games2:WHDLoad/Games
A-Demos        Demoscene:Demos
HELP          System:Locale/Help
            + System:System/MUI/Docs
..
..

Devices:
PIPE VNC VNR RAM CON
RAW SER PAR PRT DH0
DF0 CC0 Backup Programs Games1
Games2 Demoscene PC

Now comes the funny part - when I run AddGames script, it generates ONLY A-P games from the 1st partition - "Games1". When I wrongly (on purpose) modify Assign-Startup like this:

Code:

;ClassicWB Assign-Startup
;------------------------
;GAAE 68K LITE FULL ADV ADVSP P96 OS39

Assign >NIL: A-Demos: Demoscene:Demos
Assign >NIL: A-Games: Games1:Games
Assign >NIL: A-Games: Games2:WHDLoad/Games
Assign >NIL: A-MyFiles: SYS:MyFiles
Assign >NIL: A-Programs: SYS:Programs
Assign >NIL: A-Temp: SYS:Temp

(I'm removing ADD parameter from ASSIGN)

then AddGames script generates Q-Z game paths in the .menu file :guru

I have read all the related posts like:
http://eab.abime.net/showthread.php?t=58692
http://eab.abime.net/showthread.php?t=48711
http://eab.abime.net/showthread.php?t=89543
http://eab.abime.net/showthread.php?t=84032

but I could not find any working solution. Any ideas what I'm doing wrong here? I assume it's a typical PEBCAK - problem exists between chair and keyboard :)

fgh 27 January 2018 21:25

No need to create lots of partitions. The 4GB limit is per drive, not partition.
So only the first partition needs to be within first 4GB.
If you have patched your system so you can use a large drive, you can also use large partitions. (See FAQ in signature)

Tomarkus 27 January 2018 21:37

fgh, thanks for your reply. I've made a mistake here - these are not partitions, but drives - Game1 is a single-partition 3,5GB drive, as well as Games2. I have edited my 1st post accordingly.

merlinkv 17 February 2018 00:25

Anyone knows if a new CW version is expected in the near future? ....


All times are GMT +2. The time now is 22:23.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.06817 seconds with 11 queries