English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   MUI Installation Issue (http://eab.abime.net/showthread.php?t=19317)

AdamSelene 13 July 2005 23:20

MUI Installation Issue
 
Folks, has anyone tried installing MUI v3.8 off of Aminet? (the file is mui38usr.lha)

It's just that I got round to purchasing a keyfile for it the other day, then tried to install MUI on my WinUAE installation and got the following error partway through the installation script:

"Sorry... an error has occurred!

COPYLIB: Can't copy file " " in line 299.
DOS Error Type: Unable to locate a file or drawer."

I took a look at the installation script (Install-MUI) with ED, but my knowledge of install scripts for Amiga is a bit limited, so I couldn't spot any obvious issues.

Anyone got any ideas? Or should I just ask Stefan?

RetroMan 13 July 2005 23:44

Just had a look at the script and it seems to be ok ....

Try this :

Install to RAM: first, copy to HD and set the Assign in your startup-sequence by hand ...

If that doesn´t help, try another INSTALLER in your C: dir (from Aminet) ...

AdamSelene 13 July 2005 23:50

RetroMan: I dl'ed Installer v43.3 from Aminet, and tried it again with the same response, and also tried installing it to RAM: first as well, but to no avail...

Blessed Amiga! Why do you mock me so?! :(

Toni Wilen 14 July 2005 00:12

Unpack the MUI archive inside the emulation.

AdamSelene 14 July 2005 00:19

Toni: That seems to work. Is there a difference in the .lha formats used between PCs and Amigas then? Or am I missing something more obvious?

kuesco 14 July 2005 03:17

Well, just a suggestion.
In the final MUI installation (usually workbench:utilities/mui) you can see a file aprox 8K in size without name, in fact, the real name of that file is just one space without extensions.
The amiga dos can manage this type of names perfectly, but windows can´t.
If i try to copy the file from the amiga "as-is" the pc detects a violation and denys access to disk.
I tried to copy it with amiga explorer over LAN and with floppy disks and none works.
Maybe this is the cause of your trouble, when the mui installer tries to create the file, windows blocks it.
Try to activate UAEDBFS in the uae preferences. (In my pc this don´t help, but give a try). I have encountered no workarounds for this, maybe if you can access a real amiga with mui installed, then you can copy the entire mui drawer (rename the file to SPACE or something first, seems like mui don´t notice the change) and then copy the mui assigns in the user-startup to yours.
If any other user has an idea let us know.

Toni Wilen 14 July 2005 15:47

lha (lzh) format is the same but following things can be lost if you unpack Amiga archives outside emulation:

1: files with "illegal" characters. \*?"<>| are not allowed in Windows filesystems (same "problem" with most Unixes too), also names starting or ending to space/period or filename with single space/period are not allowed. Also includes device names line AUX, CON, PRN, NUL, LPTx, COMx.
2: comments are lost
3: Amiga protection flags are lost

AdamSelene 14 July 2005 21:31

Gotcha Toni, ta for the info. This applies to any .lha files then (insofar as unpacking them in Windows, at least). It's a good job I still have some AFCD's I borrowed from a mate many moons ago (so I could get hold of the LHA command)!

sergius 29 June 2019 23:09

Today I installed a fresh amigaos3.9 with WinUAE into an UAE folder.
I needed to install MUI3.8 and had same issue with line 229.
I installed boingbag 1 and 2 and tried again MUI and it worked fine.

thomas 30 June 2019 00:26

Boingbag 1 fixes UnArc (or rather xadmaster.library). Before that it cannot properly unpack files with space characters in the name.


All times are GMT +2. The time now is 12:24.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04022 seconds with 11 queries