English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.FS-UAE (http://eab.abime.net/forumdisplay.php?f=122)
-   -   FS-UAE 3.0 Stable Series (http://eab.abime.net/showthread.php?t=97818)

tero 07 September 2019 19:14


Originally Posted by Clark Kent (Post 1344223)
At the moment only directories and images could be mounted.

I'm not using real harddisks but the sd card i use in my a1200 can be used with fs-uae. I guess harddisks should work too.

Make sure that fs-uae has the rights to use the device. Maybe start the emulator as root (or as administrator on windows)

EDIT: see this thread:

Clark Kent 08 September 2019 11:39

OK, this seems to be a workaround - but it's not sure that it is always the same disk number. But I would like to see this in the GUI as seen in WinUAE.

FrodeSolheim 13 October 2019 13:32

FS-UAE can mount hard drives on Linux and macOS. It is quite a bit of work to add GUI functionality to lists removable disks and mount them, since this is very different on each OS (and also often requires root access), so that's not on the todo list at the moment.

As for FS-UAE with updated WinUAE core, that is progressing quite well, but somewhat in burts :) I've rewritten quite of bit of the time synchronization code, and I am also working on a new audio/video/input backend (in progress) which is why there hasn't been a new development release yet. But the end result should be a better FS-UAE :) In particular, the new synchronization code makes fastest-possible-mode much more "stable" and performant. (Fastest-possible mode didn't really work at all after the WinUAE 4.x integration before I started on the partial rewrite).

It is possible to try new stuff from the git repo. The new audio/video/input code can be tested with the

command line option (right now, both old and new modes are available in the same binary). The main problem with the new code is that there is no GUI menu at all yet, that's the main remaining thing before doing a new development release.

SaphirJD 15 October 2019 16:48

If latest Winuae changes could be included/made to work, it would be amazing - and FS-UAE would be perfect :)

Pyromania 16 October 2019 03:50

Thanx for all the updates and hard work.

Foul 23 October 2019 21:53

Any news ? new version planed ? :)

FrodeSolheim 05 November 2019 19:57


Originally Posted by Foul (Post 1353683)
Any news ? new version planed ? :)

A 3.0.1 minor update is coming today with a few bug fixes. Dev version is still an on-going project :)

Foul 05 November 2019 20:32

Downloading thx !

FrodeSolheim 05 November 2019 20:34

A new stable version has been released. Changes in FS-UAE 3.0.1:
  • Fix video scaling when restoring from fullscreen on Windows.
Changes in FS-UAE Launcher 3.0.1:
  • Scanner bug prevented Conquests of the Longbow WHDLoad to be recognized.
  • The correct kickstart wasn’t always loaded.
  • Cloanto ROMs were not always decrypted.
  • Fix for global WHDLoad quit key.
I have some issues getting the app to work without warning on macOS 10.15 due to the new security/notarization features on macOS, and absence of useful error messages when stuff don't work. You can right click and choose open to bypass the strict security checks until I've worked this out [EDIT: Looks like it is fixed now -> 3.0.1u1].

FrodeSolheim 05 November 2019 22:59

A new stable version has been released. Changes in FS-UAE Launcher 3.0.2
  • Another fix for global WHDLoad quit key.
  • Fixed a misleading warning when cyberstorm ROM was not found (3.0.1).

Commander711 07 November 2019 14:27

Thx for joining me to this forum :-) i installed version 3.0 and it costs Time to get everything get worked well, so my question is if i install 3.0.2. all my settings before are Lost / gone ?? Cause in Settings Menü and in the setting folder are empty and i cannot save my settings :-(
and i have to deinstall 3.0 Version before installing 3.02 ?

Thx in advance !


FrodeSolheim 07 November 2019 22:32

@Commander711 You can install 3.0.2 over 3.0.0, no need to uninstall anything. No setting should be lost by the upgrade.

MrGimper 08 November 2019 22:43

May be an odd question but is the stable now further ahead than the dev?

lesta_smsc 09 November 2019 00:19

Thank you for the updates Frode! This emulator is providing me and friends with great joy since it has mate netplay a reality!

amigafreak68k 13 November 2019 17:24


Amiga Model Option A4000/OS4 is missing in V3.0.2 for macOS

FN_Amiga 04 January 2020 10:42


is there a date for a new compiles/executeable version of FS-UAE?

FrodeSolheim 04 January 2020 16:55


Originally Posted by FN_Amiga (Post 1369199)
@Frode: is there a date for a new compiles/executeable version of FS-UAE?

I can't really set a date, it's done when it's done, but it's a good idea to create a thread with status / progress. Right now I'm working on updating the input subsystem. The menu subsystem also needs rework for the new version.


Originally Posted by amigafreak68k (Post 1358698)
@Frode Amiga Model Option A4000/OS4 is missing in V3.0.2 for macOS

Hmm, it works fine here (...?)


Originally Posted by MrGimper (Post 1357630)
May be an odd question but is the stable now further ahead than the dev?

Yes, that's because there hasn't been a development release after the previous development series became stable :)

FN_Amiga 06 January 2020 09:17

ok, such a thread would be fine, many thanks...

ItsTheSmell 12 January 2020 08:04

Im running PureOS (debian) and I want to install the update for my already installed version, how do I do it?

qupe 13 January 2020 11:29

Hi Frode,

quick question, I may just be missing something on the website, but is there a way/place to see what new games/game updates are made with database changes?

For Example Jaguar XJ220 is currently on whd 1.7 on the database but 1.8 is out so when it is updated I'd like to know so I can change to the newest version.

All times are GMT +2. The time now is 11:55.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.04892 seconds with 11 queries