English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   Coders. System (http://eab.abime.net/forumdisplay.php?f=113)
-   -   icon.library 46.4 test versions (http://eab.abime.net/showthread.php?t=64079)

AMIGASYSTEM 19 February 2021 19:48

We are in 2021 we have to break with the past, 30 years ago we dreamed of a powerful and modern Amiga, now this can be obtained without spending big money.

Your icon.library has been one of the software contributors to modernity showing beautiful icons even on old Amiga machines :)

PeterK 19 February 2021 20:13

No, for me the Amiga nowadays is just something like a kid's toy of the past for old retro fans, although it once was a useful system in the 1990'th. I can't see any good reason to work with it anymore, and I was never interested in playing games like most other Amiga users. A new OS like 3.2 and better hardware like the Vampire or whatever won't change anything.

AMIGASYSTEM 19 February 2021 21:02

Yes I think like you, to someone who told me to buy the vampire I replied that I am too old for toys.

Amiga today is just a pastime, but having fun is not forbidden, then if something modern comes along welcome.

AMIGASYSTEM 22 February 2021 18:47

Hi Peter at the moment I left the icons like that, also because my AROS x86 Distribution was already ready.

If you have time to waste and on PC you have the VMware Player (free) you can try my AROS One x86


PeterK 23 February 2021 12:53

Your new icons on the Aros One x86 screenshot are looking brilliant, you did a great job Carlo, no doubt about your creativity. :great

Maybe you should build your own iconsets and upload them to Aminet, because I don't like testing huge distros. I've already seen so many but never had any utilization for pre-configured software collections.

AMIGASYSTEM 23 February 2021 15:02

The icons are the same of AROS 68k, however at least for the Folders icons I'll have to add the Glow, there are other users who have reported what you suggested.

The distro is not enerome, all data are unpacked, no need to install, from the ISO you can browse the Internet and use almost all applications, excluding only those that need to write to HD, basically it is a modern OS3.1.

About icons, I don't know if you can help me, AROS x86 refuses to recognize "Disk" icons, it sees them as "Project" icons.

On AROS X86 there are no tools to change the status of the icons, does it automatically, i have done numerous tests but AROS x86 keeps seeing the Disk icons as Project icons.

The original AROS icons are of a strange format !!!

With one of my tricks as you call them, I solved it even if they are shown as folder icons :)

PeterK 23 February 2021 15:37

I've no intentions to play with Aros x86, not even with a Live-CD.

Yes, Aros icons have a strange format, sometimes a mixture of one ColorIcon image and the other one is an OS4 ARGB image. I don't know if the support for PNG icons works better on Aros x86 than on Aros 68k.

Sometimes on Aros the disk icons are not stored as "disk.info" in the root directory but only as ".info" files, for example "DH0:.info". Don't know whether that could happen on Aros x86, too. Ask the Aros developers how disk icons work.

AMIGASYSTEM 23 February 2021 17:22

No on AROS 68k the problem doesn't exist, Disk Icons are seen correctly.

On my Distro there are no volume icons, there are only the ISO icons to use the DVD.

For the installed system the icons are used instead def_.....

I reported the problem on amigalife, I attach links to better understand the problem


AMIGASYSTEM 24 February 2021 17:34

I noticed that the Disk icon of MorphOS is instead supported by AROS x86 :rolleyes

Also I found that IconEditor OS3,9 with your icon.library manages to convert properly to Disk icon, only the graphics get corrupted.

PeterK 25 February 2021 12:38

Won't expect that my icon.library or the OS 3.9 IconEdit are working on MorphOS or Aros x86, but who knows? :confused

So where and how do you get corrupted disk icon images?

IconEdit was always able to change the icon type, and my icon.library changes every wrong type automatically to "Disk" in case that you save an icon as "disk.info" in the root directory of a drive, which is not done by other libraries.

AMIGASYSTEM 25 February 2021 13:19

I am not an expert in this, but AROS handles icons differently, it does it automatically.

Example, if you take an icon Project, Drawer, Tool etc.. if you rename it Disk.info, AROS will convert it to Disk icon automatically.

Also if you give a Project or Tools icon to a folder, the icon will automatically turn into a Folder icon.

AROS unlike Amiga can manage Disk Icons, Anmiga OS in a folder does not see disk icons because they are invisible as files !

Look at the screenshot, here is what happens with an icon converted with IconEdit OS3.9, on the Workbench a grey square, but if I go to icon information the "two" faces of the CD icon are perfect

PeterK 25 February 2021 14:05

Sorry Carlos, but now your description is even more confusing. You are talking about Aros, not saying Aros 68k or Aros x86. I don't care much about Aros 68k and not at all about Aros x86, which is a totally different OS fork.

And there is no Workbench on Aros 68k, just Wanderer or DOpus5. You don't mention which icon.library is installed for your tests.

If your problem is on Aros x86 I can't help you.

AMIGASYSTEM 25 February 2021 19:29

Yes sorry I call it Workbench because a lot of people don't know that Wanderer is more or less the same thing but it couldn't be called Workbench.

No AROS 68k doesn't have that problem, I know you don't care about AROS x86 (too bad), I just wanted to know what kind of Icone are those of AROS x86 and those of MOS, since IconEdit OS3.9 loads them perfectly, the problem is only in saving !

PeterK 25 February 2021 19:47

I've no idea which format Aros x86 and MorphOS icons have, but if you would upload two of them I could check that, or you could ask aunt Google, she is gossip and knows everything!

Found this:


merge icon35 and png icons
png data would live in the IFF stream of the icon35 format (IFF type 'PNG ')
4 color and icon35 image formats would be precomputed by the ilbmtoicon tool
AOS should be able to read and understand this format

Do OS4 and MorphOS use the same type of PNG icons as us, or a different variation? They use the same format (which PowerIcons originated), which is a plain PNG file named "*.info" with some extra PNG hunks in it to hold some icon data. (PNG is like IFF in that way).

Extending the Icon 3.5 to include PNG data, so that (a) our generated ICONs can work on any Amiga system, including OS 1.x to 3.x, and (b) my poor 68000 can choose a planar image from the icon file instead of spending approx 7 seconds per icon converting from ARGB to 4-color planar.

Existing PNG support will *not* be changed - so we should continue to be able to enjoy AmigaOS4 and Morphos icons sets on the faster processors.

png images with special ic0n chunk embedded inside png. can be 1 or 2 png images.

ic0n chunk stores the 'old' data required to fill f.e. a drawerdata structure.

Maybe you have such a merged Aros icon. I've never seen that yet and my icon.library has no support for these merged icons with IFF type PNG.

AMIGASYSTEM 25 February 2021 21:38

Uncle Google is good if he finds a better user than us :D

Here are some AROS and MorphOS icons taken from their original ISO!

In the screenshot with IconEdit of OS 3.9 I loaded an AROS and a MOS icon

PeterK 26 February 2021 18:29

Your Aros icons have one color mapped image (OS 3.5) and one OS4 ARGB image. My library just takes the TrueColor OS4 image and generates a new 2. color mapped image from it with an additional simple glow effect. That's nothing new.

The MorphOS icons are normal PNG icons with one image (as former used by PowerIcons from Elena Novaretti). My library generates a second image here again. These PNG icons don't have this strange merged format as it was explained above, no IFF type PNG chunk, that's not the problem.

I have no problems using these icons for disks, for example copying them with DOpus4 to DF0:disk.info and then reload the disk. Icon=>Information never worked reliable for me, mostly just crashes WinUAE and sometimes even Windows. I've downloaded the latest nightly Aros 68k build, and that has a bug (Enforcer hit) in the Aros Rom now. Aros is the perfect system to run away ...

What are you doing with these icons? How do you get the gray disk icons?

Maybe that gray is the erased background, but the TrueColor image is not updated? Do you get the image when you switch "Wanderer as background" off and on again in the menu?

AMIGASYSTEM 28 February 2021 11:53


Originally Posted by PeterK (Post 1465476)
to run away ...

What are you doing with these icons? How do you get the gray disk icons?

If you're referring to the attached grey icons, i didn't create them, they are the original ones from the Nightly Builds, i don't use them.

Regarding the coloring of PNG icons developer miker1264 is making significant progress, his icons are compatible with all Amiga OS

If you want to see the screenshots you have to login

PeterK 28 February 2021 14:06

4 Attachment(s)
Carlo, I'm talking about the gray disk icon on your screenshot: http://eab.abime.net/attachment.php?...3&d=1614255581

I've tried the disk.info and several deficons from the ArmHF-System now, but everything loads without problems here on my Aros 68k system, all are Aros icons (mixed OS3.5 + OS4 ARGB images).

Edit: If you use the 3.9 IconEdit to change the type of an Aros icon to "Disk" then IconEdit will, of course, convert that into a pure OS 3.5 color mapped icon, no ARGB TrueColor image remains. Maybe Aros x86 cannot display OS 3.5 icons for disks? I don't know. But on your screenshot with the gray square Icon Information still shows a TrueColor CD image, that can't be the result from saving with the 3.9 IconEdit. So, what are you really doing Carlo?

No, I don't want to create an account and login at amigalife.org. Copy and upload the screenshot if you think that's important.

My screenshots are from Wanderer on Aros 68k, the last one was made after saving with IconEdit.

AMIGASYSTEM 28 February 2021 19:24


Maybe Aros x86 cannot display OS 3.5 icons for disks?

Yes right, grey icon only for Disk.info, but only from Wanderer, which then strangely always from Wanderer if you do icon information is seen well, even other applications such as Dopus4 on AROS x86 sees well the icon disk 3.5.

AROS x86 basically sees just about any OS3, OS4.1 or MOS icon except the OS 3.5/3.9 disk icon.


My screenshots are from Wanderer on Aros 68k, the last one was made after saving with IconEdit.
As I had mentioned even I on AROS One 68k have no problem.

For the screenshots on Amiga ae.amigalife I will see if I can attach the images here

PeterK 28 February 2021 21:13


Originally Posted by AMIGASYSTEM (Post 1466081)
As I had mentioned even I on AROS One 68k have no problem.

Correct, but you also said this:

Also I found that IconEditor OS3,9 with your icon.library manages to convert properly to Disk icon, only the graphics get corrupted.
That statement was a bit confusing, because the converted icons are not corrupted, they are OS 3.5 ColorIcons. I had to check whether there was something wrong with them.

All times are GMT +2. The time now is 11:54.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.32165 seconds with 11 queries