English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Games (http://eab.abime.net/forumdisplay.php?f=6)
-   -   Some WHDLoad games won't run (http://eab.abime.net/showthread.php?t=6326)

alkis21 10 September 2002 09:26

Some WHDLoad games won't run
 
I'm having problems with a few games I downloaded from http://www.gandimann.de/Gandimann/hauptframe.htm
When I launch:

P.O.W.
Plan 9 from Outer Space
Rocker Ranger

I get the message:
Error during 'resload_kick' - invalid kickstart image

and Aladdin works ok until I try to start the game, in which case I get

Function 'resload_Decrunch' has failed to decrunch data

I have an A1200 with 10MB RAM and the latest WHDLoad version, unregistered (although these files are using their own version).
Help please?

Akira 10 September 2002 10:00

For the "Error during 'resload_kick' - invalid kickstart image" error, you need to have a KS1.3 kickstart image in your DEVS:Kickstarts directory... You can download what you need from TomTom's

I get the same error with Aladdin, and I'd also like to know how the heck to fix it :)

alkis21 10 September 2002 10:10

I'm pretty sure I have it there as I use it for TUDE, does it need to have a specific name maybe?

Akira 10 September 2002 10:25

Yes.
kick34005.a500

Have you got the .PAT and .RTB files too? TUDE doesnt need them(skick does) so perhaps you dont have them.

Codetapper 10 September 2002 11:45

resload_Decrunch error
 
Both the original and the Prodigy crack of the game work perfectly in WinUAE with WHDLoad 15. I am guessing you are using another cracked version which has had some files tampered with to crack it.

You can try adding the FILELOG command to the tooltypes and re-run the game. When it quits you will have .whdl_filelog which contains the CRC's of all the files loaded and you can see which one is faulty.

On another sidenote, there was a bug in the WHDLoad versions from about 10 to 13 which made RNC1 files decrunch incorrectly. If you have the latest version they should work fine however.

alkis21 10 September 2002 12:22

Thans for the advice guys, I'll let you know.

Akira 10 September 2002 19:37

I didnt try Aladdin with the latest WHDLoad, will have to do that!
I dloaded it from TomTom's, dunno if he used a pirate image or an original.

alkis21 11 September 2002 23:20

Two out of four
 
Akira, Aladdin works fine now! I downloaded the wdhload installer and tried it with the cracked version I have, no problems.
I also replaced the three files you guys told me. Plan 9 from Outer Space works now, but the other two gave me an even more mysterious message:

Function 'resload_Patch' called with unacceptable arguments
PC=$9FF722 (Slave $14A).


Any ideas?

Codetapper 12 September 2002 23:01

Unsupported version
 
That error means that the register a1 at the time of calling the WHDLoad function contains an incorrect value. Either it's a bug in the slave or more likely it's a hacked/unsupported version which has the patch in the wrong place.

Often a game was re-released on budget and the disk image is different, even by only a few bytes offset (so a patch at say $1000 should now be at $1002) and that makes the difference between a slave working and crashing.

I would contact CFou and ask him to look at it as he did the Plan 9 patch and he uses lots of cracks to make his slaves. Just tell him your version of the game (I'm guessing it ain't the original!)

alkis21 13 September 2002 09:13

I don't know if the files were compiled using the original disks, as I downloaded them from TomTom's.

Antiriad 16 September 2002 23:09

Hello all, Im wondering whether i have an supported version of IM2025. The whdload install didnt take all the files of my two floppies - only the ones in the root of each disk. The files within the "IM5data" directory weren't taken across.
Now i have a hacked copy as well as the original and in this case the dir is called "IM12data" but still, thats ones a hack - but it could be of a more common veriosn of the game.

I copied the files over from my normal (original) hard drive installation, but got the following after i input the copy protection number and press enter after the language selection screen.

Exception "Access Fault" ($4008)
PC = $6BEFDABC (ExpMem $8DABC)
Byte Read from $4EB96BF7

NOCACHE and NoAutovec made no difference, NoMMU caused
Error in OS emualtion module
subsystem: dos.library
error number: $FFFFFF70=-144

But thats my fault as i ignored the message as my 060 card uses a MMU. :)
And novbrmove caused a reboot! But again my fault as my VBR is in the Fast RAM :D

It is referenceing the same Kick40068.A1200.RTB file and Kick40068.A1200 ROM like Rise Of The Robots, Pirates Gold CD32 and Frontier - Elite 2 do - which all work.

Ive written to JFF in the meantime, but i've uploaded it in the Zone for others to try out, if anyone could have a go on a REAL Amiga and post here what happens, it would be muchos muchos appreciated!

Antiriad 18 September 2002 23:40

Update: Reason it doesnt work is that i have the obscure ECS version of the game and the install is for the more widely known AGA version.

As such JFF author of the install will write an amended install to support this version. As such, keep all files in the data directory as these are from the originals and will work when the install is released.

On a even happier note, i was informed that the Hoodlum crack of IM2025 AGA works fine with this install! As such, tis workin now!

Akira 19 September 2002 01:14

I had that IM2025 ECS too.. bastard wouldnt run from disks! I had to install it in my A600's HD.
Did you try doing this? the proggy comes with an installer

Antiriad 19 September 2002 01:45

Hmm, never tried off floppy. I installed it immediately on my hard drive as i found it only recently. Ill give a stab Akira.

Akira 19 September 2002 02:12

try instaling it using the game's own installer, instead of WHDLoadizing. See if it works!

Antiriad 19 September 2002 17:00

Hmm, did a new fresh install..yes it doesnt work when you click on impmiss!

Seems I amended the original install as it pointed the two assigns to a /impmiss directory where it should have been DH1:Impmiss instead.

Silly wankers obviously couldnt write a decent install...

oldpx 20 September 2002 01:52

Here is the problem I'm having wit Black Crypt ATM.

Exception "Access Fault" ($7008)
PC = $794D668C (ExpMem $3568C)
locked Long Write to $FFFFFFFF

I was not using the latest install and it wasn't working now I installed the latest Whd version of the game with the same disk images yet it crashes the same way. Are my disk images faulty?

Antiriad 20 September 2002 02:02

Hmmm Burseg, did you get Black Crypt from BTTR? I think thats where i got mine and ive got no probs with it

oldpx 20 September 2002 02:04

Nope, mine was a strange lzx archive, with whdload executable included and all. I'll check bttr now. thanks.

edit: yes yes I see mine was the BTTR version. Too bad I have no way to transfer it to my Amiga ATM :/


All times are GMT +2. The time now is 02:43.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04306 seconds with 11 queries