English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.ClassicWB (http://eab.abime.net/forumdisplay.php?f=61)
-   -   WHDLoad demos/games do not work on SFS; FFS is OK (http://eab.abime.net/showthread.php?t=46525)

Lurbi 02 August 2009 21:56

WHDLoad demos/games do not work on SFS; FFS is OK
 
Hello all

I have just noted another veeeery strange phenomenon.

I have an a1200 with 8MB fastram, and a 8GB CF card.

I have partitioned it with a 1GB FFS partition and the rest is a big SFS partition.
I have patched scsi.device to support big HDDs.

In the other thread you can read that I need to reboot to get into classicWB. (after first boot I am at the insert disk screen, after amiga-amiga-ctrl classicWB boots up fine (also on all subsequent reboots)

Now I copied some demos to the FFS partition.
Everything works perfectly.

I copied over the demos to the SFS partition.
Shortly after starting them, I get errors. (Exception illegal instruction, error during resload_relocate, exception line 1111 emulator $2c ....)

When I copy the file over to FFS it works without problems.
(so the data on SFS was unaltered)

Any idea what I could do??
At the moment the whole 7GB SFS partition is unusable for WHDload :((

Lurbi 02 August 2009 23:47

Update:

I use NSDPatch now, and the coldstart problem has disappeared.

I have now a 1GB FFS Partition and a 1GB SFS Partition at the beginning of my 8GB CF card. (to rule out 4GB issues)

I run the demo (eg. 9 fingers) from FFS ... all is fine.
Copy over to SFS ... when I run it, I see the first picture, after some seconds the picture gets garbled, after some additional seconds I get an error exception illegal instruction.

If I copy the demo from sfs back to FFS than it runs again fine (no data corruption)

I guess others do not see these problems with whdload on SFS?? correct??

Wepl 03 August 2009 00:06

what is Mask and MaxTransfer of both partitions in hdtoolbox?

Lurbi 03 August 2009 00:39

Quote:

Originally Posted by Wepl (Post 579807)
what is Mask and MaxTransfer of both partitions in hdtoolbox?

> maxtransfer is 0x00ffffff
> mask and maxtransfer I did allways leave at the default.

and it seems that was the fault ...
it seems to work with maxtransfer 0x0001fffe

thanx

Lurbi 03 August 2009 00:50

OK

What I ended up using:
NSDPatch instead of patched scsi.device (never tried IDEFix97)
FFS from AmigaOS3.5

I created a biiiiig FFS partition, and it seems to work.

Regarding WHDLoad:
Blocksize of 2k makes my demos crash.
SFS makes my demos crash.

Using NSDPatch and FFS with 512 bytes blocksize seems to have fixed my problems!!

Thanx for your help.
Any further comments are welcome (I am pretty new to amiga ...)

Edit: Small addition:
It seems NSDpatch works only so well, because my CF card is 8GB.
Internal IDE-SCSI device seems to have a 8GB limit ... but I do not hit it, because my HDD is not bigger than 8GB.
For larger HDDs IDEFix can be used! (it replaces the scsi.device instead of patching it.


All times are GMT +2. The time now is 15:16.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.03917 seconds with 11 queries