English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Amix (http://eab.abime.net/forumdisplay.php?f=125)
-   -   Using tape with Amix (http://eab.abime.net/showthread.php?t=79779)

Amiga_CDTV 22 September 2015 19:44

Using tape with Amix
1 Attachment(s)
Cartridge tape drive: Amiga UNIX is distributed on a QIC-150 format tape cartridge. Device drivers are included which access the A3070 tape drive. There is no standard software interface to SCSI tape drives, so only certain types can be used with Amiga UNIX. The Caliper, Sankyo, and Wangtek brands of SCSI QIC-150 tape drives are known to work. The tape drive must be set to SCSI address 4. - Amix Version 2.0 Addendum.

"Using Amiga Unix" mentions tape only shortly on "Backing up your files" (p. 232-235), here are the examples:

Backing up files to tape: find /home/joe -depth -print | cpio -ocv -O > /dev/rmt/4

List the contents of your backup: cpio -ictv < /dev/rmt/4

Restore files: cpio -imdcuv -B < /dev/rmt/4

Other Amix tape commands: mt retension (re-tensions the tape by fast forwarding and rewinding it) and mt rewind (rewinds the tape).

Zeroing out the tape (for 2.1 installation): dd if=/dev/zero of=/dev/rmt/4hn bs=32k
Zeroing out the tape (for other versions): dd if=/dev/zero of=/dev/rmt/4n bs=32k
(Source, see also: http://amix.failsure.net/tiki-index....=tape+creation)

My short story on the topic: I bought a Wangtek 5150 ES from eBay to try it out on my 3000T. Beware: Wangtek pinch rollers are known to go goo, don't ask how I know :mad I had looked inside the drive and the roller looked just fine, but when I tested the drive with a tape, the roller went liquid and made a mess. "Fortunately" only the tape was messed beyond repair, there was surprisingly little mess in the drive itself and it was cleanable.

A friend of mine who restores pinch rollers for audio gear restored the roller and now the drive is working again. I have yet tested the drive only shortly on my 3000T (mainly in Workbench using Diavolo Backup) and it worked like a charm. Soon I was copying "several megabytes of data in just minutes" (not to mention how noisy it is ;)) In my even shorter test in Amix the drive works; retension and rewind worked and I was able to write data into the tape using the commands above. However I accidentally started backing up a directory of tens of megabytes and had to interrupt it (would have taken too long). Now it says it detects an EOF-mark and refuses to write over it (I guess I should now zero it first?).

For reference; another QIC- drive I tried (a Tandberg TDC4120, only "a bit" newer QIC-1000 drive) did not work in Amix at all (device not ready or present etc) so it is indeed picky. And yes, it was properly terminated and set to ID 4.

What I am hoping to achieve is of course being able to make physical copies of the installation tape and run the whole install from it for total authenticity :D

In the photo attached, the drive is mounted into an external SCSI-case. Probably the way I am going to keep it for easy usage between machines.

Please share your Amix-tape insights here.
:spin:spin <- spinning like a tape ;)

Amiga_CDTV 18 February 2016 19:51

1 Attachment(s)
... I managed to get an NFS share mounted on my 3000T and started figuring out how to create a new Amix install tape. Finally I got the script running and it seemed to start doing it's job, didn't let it finish yet as it seems to take "some" time to write the whole tape.

Here is a quick sketch-print of my re-created tape label (based on pics in here and elsewhere) for the hopefully soon-made tape :)

scuzz 21 February 2016 15:15


The tape drive is like the holy grail from me in terms of getting my A3000UX machine running again. I have all the various other components. Very interested in your post.





Amiga_CDTV 22 February 2016 19:04

A quick update... I let the script run all the way thrue, and it finished Ok. It also verified Ok (with the another script from the amix.failsure- site). Looks good :) I didn't try installing it, but at least the amixpkg -package manager seemed to accept it.

I zeroed the tape, then wrote the contents and then verified; all these steps took about half an hour each ;)

mousehouse 26 January 2020 16:10


I know this is an old thread but it's the most relevant one I could find... I'm rebuilding an A3000UX and I'm struggling with creating an installation tape. I'm trying to create the tape using another Amiga, I do not have access to an AMIX or UNIX machine with SCSI.

I'd love to re-create the tape and floppy labels as well, does anybody have print files somewhere that I could use?

Is there a mirror of failsure.net around? OK, after some Googling found the sad reason why.

Has anybody succeeded in creating the tape on an Amiga?


Amiga_CDTV 26 January 2020 17:34

most of the stuff from failsure.net should be in https://www.amigaunix.com/. I haven't gone thrue all the old text and checked that every file is there, but let me know if you find any errors.

I used the instructions there and the script did run Ok (as I wrote above) but I don't think I ever returned to test it (ie. to do a full install from the re-created tape). I probably still have the tape somewhere, but I am in a middle of a house move at the moment so I can't get it checked right now.

I added my old re-creations of the floppy and tape labels (see the end of the page): https://www.amigaunix.com/doku.php/tape-creation.

mark_k 26 January 2020 18:00


Originally Posted by mousehouse (Post 1374496)
Has anybody succeeded in creating the tape on an Amiga?

First, make sure you have a known-working tape drive and tape.

You should be able to recreate the tape from within AmigaOS, accessing the tape drive via a handler like BTNtape or tape-handler. (There are other tape handlers, search Aminet.)

I read the files from my original AMIX tape that way. I don't remember which handler I used though.

mousehouse 26 January 2020 23:08

The drive is working fine on my 3000T which I'm using to create the tape. I've worked through with BTNtape but I found it confusing as to how to transfer the files (00, 01, ...) to the tape. First I used "tar" to put the files on the tape - but I do not know if that worked. I did try to use that one but got all errors and assumed it was the tape. However, it might be the same error I'm having now.

But now I've done a "copy #? to tape:APP", which took half a day because I forgot to add the no-rewind option to the mount list entry.

Anyway, I cannot get it to install just yet - and therefore do not know if the tape is setup correctly.

I have two SCSI IDs in the machine on a SCSI2SD card. SCSI ID 0 is my Amiga 2.0 install. SCSI ID 1 is for AMIX (13GB but I only define a few small partitions at the start). After booting AMIX (which will not load the root fs floppy if Kickstart 2 is loaded in memory for some reason) and setting up the partitions it will start reading the tape and complain about not enough filesystem space or lack of inodes. Even though it just did a newfs / makefs or whatever goes on ...

Any tips?


mousehouse 27 January 2020 11:52

Update... I got it to install! The issue is with the physical disk size being too large. I reprogrammed the SCSI2SD to a disk size of 1GB for ID 1. It then formats without issues and is now installing from tape.

For anybody out there that wants to create their AMIX tape on an Amiga... take a day off as it is all slow as ****.

- Install and configure BTNtape3 from Aminet
- Download the tape archive 1 and 2 from amigaunix.com and put all the files 00, 01, 02, ... in a directory
- Copy the files starting with 00 to the tape (copy #? tape:app)

mark_k 27 January 2020 14:47

Be careful that the files are copied to tape in the correct order if you use Copy #?. The Copy command will copy them in the order they're listed in the directory, it doesn't sort names first. It would be safer to do somthing like Copy 00 01 02 03 04 05 06 ... TAPE:APP

All times are GMT +2. The time now is 03:09.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04224 seconds with 11 queries