English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Games (http://eab.abime.net/forumdisplay.php?f=6)
-   -   Graphics Corruptions (http://eab.abime.net/showthread.php?t=70253)

Macca 01 August 2013 22:42

Graphics Corruptions
 
Hi,

Not sure where to post this as I'm not sure whether it's a problem with WinUAE or whether it's something else.

I've got ClassicWB (latest ADV pack) with ClassicWB configuration file being used (except for the hard-drive and ROM file).

I'm using WHDLoad 17.0 and noticing graphics corruptions in lots of games:

Eye of the Beholder (straight away - a right mess)
Turrican 2 (again straight away - the game is unplayable)

I can put up screenshots later but does anyone have any ideas on how to fix it?



M.

Retro-Nerd 02 August 2013 00:06

First you should try WHDLoad 17.1 since 17.0 had some timing issues. And try also the latest WinUAE beta too.

Macca 02 August 2013 10:33

Hi

I've updated to WHDLoad 17.1 and that made no difference. I'm sure it's probably a setting in WinUAE as I vaguely recall changing something on an older version that worked.

I can't see any beta versions of WinUAE on there website (they mention WIP 2.7 but can't see any where to download it).

So I've tried v2.5, v2.6 and 2.6.1 and I'm going to try some older versions but nothing seems to work yet.

Image below (it actually looks worse than this in action but I hope you get the idea).

http://s21.postimg.org/8gn3y6jz7/image.jpg

Toni Wilen 02 August 2013 10:51

JIT enabled? JIT is not very game compatible option.

Macca 02 August 2013 10:51

Right more weird info. If I go back to 2.4 then Turrican 2 is fine. But I loose the ability to resize the window.

However Eye of the Beholder actually then fails to do anything. On some occasions I get:

Exception "Privilege Violation" ($20)
at $10FB28F6 (Task 'input.device', ExpMem $8F6) occurred.

The music also sounds funny on launch. Both games 'work' on the latest version of WinUAE but then I get graphics corruptions so it suggests something is up with the emulator rather than the games.

Macca 02 August 2013 10:54

JIT was enabled. This has now fixed running Turrican 2 on the latest emulator! Weird thing is now Eye of the Beholder fails to display anything - going to re-download it and try again!



M.

Edit: 10 points to Toni :)

Macca 02 August 2013 11:02

Eye of the Beholder is buggered but apart from that it seems fine. It's not a major thing but if anyone has any ideas on how to get it working it would be nice to have a stable emulator where everything works!

Currently when running EotB I get a black screen with music playing. It doesn't seem to respond to Esc / Mouse Buttons / etc.


M.

Macca 02 August 2013 11:19

I take it back - It Came From The Desert also has graphic corruptions :(

Not doing to well - fix one and break some others! :D



M.

Toni Wilen 02 August 2013 11:25

It is usually perfectly normal without disabling fastest possible CPU and possibly enabling immediate blitter. Newer WinUAE versions have timing improvements in fastest possible CPU modes that breaks games that appeared to work previously.

Macca 02 August 2013 11:52

Changing it to 'Approximate A500/A1200 or cycle exact' and then 'Cycle Exact' seems to have fixed it. With Immediate Blitter it made It Came from the Desert run too quickly.

It's now working slowly but fine.

Thanks for your help!



M.

Retro-Nerd 02 August 2013 16:12

Another game would be Disposable Hero WHDLoad. It has freezes/micro stutters in scrolling. If you disable Chipset -> cycle exact it (while still set to cycle exact A500/1200 in emulation speed) runs smooth again. Though no problems if you use an A600 configuration for WHDLoad. Latest WinUAE Beta, as always.


All times are GMT +2. The time now is 18:26.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04133 seconds with 11 queries