English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   OS 3.5 icons on 3.1 & WHDLoad hangs when displaying icons (http://eab.abime.net/showthread.php?t=65713)

PoulpSquad 05 September 2012 17:56

OS 3.5 icons on 3.1 & WHDLoad hangs when displaying icons

I'm trying to build the most lightweight, fast and bloat-free Workbench 3.1 I can capable of running WHDLoad slaves and showing those nifty OS 3.5/GlowIcons/NewIcons/WhateverIcons.

After some keyboard melting Googling for a way to do this, I frankensteined myself a standard WB 3.1 install with icon.library, workbench.library and SetPatch from OS 3.5 and newicon.library from OS 3.9.

Everything seemed to work fine at first glance, but sometimes slave installs hang when they try to show the icon selection window. The window doesn't display, install freezes, and the whole system falls in coma.

No error messages, no gurus, WinUAE runs great. Menus "work" (I can click on them, they show their usual stuff, but nothing works, e.g. "cleanup" does nothing etc.).

I'm pretty sure it's not WinUAE-related, and has to do with those libraries I added.

What means do I have to show WHDLoad icons on WB 3.1, without installing half of Aminet archives (MWB, MUI, Scalos, GlowIcons, NewIcons, ClassAct, etc...)?

Thanks in advance for any help :)

PeterK 06 September 2012 00:10

Did you install the latest icon.library v46.4.256 from Aminet ?
You could also try the new concept of my of my IconDemoADF.rar which uses LoadResident instead of SetPatch v44. Of course, you can replace the supplied OS 3.0 files in that package with those from OS 3.1.


Unfortunately, I can not help you with WHDLoad, because I never play any games.

Just tried DeluxePacMan and WHDLoad 17.1 with AmiKit 1.6.2b and with the original icon.library 45.1: WHDLoad throws thousands of Enforcer hits there, so it seems to be buggy !! Is there a newer version already?

PoulpSquad 06 September 2012 00:44

Thanks a bunch for your reply, I'll make sure to check this out!

I don't think there is any newer version than 17.1...


Your library works great, it's just what I was looking for... and it's quite fast too! I tried it with Amiga Forever, which normally goes as fast as an anemic snail on my PC, and suddenly it's become usable. Great job!

It didn't solve my WHDLoad icons' problem nevertheless. I can reproduce the failure at least, it happens when I install 3 slaves in a row, attack sub 688, A10 tank killer and AGE.

AGE installer hangs just when it tries to show its icons. Somehow I suspected it might be a problem with the RAM disk, so I decided to change T: assign in startup-sequence and have it on hard disk.

I proceeded to reproduce the hang but this time around it was gone... What might be the relation between icons and RAM disk?? :scratches head:

Jeopardy time:

Question 1: Is there some replacement RAM disk I could try?

Question 2: Does it sound like a good idea to have a hardfile in RDB mode on a Windows RAM disk and have Workbench use that instead of its natural RAM disk?

Question 3: Is there any way to disable the RAM disk, now useless if I'm using an "external" RAM disk of sorts?

PeterK 10 September 2012 11:26

Sorry for my late reply PoulpSquad, I didn't notice that you have updated your last posting here.

As I already said above, I never play any games and I have no knowledge or experience with WHDLoad. So please tell me exactly what I have to install and to try out on WinUAE to reproduce your problem with these slaves and their icons.

Concerning your question 1.) There is the Amber Ram Disk as a possible replacement which I use myself on my WinUAE system.
2.) Don't know, never tried that?
3.) Do it the same way as AmberRAM uninstalls the RAM Disk.

PoulpSquad 10 September 2012 12:36

No problem, I'm glad you had time to answer

I'm aware you stated you don't play games, my edit was addressed to whoever can/wants/could/would help me out ^^

Reproducing the problem requires a standard Workbench 3.1 install, WHDLoad 17.1, and a couple of games. I can consistently make it fail with 3 of them, 688 attack sub, A10 tank killer and AGE (from CAPS). AGE hangs 100% of the time at the icons selection screen for me.

I experimented those past days with Amiga Forever, and icons seem to work, but now I get random crashes during slaves installs. WinUAE logs show some DMA related stuff I've never seen before. It's maybe related to this http://eab.abime.net/showpost.php?p=...&postcount=199?

I'll give it another go with AmberRAM and report back, thanks for your advice!

PeterK 10 September 2012 14:17

Why do you need the Ram Disk for WHDLoad ? The games in AmiKit or ClassicWB are started from normal HD drawers, not from RAM:. What do you mean with icon selection screen ? Can you make a screenshot. Sorry for my stupid questions.

PoulpSquad 10 September 2012 19:02

1 Attachment(s)
It seems installs of games copy a bunch of icons in T: and open a window for the user to choose one. It happens Workbench assigns T: on RAM Disk by default.

Removing the assign in Startup-Sequence and having T: on hard disk instead of RAM disk works great, I didn't have a problem.

I attached a screenshot that shows the icons selection window from Shufflepuck Cafe (installers won't show this window if 3.5 icons aren't supported).


Now going back to WB I can't open T on RAM disk. I can't even select it. Strange thing is that I could before launching this installer :scratches head:

PeterK 10 September 2012 21:33

Ok, I tried to install the loader for Shufflepuck Cafe on AmiKit. I extracted the lha into RAM: and also set the destination for the game to RAM:. The window with the 3 icons appeared and I tried out all of them. After doing that the WHDLoad splash screen came up telling me that this is not a registered copy of WHDLoad 17.1 and then a DOS error 205 followed saying that there is no slave file. Of course not, because I don't have one, but nothing went wrong so far, no freezes, no crashes, no Enforcer hits until this point.

Are you using StackAttack or MinStack to increase the stack size to at least 8000 bytes ? Ok, works even without increased stack here.

Do you use the latest icon.library 46.4.256 ?
When exactly is it freezing or crashing ? When you just click once on one of the icons is it changing to the selected image ?
When you doubleclick an icon does the WHDLoad slashscreen appear or does even the copying of the slave begin to start ?

Update: I've also tried A10TankKillerHD and 688 Attack Sub now, but again no problems here on AmiKit. Yes I know, that's OS 3.9, of course. Where can I download the WHDLoad AGE installer ?

PoulpSquad 10 September 2012 22:35

Crash conditions:

- Install Workbench 3.1
- Copy icon.library, workbench.library, newicon.library and setpatch from WB 3.9
- Install WHDLoad 17.1
- Install those 3 games, in same session (no reset or exit WinUAE): 688 Attack Sub, A10 Tank Killer and AGE.

AGE installer hangs when it tries to show icon selection window. It opens the window, but no icons are shown. Can't close it, can't exit installer, Workbench menus are dead.

Installing 688 attack sub and A10, resetting, and then installing AGE works fine.

I used Shufflepuck to take the screenshot to show you what I meant by "icon selection window". Shufflepuck works fine here. I forgot registration is required to play it, sorry about that...

I didn't try icon.library 46.4.256 yet, I'll try that in a moment and report back.

What I don't get is the relationship between RAM disk and icons. When I remove assigns in startup-sequence and have T: on hard disk (instead of RAM disk) everything works great. WHDLoad installers unpack their icons in T: on hard disk and they're quite happy.

PeterK 10 September 2012 22:45

The relationship between RAM: or T: and the crashing icons could be simply the fact that WHDLOad is trashing the memory, as I already mentioned in my first post. But trashing memory can also mean that it is trashing the Ram Disk or T: because the RAM: filesystem is based on the system memory unlike that of any harddisk. You could try MemTrailer 96, although I don't have much hope that this would fix the crashes, since it could not avoid the Enforcer hits here.

Better send a bugreport to the author of WHDLoad and tell him he should check his program with Enforcer and SegTracker.

PoulpSquad 10 September 2012 23:04

1 Attachment(s)
Just tried with icon.library 46.4.256, and I can't reproduce any weird behavior now, except for an error 205 on ram disk when I try to snapshot window content.

I'll stop bugging you and try some installers tonight, just to make sure.

PeterK 10 September 2012 23:38

Remove AmberRAM or read the docs again.

PoulpSquad 11 September 2012 00:26

I didn't have it installed. I did everything on a clean, base install of Workbench 3.1 with icon.library 46.4.256 + workbench.library, newicon.library and setpatch from Workbench 3.9.

PeterK 11 September 2012 22:54

What did you try to copy to RAM: when that error 205 came up ?
Use the Installer in Expert-Mode and let it create a log file. Check that for errors. Or use Scout or SnoopDos to get more information about what goes wrong. What does a simple Assign command say about the Ram Disk: ?

Are there still freezes or crashes with AGE or not anymore ?

PoulpSquad 11 September 2012 23:41

I wasn't copying anything at all, I just did a snapshot all.

As for AGE, it doesn't crash if I use Workbench 3.9 files and your icon.library. I guess it's a compatibility problem between workbench.library from 3.5 and Workbench 3.1.

With standard WB 3.5 files I can reproduce the crash 100% of the time... I'm dropping this idea of mine to use WB 3.1 as base with 3.5 libraries, and use Amiga Forever instead.

I'll try this SnoopDOS thing later on and report back

PeterK 11 September 2012 23:46

Which tool for the snapshot ? Is it reproducible ?
Is the AGE installer working now ?

PoulpSquad 11 September 2012 23:54

No special tool, just Snapshot all command from Workbench menu

AGE installer works with WB 3.9 libraries.

PeterK 12 September 2012 00:01

OOPPS ! I was thinking about a screenshot tool.... I should read better ;)
But I will try out to make a snapshot on ClassicWB.

Update; ok, I've just tried to snapshot the Ram Disk window with a few icons on my IconDemoADF installation and didn't have any problems or DOS error here. Cleanup by name, Resize to fit and Snapshot all, all that works here under OS 3.0.

Update: Do you have a dos.library replacement installed ?

PoulpSquad 13 September 2012 01:28

No, only standard WB 3.1 with a bunch of libraries from 3.5 (workbench.library, icon.library and setpatch).

I get the same symptoms using icon.library 46.4.256 with LoadResident, so I believe workbench.library is the problem, or maybe setpatch.

With 3.9 libs it works fine (That's all about the Ram Disk, AGE installer is still stubborn with OS 3.9 files)

Did you use workbench.library 3.5 or 3.9 in your demo disk?

PeterK 13 September 2012 21:55

The IconDemoADF uses wblib 45.131, modified for OS 3.0.

What is your wblib version ? I've tried 44.1479 and 44.1559 without problems.
Which WinUAE version do you use ?
Is your RAM:disk.info a softlink ?

All times are GMT +2. The time now is 14:52.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04704 seconds with 11 queries