English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   FFPlay: Command too long (http://eab.abime.net/showthread.php?t=89550)

AMIGASYSTEM 21 November 2017 14:53

NetSurf: FFPlay Command too long
 
If with NetSurf i try to run a Link video YouTube, i get the message "FFPlay: Command too long" what could you do to solve it?. Arti he advised me to update the Shell KingCON, but my system already has KingCON 1.8 installed :confused

AMIGASYSTEM 22 November 2017 01:19

If you do not understand well attached screenshot exhaustive

Romanujan 22 November 2017 11:22

Which OS version? If I remember correctly, OS 3.1 has some serious command line length limitations. You need to have OS 3.9 shell... better yet - use this: http://aminet.net/package/util/boot/ShellUpdate

AMIGASYSTEM 22 November 2017 14:13

Thank you for your reply, the problem is present on all my OS: AFA_OS, Amikit, AmigaSYS, OS3.9 RTG, all updated with BB1/BB2/BB3/BB4. I know well "ShellUpdate" some time ago I also found a bug that the author has solved, you can read HERE

emufan 22 November 2017 17:45

is there a script with that ffplay command, called by netsurf, which you can edit?

AMIGASYSTEM 22 November 2017 22:59

No, there are no scripts, with snoopdos stops on this (see screnshot)

emufan 22 November 2017 23:14

thats for sure, more than 255 chars for the command line (255 is OS limit?)
use another search engine , www.startpage.com does not have those long redirector links

AMIGASYSTEM 23 November 2017 00:01

Arti he told me to update "KingCON" because it works for him!, he suggested setting the value 700 at command "WBNameLength", but WBNameLength who can not accept more than 250 :sad

emufan 23 November 2017 01:18

hmm, I'm not sure WBNameLength will help with the command line length.

not sure what to do about that issue :/

#1) if the error comes from ffplay, you may look for another version, ask Arti which version he is using.

AMIGASYSTEM 23 November 2017 01:23

Yes I had tried WBNameLength maximum parameter 250 :crying

AMIGASYSTEM 23 November 2017 01:29

Quote:

Originally Posted by emufan (Post 1201491)
#1) if the error comes from ffplay, you may look for another version, ask Arti which version he is using.


All previous versions work but used a different way, see video:
https://youtu.be/tmcWjt75wcg


The new version work Direct streaming of youtube video:
https://youtu.be/Mvnsolxuh4o

emufan 23 November 2017 01:47

so in new version ffplay is build into netsurf?

the ffplay error, is it with the very long google address or with standard youtube links too?

AMIGASYSTEM 23 November 2017 08:38

Version of NetSurf for Amiga Standard he used already FFPlay (see my first video). The versioni Vampire he used RiVA because FFPLay required FPU

AMIGASYSTEM 23 November 2017 18:42

Today i tried to shorten the link (with tinyurl.com) and run FFPlay it from a shell that worked (video MP4 HQ 904x720), maybe to use with a nice GUI, i'm not a programmer :sad


https://youtu.be/yO_NufrJbRQ

emufan 24 November 2017 12:03

hmm, some solution would be an addon/plugin to netsurf,
which would rewrite the URLs of the current webpage , shorten them.

some kind of local proxy software, kind of squid.
ok, this doesnt help at the moment, no amiga version, and a bit of overhead.

maybe arti will take a look at that issue and will find a fix.

meanwhile I only can advice not to use google, use some different search engine,
or use YT homepage as a starting point.
which all should give shorter links.

AMIGASYSTEM 24 November 2017 21:49

Thank you emufan for the precious information, Regarding the GUI, if I can serve someone, I found it in the GuUi4Cli package, a nice GUI that lets you run a bit of everything, see video.


GUI Play Link Video With NetSurf and WGet Download Archive:
https://youtu.be/b2cOyIFq3t8

emufan 24 November 2017 23:17

np. the Gui4CLI tool is really nice. a cool example is the mpegagui on aminet.
but it is a lot of work to write the code for such a gui :)

AMIGASYSTEM 25 November 2017 08:50

On Aminet there is as well Argue similar program to GUI4Cli

AMIGASYSTEM 08 December 2017 01:06

Released New NetSurf 03.12.2017 in the review reports:

- Added YouTube streaming of 3gp files though ffplay (needs to be in C: and CLI must support long names).

Someone knows how to expand it CLI for support long names !!! (see comments made above)

AMIGASYSTEM 16 December 2017 17:18

Quote:

Originally Posted by AMIGASYSTEM (Post 1204626)
- Added YouTube streaming of 3gp files though ffplay (needs to be in C: and CLI must support long names).

Nobody knows how to get support long name :spin


All times are GMT +2. The time now is 20:53.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04466 seconds with 11 queries