English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   How to use pcmcia with 8mb fast ram on a1200? (http://eab.abime.net/showthread.php?t=99216)

liquidsmoke 16 October 2019 03:35

How to use pcmcia with 8mb fast ram on a1200?
as far as im aware on an amiga 1200, 8mb fast ram will shut down access to the pcmcia port (specifically for using compact flash)

once i move the jumpers on my expansion board to 8mb (its set at 4mb currently) i still will need to be able to use the pcmcia compact flash to transfer stuff from pc to amiga

how can i do this?

ptyerman 16 October 2019 06:44

The only way you can do that is by installing and using a 3.0 kickstart ROM. 3.1 introduced the PCMCIA limits with memory, with 3.0 you can use the whole memory space.

solarmon 16 October 2019 07:49

Follow these guides:



EDIT: These guides are only on how the get CF working in the PCMCIA slot when assuming there is no conflict with Fast RAM memory addresses.

Jope 16 October 2019 10:12

There is a patched card.resource floating around that you can loadmodule..


solarmon 16 October 2019 11:12


Originally Posted by Jope (Post 1351753)
There is a patched card.resource floating around that you can loadmodule..


Wait, you mean you can get the PCMCIA slot to work with 8MB Fast RAM for ANY memory expansion card?

liquidsmoke 16 October 2019 11:42

yeah id like to know if that plays nice with any 8mb expansion. mines a very old marpet one. (similar to the amitek hawk)

also i dont fully understand that loadmodule comment about if its already present in startup-sequence.

ive already got loadmodule for scsi.device, so what would the loadmodule line look like??

Jope 16 October 2019 12:37

I don't see why it would care what memory expansion you have occupying the Z2 address space.

The only thing you need to take care about is, don't plug in any PCMCIA memory cards.. Only IO devices are compatible, such as ethernet or memory card adapers.

solarmon 16 October 2019 13:01

I'll definitely have to try it out!

I've been hearing, and I've been telling people, that there is an issue with 8MB Fast RAM and PCMCIA on the A1200/A600

This solution/workaround came out in 2017 and this is the first I'm hearing about it.

liquidsmoke 16 October 2019 13:19

is that for a 3.0 rom or 3.1?

Daedalus 16 October 2019 13:32

It's for a 3.1 ROM - the 3.0 ROM doesn't have the check that disables the slot, so it can be used without the patch.

solarmon 16 October 2019 13:33


Originally Posted by liquidsmoke (Post 1351800)
is that for a 3.0 rom or 3.1?

Good question that I'd like to ask and know too. I've only got 3.0.

This article suggests there card.resource versions are different between 3.0 and 3.1:



card.resource          37.11    40.4

solarmon 16 October 2019 13:37


Originally Posted by Daedalus (Post 1351804)
It's for a 3.1 ROM - the 3.0 ROM doesn't have the check that disables the slot, so it can be used without the patch.

Wait, are you saying there is no 8MB Fast RAM and PCMCIA slot issue on 3.0 ROM?

I've never tried using the CF in the PCMCIA slot on my A1200 with 3.0 ROM in 8MB mode because I thought there would be an issue.

Daedalus 16 October 2019 13:48

The "issue" is that the slot was primarily designed for SRAM memory cards that were mapped straight into the Amiga's address space, either as fast RAM or as storage. Unfortunately this space coincides with the upper 4MB of Zorro-II space, meaning only one can be used at a time. With versions of Kickstart up to 3.0, no checks were done, and so inserting an SRAM card with 8MB of fast RAM fitted resulted in a conflict and instant crashes, refusal to boot etc.

This wasn't an issue prior to Kickstart 3.0, since 8MB of fast RAM wasn't doable in an A600 at the time. But it turned out to be an issue in the A1200, with its expansion slot designed for easily adding 8MB RAM cards. To prevent the clash, a check for this issue was added to Kickstart 3.1, which disables the PCMCIA port when 8MB of Zorro-II RAM is detected.

This solved the clash, meaning no crashes or failure to boot when a card was inserted. It wasn't until later on that I/O-only cards like CF card readers and network cards became a thing, and people realised that the 3.1 fix also prevented the use of cards that didn't need the Zorro-II space.

solarmon 16 October 2019 14:06

Thanks for the background information and clarification. I was always under the (incorrect) understanding that it was an issue with anything/everything in the PCMCIA slot.

Having looked at the memory map again, it does clearly state PCMCIA memory cards. I just read/understood it wrong. Maybe it is worth adding a note about I/O cards and differences between 3.0 and 3.1 ROMs?

So, in summary, for the A1200:

3.0 ROM + 8MB Fast RAM + PCMCIA/CF = OK
3.1 ROM + patch + 8MB Fast RAM + PCMCIA/CF = OK

are they correct statements?

Daedalus 16 October 2019 14:53

Yep, that's it. Chances are that if you're using 3.0 or 3.1 ROM, you're already patching it for things like scsi.device updates, so adding the PCMCIA patch shouldn't make a difference in use.

ItsTheSmell 16 October 2019 15:20

Right now I'm using 3.1.4 ROMs with an amitek board set to 8mb. My WB is pretty much vanilla. If I leave the pcmcia cf reader in it boots to the purple wb screen, if I remove the cf reader and reboot it boots to WB Then I can add the cf reader and so far its problem free. Its never gone over 4mb of ram though. I'm no expert BTW, this is just my experience.

liquidsmoke 16 October 2019 16:03

luckily ive got some 3.0 roms aswell i can fit.

so i can choose what to do now, without any fear of my 8mb messing up things.

also means i can get the amiga kit ethernet pcmcia card, and not have to keep unplugging my cf card.

very interesting information from everyone. thanks.

solarmon 16 October 2019 22:05

So I tried it on my A1200 rev 2B with Kickstart 3.0 ROMs and an ram expansion module from https://www.arananet.net: in 8MB mode:


I'm using ClassicWB and it comes with LoadModule already loading the scsi.device:


However, when I boot up with the CF in the PCMCIA slot, I get this LoadModule error:


If I put in the CF after Workbench has loaded, the CF disk icon initially appears but them the A1200 hangs, resets and throws a Guru:


Am I doing something wrong, or should be doing something?

The CF works fine with the memory expansion module in 4MB mode.

liquidsmoke 16 October 2019 23:19

i looked at the website where you bought the 8mb ram

he says this

Update 17/06/2019: There was a bug on the firmware using the 5.5MB version that could make conflict with the clockport or part of the SlowRam. The bug was identified by the user Monideth Pen.
New firmware offer 4MB/8MB and does not make conflict with the clockport or the slowram. The firmware for this version of the board can be located here. https://github.com/arananet/tf328/tree/edu1200_board

have you updated the firmware on your card solarmon?

not sure if that bug would cause a software failure, but any bug has the potential to i guess

also i think theres a newer version of loadmodule on aminet. maybe that will work better if you add the reverse statement to the end of the line.
eg. c:loadmodule devs:scsi.device reverse

solarmon 16 October 2019 23:40

That issue was to do with a conflict with the memory address space used for Slow Ram, which was out of range.

I have already updated mine with the firmware that disables the Slow Ram.

(And I was the user that reported that issue! :great)

All times are GMT +2. The time now is 21:38.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04725 seconds with 11 queries