English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Strange harddrive corruption (http://eab.abime.net/showthread.php?t=99649)

MickGyver 13 November 2019 22:34

Strange harddrive corruption
 
I have been having problems with WinUAE lately. It seems the files on harddrives (hdf and virtual directories) somehow get corrupted and I get all kind of weird errors (crashing programs etc.) The only thing I can then do is create a new harddrive and install everything again. Any ideas what could be causing this, am I doing something I shouldn't?

I have tried reinstalling WinUAE, have tried both the 32 and 64 bit versions with similar problems.

This problem is a bit generic since I can pinpoint when the "corruption" happens but I'm grateful for any insight!

DamienD 13 November 2019 22:46

Some questions MickGyver that may assist us with helping you ;)
  • What type of HDF i.e. RDB mode or not?
  • What type of file system i.e. OFS / FFS / PFS3AIO?
  • What OS is installed i.e. 1.3 / 2 / 3.1 / 3.5 / 3.9 / 4?
  • When do you notice the corruption occurring e.g. copying files?

MickGyver 13 November 2019 22:54

Quote:

Originally Posted by DamienD (Post 1358805)
Some questions MickGyver that may assist us with helping you ;)
  • What type of HDF i.e. RDB mode or not?
  • What type of file system i.e. OFS / FFS / PFS3AIO?
  • What OS is installed i.e. 1.3 / 2 / 3.1 / 3.5 / 3.9 / 4?
  • When do you notice the corruption occurring e.g. copying files?

Cheers!
  • I use the ClassicWB v28 Full HDF, haven't used RDB mode.
  • File system is the one used by the ClassicWB hdf image, I'm not sure which one it is.
  • I use WB3.1 floppies to upgrade ClassicWB to 3.1.
  • The corruption (if it is that) "just happens". Earlier today I was using Blitz Basic 2 in WinUAE without problems. I closed WinUAE and now this evening Blitz Basic 2 does not start properly any more, I get a software failure after the nag screen. I tried reinstalling Blitz Basic 2 but get a software failure in the middle of the install.

DamienD 13 November 2019 22:57

Thanks for the information ;)

I'm also not using RDB mode .HDFs. Classic WB file system is FFS.

I also use Classic WB Lite 3.1 and have never experienced the issues you describe.

Mind you, I've never used / installed Blitz Basic 2 but this stuff shouldn't occur.

Does the corruption only happen with this app? Do you have enough RAM set?

Have you tried running SnoopDos before starting Blitz Basic 2 to see if anything strange is captured?

jotd 14 November 2019 00:00

I already had this issue. Executable file corrupted (and guru) when running the program. The executable file was AGSMenu (amiga games menu). Never had this issue with some other program.

MickGyver 14 November 2019 08:49

Quote:

Originally Posted by DamienD (Post 1358814)
Thanks for the information ;)

I'm also not using RDB mode .HDFs. Classic WB file system is FFS.

I also use Classic WB Lite 3.1 and have never experienced the issues you describe.

Mind you, I've never used / installed Blitz Basic 2 but this stuff shouldn't occur.

Does the corruption only happen with this app? Do you have enough RAM set?

Have you tried running SnoopDos before starting Blitz Basic 2 to see if anything strange is captured?

Can't say I have seen it happen to another program, but I mainly use Blitz Basic 2 in this configuration. I will try SnoopDos to see if it catches anything strange, thanks for the tip!

Quote:

Originally Posted by jotd (Post 1358832)
I already had this issue. Executable file corrupted (and guru) when running the program. The executable file was AGSMenu (amiga games menu). Never had this issue with some other program.

The weirdest thing (at least for me), is that the program can't be reinstalled without guruing. Have you been able to get AGSMenu to work again on the same hdf or virtual drive after the corruption?

MickGyver 14 November 2019 09:49

This is what I get when I start SnoopDos and then open windows in WB and start Blitz Basic 2.

Code:

Count Process Name      Action    Target Name                Options Res.
----- ------------      ------    -----------                ------- ----
1    [7] Scalos_Window_ ChangeDir  SYS:                                   
2    ramlib            Load      Scalos:Plugins/OOP/filetype        OK 
3    ramlib            Open      env:scalos/FileTypes.prefs  Read    OK 
4    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
5    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
6    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
7    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
8    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
9    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
10    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
11    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
12    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
13    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
14    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
15    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
16    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
17    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
18    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
19    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
20    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
21    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
22    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
23    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
24    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
25    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
26    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
27    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
28    [1] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
29    [1] Scalos_Window_ ChangeDir  System:                               
30    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
31    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
32    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
33    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
34    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
35    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
36    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
37    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
38    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
39    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
40    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
41    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
42    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
43    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
44    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
45    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
46    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
47    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
48    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
49    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
50    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
51    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
52    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
53    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
54    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
55    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
56    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
57    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
58    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
59    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
60    [5] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
61    [5] Scalos_Window_ ChangeDir  System:Programs                       
62    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
63    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
64    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
65    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
66    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
67    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
68    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
69    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
70    [8] Scalos_Window_ Open      acidlibs                    Read    OK 
71    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
72    [8] Scalos_Window_ Open      defaultdbug                Read    OK 
73    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
74    [8] Scalos_Window_ Open      deflibs                    Read    OK 
75    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
76    [8] Scalos_Window_ Open      help                        Read    OK 
77    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
78    [8] Scalos_Window_ Open      help.dat                    Read    OK 
79    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
80    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
81    [8] Scalos_Window_ Open      acidlibs_backup            Read    OK 
82    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
83    [8] Scalos_Window_ Open      ted_lib.fd                  Read    OK 
84    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
85    [8] Scalos_Window_ Open      ted.doc                    Read    OK 
86    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
87    [8] Scalos_Window_ ToolType  DEFAULTIMAGE                        Fail
88    [8] Scalos_Window_ ChangeDir  System:Programs/Blitz2                 
89    [8] Scalos_Window_ ChangeDir  System:Programs/Blitz2                 
90    WBL                ChangeDir  System:Programs/Blitz2                 
91    WBL                Load      Blitz2                              OK 
92    WBL                ChangeDir  System:Programs/Blitz2                 
93    WBL                ChangeDir  SYS:                                   
94    Blitz2            ChangeDir  System:Programs/Blitz2                 
95    Blitz2            Open      Blitz2.info                Read    OK 
96    Blitz2            Load      blitz2:ted                          OK 
97    ramlib            Load      LIBS:asl.library                    OK 
98    ramlib            Load      DEVS:clipboard.device              OK 
99    Blitz2            Open      CLIPS:0                    Read    Fail
100  ramlib            Load      LIBS:ted.library                    OK 
101  Blitz2            Open      ENV:ted.prefs              Read    Fail
102  Blitz2            Open      ENV:Ted.history            Read    OK 
103  Blitz2            Open      ENV:Ted.menus              Read    OK 
104  Blitz2            LockScreen Workbench                          OK 
105  Blitz2            LockScreen Workbench                          OK 
106  Blitz2            ChangeDir  System:Programs/Blitz2                 
107  Blitz2            Open      blitz2:acidlibs            Read    OK 
108  Blitz2            Open      blitz2:deflibs              Read    OK 
109  Blitz2            Load      blitz2:defaultdbug                  OK 
110  [8] BMX            Open      CON:20/20/500/50/ButtonMenu Write  OK 
111  [8] BMX            Open      Utils                      Read    OK 
112  [9] WBRun          ChangeDir  System:Utilities                       
113  [9] WBRun          ToolType  CLI                                Fail
114  [9] WBRun          ToolType  TOOLPRI                            Fail
115  [9] WBRun          ChangeDir  System:System/BMenu                   
116  [9] WBRun          ChangeDir  System:Utilities                       
117  [9] WBRun          Load      SnoopDos                            OK 
118  SnoopDos          ChangeDir  System:Utilities                       
119  [9] WBRun          ChangeDir  System:System/BMenu                   
120  SnoopDos          ChangeDir  System:Utilities                       
121  SnoopDos          ToolType  Settings                            Fail
122  SnoopDos          ToolType  Language                            Fail
123  SnoopDos          ToolType  PatchRamLib                        Fail
124  SnoopDos          ChangeDir  System:Utilities


rutra80 14 November 2019 14:00

I'd rather look for compatibility problems like wrong UAE config, disk larger than supported by system, some installed hack, etc. And I'd rather debug with something like Enforcer/Mungwall to detect memory corruptions.

Or maybe something on PC side is corrupting HDF? Bad RAM?

Toni Wilen 14 November 2019 21:03

It probably isn't Amiga-side problem if directory harddrive contents are also getting corrupted, almost all data structures are in PC-side memory only, inaccessible from Amiga side.

Only possible exception is some program doing something weird and modifying other files.

jotd 14 November 2019 23:25

Note: After installing AGS again, everything worked fine again. dir structure wasn't corrupted. Maybe it's an AGS-only issue for me. This program is strange and has bugs, like images stopping being displayed on FFS, but okay on PFS...

MickGyver 02 December 2019 16:38

Thank you for the help everybody! The problem was actually only related to Blitz Basic 2 after all (my fault). I have an installer script and another script that process the Blitz Basic libraries. I had other files than libraries in the Blitz library folder and this caused crashes for both Blitz Basic and the scripts. Depending on the extra files I got various errors, that's why I mistook it for some kind of corruption.


All times are GMT +2. The time now is 18:31.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04356 seconds with 11 queries