English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.FS-UAE (http://eab.abime.net/forumdisplay.php?f=122)
-   -   FS-UAE 3.0 Stable Series (http://eab.abime.net/showthread.php?t=97818)

Gardhul 21 January 2020 10:21

Quote:

Originally Posted by qupe (Post 1371263)
Hi Frode,

quick question, I may just be missing something on the website, but is there a way/place to see what new games/game updates are made with database changes?

For Example Jaguar XJ220 is currently on whd 1.7 on the database but 1.8 is out so when it is updated I'd like to know so I can change to the newest version.

I would like that too...

FrodeSolheim 12 February 2020 18:36

As promised, I've done a write-up of what's going on with FS-UAE development -> here https://eab.abime.net/showthread.php?t=100873 :)

FrodeSolheim 09 March 2020 22:11

A new stable version has been released. Changes in FS-UAE Launcher 3.0.3:
  • Fixed crash when starting the Launcher in a KDE environment.

(Update only relevant for Linux)

qupe 10 March 2020 14:42

Quote:

Originally Posted by FrodeSolheim (Post 1384120)
A new stable version has been released. Changes in FS-UAE Launcher 3.0.3:
  • Fixed crash when starting the Launcher in a KDE environment.

Still shows 3.02 on the site?1?

FrodeSolheim 10 March 2020 14:43

Quote:

Originally Posted by qupe (Post 1384284)
Still shows 3.02 on the site?1?

True, I didn't create releases for Windows / macOS (none needed). If you go to the Linux downloads you'll see 3.0.3 there. I've added a note to the previous post.

qupe 10 March 2020 15:35

Quote:

Originally Posted by FrodeSolheim (Post 1384285)
True, I didn't create releases for Windows / macOS (none needed). If you go to the Linux downloads you'll see 3.0.3 there. I've added a note to the previous post.

No worries thanks FrodeSolheim

Foul 24 April 2020 13:34

little update : 3.0.4 : what's new ? :)

FrodeSolheim 24 April 2020 14:24

Relatively minor stuff :) (Will probably be an 3.0.5 soon, must just fix some stuff due to notarization changes by Apple - AGAIN).

FS-UAE
--------
Version 3.0.4:

* Fix compilation of sana2.cpp with GCC 10.
* Fix OpenGL shaders with multiple passes on macOS.
* Include compilation fix for "unknown" CPUs architectures.
* Updated the GLAD OpenGL loader.


Launcher
-----------
Version 3.0.5:

* Workaround for old file database entries with incorrect \ escape.

Version 3.0.4:

* Filename escaping for FS-UAE and .uaem comments when using .lha files as HDs.
* Fixed bug in escaping of \ in archive.py.

qupe 04 May 2020 22:22

Hi FrodeSolheim, can I download 3.02 portable from anywhere? I'm having issues with 3.05 as mentioned below at the minute and 3.02 was stable for me, I haven't tried 3.03 or 3.04.

FrodeSolheim 04 May 2020 22:36

Yes, you can go back in time here: https://fs-uae.net/files/stable/3.0.2/

(Ignore 3.0.3 and 3.0.4; they were not full releases, and not released for Windows for example)
(Will look at reported issue later)

qupe 04 May 2020 22:48

Many thanks.

Edit: My own whdload configs work again :)

Foul 23 May 2020 20:11

Any news concerning the next big version ? I am impatient ;)

qupe 05 June 2020 14:26

Didn't know where to post this but I am having to configure a lot of the WHDLOAD games, which is no problem, but the 2 player simultaneous games (that I have tested so far) are set to joystick and mouse.

Not sure if it's deliberate or not, but like I said 90% of my pack is now self configured as FSUAE is very simple to set up :)

Foul 28 August 2020 10:31

yesterday, fs-uae update to FS-UAE 3.1.0dev but got some requester error @ start :

https://i12.servimg.com/u/f12/16/40/49/27/screen41.png

Must ignore all to get the fs-uae windows...
edit : the icon in my start menu has disappeared

MrDBUG 07 September 2020 04:23

Had problems with the dev version on Linux, updated the launcher but not the rest to 3.1 or summin.
EDIT: Right now I got a similar error message as Foul ! But on Linux Mint 19.3

FrodeSolheim 13 September 2020 22:05

"3.1.0dev" (which isn't the an actual release / done yet) was accidentally "released" via Ubuntu PPA for a couple of older Ubuntu releases :nuts

I recommend downgrading to 3.0.x via the stable series, not sure if I'm going to add a fake 3.1.0dev2 (which is 3.0.x) to PPA in order to fix this, perhaps better to just focus on getting the real 3.1.0dev (and call it 3.1.1dev) out...


All times are GMT +2. The time now is 10:53.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.05258 seconds with 11 queries