English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   New to Emulation or Amiga scene (http://eab.abime.net/forumdisplay.php?f=26)
-   -   A600 update! - more help required.... (http://eab.abime.net/showthread.php?t=67244)

foob 03 January 2013 18:30

A600 update! - more help required....
Progress Update Time!

So, today i received a package int he post from the very kind Roy, containing the new WB disks and backups of them, and the CF boot disk Akira provided (and a backup of that also). Along with this, i also got my dry disk drive cleaner. This is what happened...

Firstly i popped the disk cleaner in, this didnt do much atll (i suspect its because theres no program forcing the disk drive to read from the disk (even though its not a data disk, just a brush).

Then, i tried the first WB disk from Roy, it came up with block read error so i replaced it with the backup and finally ive been able to get into workbench. First thing i did was copy this disk to one of converted 1.44MB, which now seems to work fine. However, at this point, i'm trusting Roys disks more than this a600, and im starting to think i may have a faulty drive rather than every single one of my disks are bit-rotten. Anyway, at least for now, i have WB up and running so EasyADF should no longer be an issue (although i havent tried it yet, reason incoming.)

The second thing i tried after creating the WB backups of my own, is putting in the CF card into the PCMCIA reader and trying to boot from that as per Akira's helpful instructions (and bootdisk). The disk itself seemed to work fine, but i get an error saying that there is no device in CF0, when there is. I've just double checked that its still set up OK as it still boots in winUAE perfectly fine, and the only thing i can think of that may or may not an issue is that i had to use kickstart .175(2.04) to install on the CF, as its the only ROM i had available other than 1.3.

EDIT:- Adding exact error message from A600 - "No disk present in device CF0". have photo if it helps (but i doubt it)

So, at this point, im stuck again.... but still making progress. Any ideas on what to do next?

For those new to my plight, this thread is a continuation from http://eab.abime.net/showthread.php?t=67176 - a brie fsummary of what has happend from the beginning follows ;-

1) purchase used a600, came with kick 32.299 and no WB disks.
2) have PCMCIA CF adapter and 4G CF card, purchased with EasyADF software from amigakit.
3) Suggested that its possible to install WB to CF and boot from PCMCIA. installed WB to CF using winUAE but only had 2,04 ROM available. Booting WB from PCMCIA is my goal, not to install a CF hard drive at all.
4) CF card boots fine in WinUAE.
5) see above.

Arnie 03 January 2013 18:33

Try booting from EasyADF

foob 03 January 2013 18:43

Just done that, getting the same error. I also formatted the disk completely and just stuck a couple of ADFs on there (formatted with fat32 @ 4GB) and its still saying "no disk present in CF0".

I'm starting to get the feeling this CF card is an incompatible one. Its a KIngston 4GB, can take photo if required.

Arnie 03 January 2013 19:15

The one I got from Amigakit with EastADF was a 4gb Sandisk Ultra 30mb/s. I've never formatted it and it works fine.

It could be the 37.299 kickstart as suggested before??

jimbob 03 January 2013 23:59

You can't boot directly from a FAT95 formatted CF card. I believe the CF0: device can only boot from an amiga formatted disk. You need some minimal boot floppy which loads the drivers for using compactflash.device and the FAT95 filesystem. I think this is what Akira has provided you with.

So insert Fat95 CF with workbench installed on it, (via WinUAE), into PCMCIA, but boot from Akiras floppy which I think is set up to switch over to the CF to load WB once the drivers are loaded.

foob 04 January 2013 00:52

this is exactly what i have done, when booting from the floppy, it says there is no disk in CF0.

i have ordered a transcend 133x CF card from amazon so hopefully that will do the trick. i don't really know what to do at this point so im just guessing.

prowler 04 January 2013 01:01


Originally Posted by foob (Post 859377)
I'm starting to get the feeling this CF card is an incompatible one. Its a KIngston 4GB, can take photo if required.

You may well be right about that. :agree

Kingstons are good cards, but not always compatible with the Amiga's PCMCIA port. Oddly, the card's memory capacity seems to be an important factor.

jimbob 04 January 2013 01:15

My mistake, I was thinking of CC0: which is the built in device for PCMCIA cards. It can only use amiga formatted disks and can't boot CF cards at all I think.

If you now have standard workbench floppy, then you can attempt to mount the CF card without booting from it. A600 display the 'no disk present' error when manually mounting a FAT95 CF, and then after some delay, the drive appears, maybe this delay could cause a problem when it happens in the startup sequence, as I assume it must using Akiras boot disk.

Does anything happen if you just wait a few seconds and cancel the "no disk" dialog?

foob 04 January 2013 02:41

i'm just going to give it a quick try now and see what gives.

As far as the CF card is concerned... i can't remember where i read it but i i know ive seen somewhere that some CF cards don't work because they are incapable of running at a low enough speed for the amiga to interpret, so you have to purposefully buy a brand that can handle these lower speeds. I remember seeing the trancend x133's as a compatible brand so i got one of those. will be a few days before i get it though, obviously.

anyway, regarding mounting manually..... how? i assume from the CLI but i even don't relaly know how to get that up. i'm just re-installing WB on the CF now via winUAE so i can try,

EDIT: just tried again and pressed cancel, didnt work. Comes up with message "Can;t find cf0:devs; assign failed returncode 20"

jimbob 04 January 2013 04:47

I don't know if Roys WB disk includes the CF reading software but you can find out by trying this. With the PCMCIA adaptor and CF inserted, boot from the WB floppy, open a CLI and enter

mount CF0:
cd CF0:

If it is a standard WB this won't work because it doesn't have the CF reading software. But, Akiras boot disk must have it so you can make a WB copy and add the required stuff from there.

First make a copy of the WB disk. Then you need to make some space on it, you can delete all the stuff in utilities drawer for a start. I'm not 100% how much space you need. Then from memory, so please someone correct if wrong, copy from Akiras disk the files

compactflash.device to your devs: drawer
fat95 to your l: drawer

For WB2, I think you also need to edit the mountlist file. This is in the devs: drawer. You need to add an entry to it which tells AmigaDOS how to use the CF0: with Fat95. To edit the file, at a CLI, type

ed devs:mountlist

to open the file in a simple text editor.


Check out post 28 in this thread to see the entry you need to add to the mountlist. You need to add the line


Followed by all the lines in the code box for CF0 mountlist in that post. Save and reboot using your new WB floppy. Open CLI and again enter

mount CF0:

If nothing appears to happen try

cd CF0:

(sometimes the drive won't mount until you try to access it)

If still nothing happens, take a break and wait for your new CF card to arrive. Then start again. Try not to get too pissed off, this chicken and egg problem of getting software from PC to Amiga afflicts everyone returning to Amiga but you only have to get through it once and then pretty much all amiga software ever is at your fingertips.

amigakit.com 05 January 2013 15:05

Kingston 4GB will never work with the Amiga's PCMCIA card slot.

That is why we offer tested, compatible CF cards with our EasyADF Transfer Kit here:


hansel75 05 January 2013 15:19

I'm not sure if this is of any use, but if your trying to boot WB from a pcmcia card, this might help-


I used to use this floppy boot disk method before i got my ide setup and it worked fine, Ppil made up this boot disk for this purpose and the link to it is still valid, the file is called comfy_a600.zip, just look towards the bottom of the page where Ppil last posted.


foob 08 January 2013 15:28

just a tiny update for the moment.... my transcend branded card just arrived! im gonna try this again now and see if i get anyway, await for more info!

foob 08 January 2013 16:07

OK, so now ive had a chance to try it... this is what happened.

Installed WB via winUAE and tried it in winuae first, booted fine. Then tried it on the amiga with akiras bootdisk, i now get the error "Disk in CF0 is not a DOS disk".

so then i wiped the CF card, stuck a bunch of .adfs on there and booted into WB via EasyADF. This time, the CF card is recognised, but EasyADF is not recognising any files on the disk, it just says its empty.

I have to admit, my patience is starting to wear thin with this thing.

demolition 08 January 2013 16:13

I'm a little unsure whether you're trying to boot from the CF card in the PCMCIA slot, which afaik is not possible.

When you say that you wiped the CF card, do you mean format with FAT32 in Windows?

foob 08 January 2013 16:32

The card has been formatted in FAT32 in windows.

I am indeed trying to boot from the CF card in PCMCIA, with the use of a boot floppy provided by Akira on here. i have been told multiple times that this is infact possible.

demolition 08 January 2013 16:35

Well, then you're booting from the floppy disk which will load the CF and FAT drivers and the continue the boot from the CF card. That should be possible. :-)

foob 08 January 2013 16:42

And this is where i am stuck. When trying to boot using the floppy, i get an error message saying the disk in CF0 is not a DOS disk. i am unsure what to do from here or why this could be happening.

demolition 08 January 2013 16:48

I could try out the boot disk later tonight to see how it works in my Amigas.

Akira 08 January 2013 17:20

Did you try formatting as FAT instead of FAT32? although I don't think it should be a problem.
I can;t help as all my cards are smaller than 4GB and work fine. Also I am using an SD card reader and not CF.

Just make sure you aren't formatting the CF card in WinUAE, as I said, never format.

All times are GMT +2. The time now is 05:42.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04710 seconds with 11 queries