English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Diablo Porting On WinUAE (http://eab.abime.net/showthread.php?t=98629)

AMIGASYSTEM 30 August 2019 15:17

Diablo Porting On WinUAE
 
Hi Toni I'm testing Devilution X (porting Diablo) on WinUAE finding some oddities maybe because of the porting still not perfect.

I noticed that it only works with WinUAE v3.6.1 and WinUAE v4.0.0 but it happens that without changing anything then no longer works even on these versions, then maybe I try again later and it works again.

The Devilution X 040/060 are the versions that work, 060 only on WinUAE v3.6.1

Functional version The Devilution Build #256 (27-ago-2019 13.58.40)
(Next version 29-8-2019 generates RAM error)


Attached Log and Config UAE of WinUAE 4.2.0

Porting Devilution X:
https://jenkins.amigadev.com/job/Dev...nX/job/master/


Working Video Test: https://drive.google.com/open?id=1Jq...eJotZaqgpF3pJ9

Toni Wilen 31 August 2019 09:55

Hmm.. Too many unknown variables.

Did you make sure AmigaOS stack is large enough?
Did you really only change CPU model and everything else was 100% identical?

Your log shows weird file errors..

H=FFFFFFFF TYPE=ffffffff ERR=00000002 'C:\Users\Win7\Desktop\Share\Diablo\data\Diablo1RestrictedTest.foo'
FILESYS: 'data\Diablo1RestrictedTest.foo' illegal filename

2 = ERROR_FILE_NOT_FOUND. I have no idea what is going on here.. (I don't see any illegal win32 paths or characters, unless there is also _UAEFSDB.___ with mismatched contents)

AMIGASYSTEM 31 August 2019 10:03

Tones on the systems I use the Stack is automatic, then as I said many wanted everything works perfectly.

Then I try the same configuration the same files, almost all "identical" and the game no longer starts and generates those errors.

.foo files do not exist are created by WinUAE, even Diablo.ini is generated at each launch.

In some cases I can make the game work by deleting these files created and resetting WinUAE (reset to default and Clear Disk History)

I Diablo only works on one of the many systems I have and I don't understand why, i have and only with WinUAE 3.6.1 and WinUAE 4.0.0

Aladin 31 August 2019 10:25

https://www.ppa.pl/forum/strefa-gier...ier/93#m658840

I think we have to wait a bit to have a functional version

AMIGASYSTEM 31 August 2019 11:08

Yes, but it worked for me even if sometimes it doesn't work anymore.

https://drive.google.com/file/d/1Jqs...aqgpF3pJ9/view

AMIGASYSTEM 31 August 2019 11:44

Toni, if it can help I enclose "log and config" of Diablo that works well

I found that WinUAE 3.6.0 works best

Now when with WinUAE 3.6.0 the files "Diablo1ReadOnlyTest.foo" and "Diablo1RestrictedTest.foo" are created in the folder "Data" and not in the folder "Diablo" where the engine resides.

In addition, other files are generated in the "Data" folder named "dumphist.txt".

I enclose logs, configs and files generated by WinUAE

Toni Wilen 31 August 2019 11:47

You should know that I don't care about old versions. And this is almost certainly application bug (some buffer overflow, too long file path, stack overflow, note that automatic stack checks can miss some situations etc..)

EDIT: Better use usual debugging tools (MMU + enforcer and mungwall etc and contact the author if you notice something interesting)

AMIGASYSTEM 31 August 2019 11:56

Ok Toni, what you say is right, the engine is not very compatible with Amiga Standard systems and thanks for confirming it, the stack however I had set it in the icon and the results are always the same, it only works with particular version WinUAE and particular OS.

arti 31 August 2019 12:28

Yes, auto builds are not working atm.

Try this instead http://netsurf.baderman.net/devilutionx-68040-hf-O3

AMIGASYSTEM 31 August 2019 12:36

Okay, this one works with all my OSs and with WinUAE 4.2.0.

You could have released it before you would have gotten me a lot of tests :p, if you like Diablo's Dual-PNG Icons, i can attach them here

Seiya 31 August 2019 13:27

@Arti
thanks, now Diablo run with music and sound with every AmigaOS version and latest WinUAE version.

AMIGASYSTEM 31 August 2019 22:36

Ok I confirm that this version released by Arti works perfectly on OS and all versions of WinUAE.
I enclose videos where Diablo runs on AfA One, present in the game animations, sounds and speech.

https://drive.google.com/open?id=1vA...3WyaRRmLwM8z2j


All times are GMT +2. The time now is 01:31.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.05232 seconds with 11 queries