English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Other (http://eab.abime.net/forumdisplay.php?f=74)
-   -   Mounting FFS-HDFs with DiskImage[Gui] (http://eab.abime.net/showthread.php?t=89730)

McTrinsic 07 December 2017 14:11

Mounting FFS-HDFs with DiskImage[Gui]
 
Hi,

so I have downloaded a few HDFs from the server.
I have an OS 3.1-ECS-system 030/50 32Fast/2Chip with some libs from 3.9.

I am mounting the HDFs with Thore Böckelmann's original version of diskimage.device and DiskImageGui 1.6, both from Aminet.

When using HDFs that use SFS or OFS everythign is fine. I would assume that a PFS-HDF would do as well, I have my HDDs formatted with it.

Unfortunately, it does nit work with FFS-formatted HDFs :( .

The drives just won't show up and are not mounted.

Anyone have an idea why?

I thried several FFSs from the OSs 2.1-3.9.

Thanks,
McT

Sinphaltimus 07 December 2017 16:37

Is FFS installed or has it been removed from the base OS that is doing the mounting? It's the only thing I can think of if it's one particular filesystem not working. Perhaps that file system is missing from the base OS.

McTrinsic 07 December 2017 19:38

Hi,
thanks for the help.

But as I said earlier - I tried all FFSs from 2.1 to 3.9 and put them in L:

mark_k 07 December 2017 23:33

Can you give links/filenames for the HDFs you're having problems with?

McTrinsic 08 December 2017 10:02

Hi,

one of them is this:
ftp://ftp:any@grandis.nu/~Uploads/am...Commodore).hdf

DamienD 08 December 2017 12:37

Quote:

Originally Posted by McTrinsic (Post 1204668)

Ok, just tested this via WinUAE and get:

https://www.imageupload.co.uk/images...8/Untitled.png

...but more importantly, Workbench .HDFs are not allowed to be uploaded to EAB or the FTP server, see Rules & Help.

Removed from the FTP :agree

ptyerman 08 December 2017 12:58

Someone's been naughty uploading that. Stand in the corner wearing a big pointy hat for a day! ;)

AMIGASYSTEM 08 December 2017 13:05

Quote:

Originally Posted by DamienD (Post 1204686)
Ok, just tested this via WinUAE and get:

https://www.imageupload.co.uk/images...8/Untitled.png

It should be a Backup HD

McTrinsic 08 December 2017 16:52

Ok I'll check for another one that doesn't work :D.

McTrinsic 08 December 2017 16:54

... And no it wasn't me who uploaded ... :)

McTrinsic 08 December 2017 17:12

Ok another one is:

ftp://ftp:any@grandis.nu/Commodore_A...869%20(DE).hdf

DamienD 08 December 2017 17:46

Quote:

Originally Posted by McTrinsic (Post 1204737)

That one works fine if I boot it directly in WinUAE:

https://www.imageupload.co.uk/images/2017/12/08/002.png

McTrinsic 08 December 2017 18:05

Ok ... got an idea why I can't mount it?

Quote:

Originally Posted by DamienD (Post 1204745)
That one works fine if I boot it directly in WinUAE


McTrinsic 08 December 2017 19:31

Uhm... could we get back to topic? ;)

DH 08 December 2017 19:42

Previous posts moved to the EAB File Server thread HERE

Now we can get back on topic McTrinsic ;)

mark_k 08 December 2017 21:04

Quote:

Originally Posted by McTrinsic (Post 1204737)

I didn't bother testing with DiskImageGUI, but that HDF is a partition image, not a complete drive image. If DiskImageGUI is designed to work with drive images (i.e. with RDB), that could explain the problem.

McTrinsic 09 December 2017 01:39

Sounds a bit odd to me as you can boot from that HDF in WinUAE.

Or does WinUAE not need the RDB?

AMIGASYSTEM 09 December 2017 03:30

Quote:

Originally Posted by mark_k (Post 1204788)
I didn't bother testing with DiskImageGUI, but that HDF is a partition image, not a complete drive image. If DiskImageGUI is designed to work with drive images (i.e. with RDB), that could explain the problem.

- DiskImageGUI -> Not mount the image

- ImageMount -> Mount perfectly, Howeveryou need to rename files to 869.hdf, no support round braket ()

McTrinsic 09 December 2017 10:38

What is ImageMount?

ptyerman 09 December 2017 10:56

Quote:

Originally Posted by McTrinsic (Post 1204868)
What is ImageMount?

Aminet is your friend. http://aminet.net/search?query=ImageMount :)


All times are GMT +2. The time now is 00:52.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.04384 seconds with 11 queries