English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   M.I.D.I. in detection bug (http://eab.abime.net/showthread.php?t=39458)

GROSDAMS 12 September 2008 14:59

M.I.D.I. in detection bug
 
hello world,

I write just to report a little MIDI bug which may be
only the cause of my configuration.



I have 4 usb port in/ou with one physical
connected with yamaha ES6 synthesizer

in version 5.1 and 5.2 sometimes winuae unable to detect ports midi IN
in while the midi out ports are ok


even if I uninstall all and try install them again
in version 5.0 and earlier I've never this problem
example: I launch version 5.1 it does not appear midi in
just after launching version 5.0: everything port are ok

I have no problem with my other midi software like cakewalk,or cubase

i could force it to works (but sometimes) when i load a valid midi configarution(<=winuae5.0),but the default
doesn't work and i don't understand because valid configuration is like
the default configuration (only midi host change)....



so if my setup is bad what other parameter that can
influence the detection of midi port



to summarize:I should use a configuration made with version 5.0
or Prior to put it on a version 5.2 or 5.1 so it works



in this regard, I wanted to know what was the
best way to preserve M.I.D.I. synchronization whan i use MUSICX program
(the best program for the graphic notes edition I've ever seen)
it works well but if my midi event are too many (during a lap time) I have bad
synchronisation
I used the functions of priorities "above"


sorry, my french translation to english is a bit rough



vive les bleus

n.b: mon est ordinateur peu puissant
XP SP1
athlon xp 1800 a 2.2 ghz
512 Mo dd sdram

Toni Wilen 12 September 2008 18:53

Quote:

Originally Posted by GROSDAMS (Post 457651)
in version 5.1 and 5.2 sometimes winuae unable to detect ports midi IN
in while the midi out ports are ok

Attach or email 2 winuaebootlog.txt log files (one when detection works and one when it fails)

Note that GUI has a bug, you need to adjust mouse/joystick port settings after changing MIDI or printer settings or they will be ignored. (confirm by selecting other GUI panel and then reselecting Ports-panel)

Quote:

in this regard, I wanted to know what was the
best way to preserve M.I.D.I. synchronization whan i use MUSICX program
(the best program for the graphic notes edition I've ever seen)
it works well but if my midi event are too many (during a lap time) I have bad
synchronisation
I used the functions of priorities "above"
Sorry, can't help. I don't have any MIDI equipment. Note that sometimes "below normal" is better than "normal" and "above normal".

GROSDAMS 13 September 2008 01:05

MIDI solved
 
after set the midi out port
change/scroll parametre Mouse/joystick on port 0 enable port midi in :great


All times are GMT +2. The time now is 15:41.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.

Page generated in 0.04788 seconds with 11 queries