English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.ClassicWB (http://eab.abime.net/forumdisplay.php?f=61)
-   -   ClassicWB with 1.3 theme - update (http://eab.abime.net/showthread.php?t=53907)

Bloodwych 18 July 2010 17:37

ClassicWB with 1.3 theme - update
 
4 Attachment(s)
Thanks to ppsh41 brilliant and kind help in this thread and providing some HDFs with software pre-installed, I have started some work on a 1.3 themed 4 colour Workbench.

The first release would to be based on Workbench 2.1 and for 68000 CPU's. This will make it a great Workbench to run on a mini-mig, WinUAE, A500+ and A600's and be compatible with the largest selection of machines. I've done a 1.3 Workbench, but it's not compatible with WHDLoad and there is very little you can do with it. So what's going to happen is I will place all the 1.3 friendly nostalgic software on a separate partition and provide 1.3 themed ClassicWB packs.

What I want to do is create a Workbench that feels like 1.3 for nostalgia reasons, runs fast and looks good in four colours. Eventually I want to release a "Work" HDF as an addon for these packs, which has the biggest selection of old school software pre-installed (see ppsh41's list above for an idea). I'll also include all the hard drive installable games that do not require WHDLoad - Wings, Battle Chess, F1GP, Monkey Island etc however the 2.1 version will of course have full WHDLoad compatibility.

The idea is have a Workbench running old school software like this: http://www.youtube.com/watch?v=hPT7SmVEpjc

I'm just playing with the idea at the moment - but the above would be the plan if I did do a release.

EDIT: Almost Finished the base packs - decided to release them as theme options for the GAAE, 68k (68000+ CPU's) and LITE versions (68020+ CPU's) of the ClassicWB. In the LITE version, if you have an AGA chipset you can run copper with the 1.3 icons. Theswe will be released very soon with v27 of the ClassicWB. See updated pics below:

Frog 18 July 2010 18:15

Crazy idea but funny :)
You seems to have some nice 1.3 icons !

fitzsteve 18 July 2010 19:45

Nice one Bloodwych, keep up the good work :great

Bloodwych 18 July 2010 21:17

Yep Frog, I'm definitely a little crazy! :D (says you wearing an xmas :xmas hat in July!) ;)

But who can say they don't find that youtube 1.3 video nostalgic. It reminds of how jealous I was when I had an A500, but couldn't afford a hard drive for the few games that supported it. Now I can build that 1.3 Workbench I always dreamed of as a kid!

Plus the software of that era, each fullscreen with it's own style and custom GUI, really hits home about what made the Amiga special back then. I want to put all that software, like X-Copy, Photon Paint etc all in one place - a setup for nostalgic reasons and of course I'll share as always! :D

prowler 18 July 2010 21:30

Hey Bloodwych,

That looks fantastic, mate! :D I'm sure it'll be a very popular release. :great

Frog 18 July 2010 23:13

I understand very well your point of view. A friend of mine got an HD for his A500 (it was so expensive i believed to became crazy when he showed me). All Cinemaware games, Eye of the Beholder and lot of adventures games became really enjoyable. Without forgotten the pleasure to got all your favorite tool has to run with just a click of your mouse.

I wish you the best luck has to build this teenager's old dream!

Techseeker 22 July 2010 20:46

Yep, would love to see this.

lolafg 17 August 2010 16:02

;) hello Bloodwych ,

as you know i'm having a little problem with my minimig , i can only use 2.5 mb of ram instead the 3.5 mb , at the moment a lot of games work with ADF , making whdload not so useful for the minimig.
As i allready said to you i'm not really fan of 1.3 workbench but your project seems really interesting and make me think that would be great to have it on minimig , one ask : will 2.5 mb of ram be enough to make work all HD games and aplications ?
If you are ok i would be pleased to test your 1.3 workbench when ready and could post video of the thing working under minimig !!

thanks in advance for your work.

Bloodwych 17 August 2010 16:12

You have the 68K installed, so see how far you get by using the multiboot menus:

http://classicwb.abime.net/classicweb/multiboot.htm

Should give you an idea of what runs with 2.5MB. For some multidisk games, you can disable preload in the tooltypes to get them running if need be, but I think it can cause screen flashing.

This 1.3 themed Workbench (actually Workbench 2.1) won't use much less mem than the 68K version - 4 colours vs 8 isn't a massive difference. If the multiboot seems to be good for gaming, you could use that as your default bootup menu with a little editing of the startup sequence rather than having to hold down mouse buttons.

lolafg 17 August 2010 16:31

Quote:

Originally Posted by Bloodwych (Post 693217)
You have the 68K installed, so see how far you get by using the multiboot menus:

http://classicwb.abime.net/classicweb/multiboot.htm

Should give you an idea of what runs with 2.5MB. For some multidisk games, you can disable preload in the tooltypes to get them running if need be, but I think it can cause screen flashing.

This 1.3 Workbench won't use much less mem than the 68K version - 4 colours vs 8 isn't a massive difference. If the multiboot seems to be good for gaming, you could use that as your default bootup menu with a little editing of the startup sequence rather than having to hold down mouse buttons.

Well , was not asking for whdload games , but for games and aplications hd instalable in 1.3 workbench.
I was thinking in having only a 1.3 workbench as main workbench and don't use whdload.

Bloodwych 17 August 2010 16:35

WHDLoad doesn't work in 1.3 Workbench anyway, so yeah if you just want to use 1.3 for a great nostalgia experience then 2.5MB is fine. In fact, it's way more than enough. :)

It will work with all hard drive installable games - Battle Chess, F1GP, Monkey Island etc - the only problem being there aren't that many games which are installable in 1.3. If your happy with the ADF route on the minimig, which is after all what it was intended for, then great.

lolafg 17 August 2010 16:44

Quote:

Originally Posted by Bloodwych (Post 693227)
WHDLoad doesn't work in 1.3 Workbench anyway, so yeah if you just want to use 1.3 for a great nostalgia experience then 2.5MB is fine. In fact, it's way more than enough. :)

It will work with all hard drive installable games - Battle Chess, F1GP, Monkey Island etc - the only problem being there aren't that many games which are installable in 1.3. If your happy with the ADF route on the minimig, which is after all what it was intended for, then great.

:D cool ,

is your future 1.3 classic workbench will automatically install the 2 separate partition 1.3/2.1 or will it be possible to onlly choose 1.3 install ?

Bloodwych 17 August 2010 16:49

The plan is to have a partition for either 1.3 or the 2.1 (with 1.3 theme), then a separate one for all the applications and games that are compatible with 1.3. :)

So you can choose which to run easily. I haven't decided how I'm going to do the install routine yet, but yeah I intend to give the user a choice.

lolafg 17 August 2010 16:59

Quote:

Originally Posted by Bloodwych (Post 693231)
The plan is to have a partition for either 1.3 or the 2.1 (with 1.3 theme), then a separate one for all the applications and games that are compatible with 1.3. :)

So you can choose which to run easily. I haven't decided how I'm going to do the install routine yet, but yeah I intend to give the user a choice.


;) Super , will wait seething with impatience ;)

Retro1234 17 August 2010 17:49

I was a bit sceptical about this at first but looks like youve done a good job -adding to your line of ClassicWB Packs

You could run some WHDload Game Slaves under 1.3
http://eab.abime.net/showthread.php?p=686111#post686111

Bloodwych 17 August 2010 18:08

Thanks Boo Boo. I try and aim these packs towards satisfying the nostalgic feel rather than stunning looks.

Thanks for the link - really interesting. I'll definitely try and chuck JST and compatible WHDLoad slaves in too. :)

fitzsteve 17 August 2010 18:29

*slaps self* No Steve! You can't get an A500+ & GVP HD+8 just to run this new awesome Classic Workbench! :bash

Bloodwych 17 August 2010 19:14

The fact you have mentioned it fitsteve means you are thinking about it...

...A500+ and GVP hard drive - tasty! :p

Bloodwych 18 August 2010 17:20

Updated the pic in the OP - removed the icon borders. Looks much better. Forgot 1.3 has no icon borders. :D

Techseeker 18 August 2010 17:26

Looks fantastic. Can't wait :D


All times are GMT +2. The time now is 14:50.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04597 seconds with 11 queries