English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.ClassicWB (http://eab.abime.net/forumdisplay.php?f=61)
-   -   Problems running ScalaMM 400 (http://eab.abime.net/showthread.php?t=81617)

chaos 17 February 2016 10:01

Problems running ScalaMM 400
 
Hi,

I recently switched to using the updated icon.library, and ScalaMM no longer works.

I'm running ClassicWB FULL v28, and I could run ScalaMM just fine before. Recently, I ran the icon.library install script, and added some updates / changes manually (enabled FBlit, updated icon.library to newest version, updated layers.library, added CMQ030 to S-S).

After this change, ScalaMM freezes and reboots when you run a script (but surprisingly, not the included main script).

I tried removing all my changes (disabled FBlit, icon.library to original version, layers.library, CMQ030), but ScalaMM still won't work. Is it possible that the install script messed something up? I looked at the script source, but I don't see anything that could cause this.

Another program that no longer works is HAMP video player - if you run it, it just exits back to shell. I will check with SnoopDOS to see if anything interesting comes up.

Also, both ScalaMM & HAMP run OK if I run with S-S disabled.

roomeo 17 February 2016 10:33

try running Snoopdos to see what fails.

http://aminet.net/package/util/moni/SnoopDos

chaos 17 February 2016 21:21

OK, I tried running SnoopDOS and when running HAMNEW.RUN an "Open" action on the .hv file fails.

I can't see in the snoopdos logfile what is the problem with scalaMM.

I checked the partitions with PFSdoctor, no problems were found.

Like I said before, this only happens *after* running the icon install script from ClassicWB. Also, if I run with startup disabled, the HAMNEW.RUN & ScalaMM work OK.

gulliver 17 February 2016 23:12

Evidently the problem is in some nasty thing in the startup-sequence.

Try running it by disabling startup-sequence lines with an ";" in their begining, to find out the offending one.

Remember that Scala was developed hitting the Amiga hardware, so hacks & patches are the first thing you should care about.

Also inspect both your user-startup and WBStartup drawer for other missbehaving apps.

chaos 21 February 2016 22:49

I checked again my S-S and WBstartup, but nothing out of the ordinary, I tried to disable most of the stuff in there but it didn''t help.

I took another look in the Icon enable / disable scripts, and they seem to move *a lot* of files around, it would take too long to check each and every one.

For now, I disabled the icon.library support with the included scripts, and everything seems to be back to normal.

PeterK 26 February 2016 18:37

Hi chaos,

could you please try out this icon.library with SCALA:

chaos 26 February 2016 22:40

Hi PeterK,

thanks for the updated lib. Unfortunately, at least for me, it doesn't fix the problem with ScalaMM. I only had time for a quick test, but it seems that even with your iconlib renamed and thus not loaded, the ScalaMM still has the same problems. I'll do some more tests and run SnoopDos and LibSnooper when I'll have some free time.

Michael 27 February 2016 07:12

1 Attachment(s)
Quote:

Originally Posted by PeterK (Post 1073473)
Hi chaos,

could you please try out this icon.library with SCALA:

New log, now much less icon lib calls !

PeterK 01 March 2016 06:45

1 Attachment(s)
OK, problem found:

... it's caused by my command "FixScalos" :guru

There is a line at the bottom of the startup-sequence "Run >NIL: C:FixScalos", which should avoid crashes on screenmode changes. It disables the ReleasePen() function while Workbench is closed.

But disabling ReleasePen() while the Workbench is closed was not the reason as expected. FixScalos also checked some pointers whether they were negative, odd or pointing to the lowest 64 kB.

But SCALA seems to use lists or nodes in the lowest 64 kB for AddTail(). This 64 kB check was responsible for the Gurus :banghead

Please copy FixScalos to MyFiles/Install/Icons/Enable/C,
copy the latest icon.library (422) to MyFiles/Install/Icons/Enable/libs
... and execute InstallIconsSupport.

PeterK 05 March 2016 17:52

Hey chaos, how about some feedback ??

chaos 06 March 2016 12:04

Yup, that seems to fix it :)

Thank you :great

PeterK 06 March 2016 12:12

Ok, I'm glad that it works. Thank you !

Bloodwych 06 March 2016 15:28

Hi PeterK, so do I need to add this new version to the Scalos ClassicWB packs? Or is it specific to ScalaMM users?

Really appreciate the fix - being able to run your iconlib on the Scalos versions is fantastic! :great

PeterK 06 March 2016 15:43

Hi Bloodwych !

Yep, this update v0.7 should replace FixScalos v0.6 as explained in my post #9 above. My old version was a little to strict by disabling access to the lowest 64 kB in AddTail(). ScalaMM 400 and maybe also other tools seem to place lists or nodes into the lowest 64 kB, so I removed this restriction.

Bloodwych 06 March 2016 15:45

Thanks, will do ASAP.

EDIT: NOW UPDATED - New versions added to the packs.

Michael 06 March 2016 20:58

So what happens with newer Scalos beyond 1.2d? And why the updates are not user in CWB?

PeterK 06 March 2016 21:26

Hi Michael,

the FixScalos patch is required for 1.2d only ! Newer versions should not need or use this patch !
Sorry, but I don't understand your 2. question.

Michael 07 March 2016 04:28

Why newer Scalos versions are not used in ClassicWB

gulliver 07 March 2016 05:10

Quote:

Originally Posted by Michael (Post 1075811)
Why newer Scalos versions are not used in ClassicWB

Most likely because even though they are much better, they require a much faster Amiga than just a 68020 and some fastmem. I believe Bloodwych made a good compriomise between features and usability taking into account the vast majority of Amigas do not have a 040 or 060.


All times are GMT +2. The time now is 21:14.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.05662 seconds with 11 queries