English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   New to Emulation or Amiga scene (http://eab.abime.net/forumdisplay.php?f=26)
-   -   N00b with a toaster 4000 (it's got issues) (http://eab.abime.net/showthread.php?t=63411)

bluegreengold 06 March 2012 01:59

N00b with a toaster 4000 (it's got issues)
I just got a complete toaster 4000 system, but it has issues. If there is anyone out there who can help guide me in the right direction to getting this machine back in action I would greatly appreciate it.

This is what I've been able to gather so far:

It has maxed out memory, a toaster 4000, a vector wavescope, and a oktagon 2008 scsi adapter with HD installed in the expansion bay. It has a 33 mHZ 040 chip. The battery is still in there, was a little corroded at the terminals but seems 'ok.'

There is no IDE harddrive. The floppy drive works, but may be kinda iffy.
The power supply works, but may be iffy.

The first time I tried to boot it, it said DF0 was not a DOS disk. I figured maybe the floppy is dusty so I aired it out and unplugged replugged the floppy connector. Tried again, with the workbench 3.0 install disk in. It successfully booted to Amigados, but not workbench.

I turn it off, and try to reboot, and this time I only get a gray screen. Wait a day, try to boot, goes to amigados again. I try booting with the two mouse buttons down to enter bios setup. I inspect the drives. It sees the octagon there so I try to set it as the boot disk. I click to do so, and the system seems to freeze. I should note that anytime I try to boot, the scsi drive makes it's normal noises, but that's about it. I was actually quite pleased that I was able to see the drive under the disk info. Not so pleased that I can't hold the 2 mouse buttons down and boot into the bios anymore. I don't understand why it worked once, but not again.

I wait. I reboot. This time it tells me there is a software error, and then it goes to the insert floppy graphic. I put in the workbench installer and it goes to amigados.

I try exploring the directories aimlessly, but that doesn't help. Turn it off. Now it just goes to the gray screen.

I try booting with what I believe is the scsi driver disk. Sometimes it boots, sometimes it doesn't it warns me that this boot disk should not be used for initial driver install, just the format tool. I say ok. It loads up workbench. However when I click on hard disk tool drawer it gives me a window where I must click ok, however the mouse does not seem to function.

I try rebooting with the mouse buttons down, it does not enter bios anymore like it had.

I suspect that the system was installed on the scsi drive, but that the drive is damaged. There is not IDE hard drive installed.

I have a lot of external scsi peripherals. I tried turning everything off, and connecting a scsi bay with a cd-rom and flyer 88. I put the controller board out to the in, and put a terminator on the out of the expansion bay. Still won't boot from the hard drive.

My concern is that I am facing numerous issues. One, the PS is old and I iwill replace it with a new athena 300W AT psu which should be a drop in replacement.

I'm concerned the floppy may be iffy. I have a lotharek floppy emulator on hand which I could use -- however, I will have to read up on that -- was intending on putting it in an atari st.

I also have a 120gb eide hard drive, but looking at the connector pins, I'm guessing that the IDE on the 4000 is too old for this drive.

Quite likely the cpu board isn't seated well. I'm going to take apart clean and put everything back together. I'm pretty sure the system is 'working' but it's being cranky -- and the HD with the os is probably damaged. This was in storage for quite a few years before I got my hands on it.

That's pretty much where I am at. Any assistance or encouragement. Especially links to how to do a clean install -- especially directly onto a scs ti drive (the drive disk suggests that maybe you are supposed to install workbench to an IDE drive first).

So if I am going to get some IDE drive -- what is the best modern practice for this. Can I install an IDE CF drive instead. How big a disk can the 4000 take? Any other tips? thanks

jimbob 06 March 2012 03:38

Well, since I've never even seen a 4000 in real life, I can say this with confidence, better advice will be coming soon, (if everyone isn't too jealous that is).

I'll offer some thoughts in the meantime. Since you suspect the PSU, I would try removing all the expansions and see how it behaves bare bones. This'll also give you a better look at the mainboard for battery/capacitor damage. Reseating CPU card and RAM seems like a good plan too.

Any IDE drive should be compatible connector wise with at most an adaptor for 44pin to 40+power conversion. Getting an amiga to correctly use the full size of large hard discs is another matter. There are lots of posts about that here. Somewhere there is a pretty definitive guide to exactly which hardware/filesystems/OS device/software is needed to support hard discs of whatever size.

A 4Gb CF card should be a safe place to start. All you need is the appropriate IDE-CF adaptor to match the connector type of the 4000s IDE. These adaptors are dead cheap, all they really have to do is break out the wires
since CF interface is supposed to be electronically/logically the same as IDE.

I wonder if a full on toaster system like this might have software and/or registration keys etc. on the original scsi disc which would be hard or impossible to replace? Even if that disc appears to be toast, (sorry :D), you can probably attempt to mount it in winUAE using a PC, since you say you have a bunch of other scsi gear. Give you a chance to poke around for licence keys and stuff. Probably a good plan to try and image the whole disc before it dies forever. WinUAE makes this very easy.

Good luck, (if you have any left after scoring this system)

bluegreengold 06 March 2012 05:29

Thanks for the tips.
I suspect the power supply is being stretched, as sometimes the disk drive works, sometimes it does not. The light shines feebly for a second sometimes but nothing loads, sometimes when I try to boot, it'll go all the way. Hopefully that's just the PS and not bad caps on the motherboard. But I'll be doing whatever it takes to bring this one back.

I was after many tries to boot using a disk that was labeled dataflyer. It loaded up workbench and presented me with some txt file readme and some disk utility programs. From what I could gather from the readmes, the scsi bus uses the ide bandwidth somehow and creates conficts. As a result there are problems with using a ide drive simultaneously. In order to get around this there are some special drivers that allow it to avoid interference. First however, you need to format the drive, and then in order to install the controller drivers that will allow the scsi hard drive to boot, you must make a modified workbench installer disk. The details may be a bit vague I wasn't taking firm notes.

Trouble is that in order to do this, you need 2 drives, or to do some manipulations with a ramdisk. Thankfully this system came with all the manuals and I've been learning how amigas work, but it'll take a while before this goes smoothly.

My plan is to wait for the new power supply to arrive, do a full breakdown/clean/remove the battery, and take a look at the solder pads for the capacitors on the mb see if there is any discoloration. In the meanwhile I'll learn how to configure the hcx floppy emulators to work with the amiga and then load up an SD card with images of the workbench installer, and the dataflyer drivers. How i'll do this, I'm not yet sure, as I don't have another amiga to make images. Will a PC with omniflop read amiga disks?

What I need is a backup of the workbench 3.0 installer because the scsi driver installer modifies one of these to make the bootable driver installer.

In the meanwhile I'll also get a ide CF card. If I can't go straight to configuring the scsi, from what I read in the info files, it should be easier to install onto and ide drive, and then configure the scsi.

Anyhow, it does seem like the system works, if not a bit

flakey and crippled. That I was able to get into workbench and read the info files means that I've got a lot of hope for making this work. I've got all of the original software installer disks (and cd roms -- which i can use once I get the scsi happy). I should be able to get everything back upon a clean install.

It would be a good idea to image that drive. I should try and do that before giving it a format.

marcfrick2112 07 March 2012 23:22

I have a non-working A4000T system as well, so I feel your pain.
Agree, with all said here, strip the machine down to just essentials, and try booting again. I can also say, at least my machine is VERY picky about its' PSU...

As for the floppy.. it's also possible that there is dirt/crud in the sensors in the drive. I used contact cleaner on my 4000T's floppy (HD drive, so it has 2 swtches) ... something to consider, maybe...

source 08 March 2012 03:50

There are no license keys that the toaster looks for. However there is in the startup sequence (if you have a flyer installed) to initiate the flyer. As for Video you will have problems with the machine booting if you do not have either appropriate monitor (commordore) or having a specific video toaster scan doubler or a indvision 4000. the Video toaster needs a sync signal from the monitor or appropriate scan doubler. If it does not then it will hang the machine. pull the toaster card from the machine and attempt booting again. if you get past that then you have to make sure that the centre frequency is set right or you will get toaster unable to genlock. you need a live video source hooked into video 1 in. not through the vector scope. you need a dc volt multimeter and you run with a video source into the toaster. you put the pos on the solder point labled err, and the ground line to the case. you want the voltage to be 2.1 i can't remember if + or -. I would have to look at my notes.

S0ulA55a551n 08 March 2012 18:42

Have you tried asking over on www.amiga.org. I know there a lot of people with toasters and or A4000s over there

Jope 09 March 2012 18:48

Just strip the machine of everything but the CPU board and the floppy drive. See if you can get it to come up like that first.

I wouldn't go to Amiga.org for Amiga help. ;-)

bluegreengold 13 March 2012 15:05


Thanks for the help so far. I thought I would post an update.

It seems like my suspicions were right and that the PSU was failing and that the SCSI hard drive was damaged in some way.

I got the athena 300 AT power supply. Unfortunately (although not surprisingly) it was not a 'drop in' replacement due to the size of its casing. I had to do some surgery and some soldering to get it to fit in the old case. The circuit board which the PSU resides on is smaller than the amiga original, so I could only screw it down in one corner. Because of this the grounding posts wouldn't make contact so I soldered some wires in to connect the different grounds on the board. I then built up some insulating pads with double sided foam tape and insulating tape so that the PSU would rest on the base of the case without shorting anything out. I removed the PC style AT motherboard connector and soldered in the old amiga PSU cable.

I removed all the cards and booted with just the floppy -- and it was good. I reinstalled all the cards and booted from the workbench install floppy still good!

In order to reinstall the drivers for the scsi card I needed either a second drive or a previous workbench install on an IDE HD. Rather than play around with the floppy emulators (which I have for my ataris) I decided to get an IDE CF adaptor and 4 GB CF card. I got the cheapest 4GB kingston I could find and did the install last night.

I boot with the floppy, it goes to amiga dos. I loadwb, and now I am not sure where to go. I used the HDtools to investigate the drives. I can see the scsi drive and I was able to install,partition and format (to 2GB) the IDE CF. I rebooted. Now it hangs at the boot unless I use the double button click to select the floppy. The floppy is the last priority boot device from the menu, so I guess it could be hanging while for a long long while before it gets around to checking the floppy. Perhaps I am being a bit too impatient, and that it would eventually boot from the floppy (many minutes later?) if I tried booting without using the double click?

I can see that somehow both the scsi and the CF drive are assigned boot priority of 0. I'm guessing this may be causing some conflict that is confusing the startup. How can I set the boot priority? I remember seeing a button for this in either the hdtools or hdsetup. Do I need to repartition and quickformat the disks in order to set these to different values?

I think I'm on the road to success here. Does anybody out there have a link to a howto for a clean install of workbench? I'm googling and searching the forums but haven't found one that is really step by step for an amiga noob.

I tried to install wb, but it tells me I need to insert the EV volume. I've read that this is a ramdisk necessary for temporary files and preferences etc, and that perhaps I need to edit my startup-sequence script? Shame I have no editor program available.

Somewhat worring is that sometimes it won't go to the double click bootup menu but just hangs there. If I leave the amiga alone for a long while, say overnight, then it will do the double click boot straight away. Could I be having an overheating issue? Or is something lingering in ram that is messing up the boot and the memory just has to drain?


bluegreengold 14 March 2012 04:53

More progress has been made. I repartitioned the CF drive, this time using hdsetup. I followed the the suggested amigados commands to load the ENV volume according to this post: http://eab.abime.net/showthread.php?t=41210
and then I was able to begin the install -- only to discover I am missing the 2nd disk of the install set (or perhaps I should say the first after the installer disk) the workbench disk!!

I will look into ordering a new set of disks and the possibility of installing workbench 3.0 to the CF via an emulator an PC.


jimbob 14 March 2012 05:25

Hi, glad you are making progress. Do you know which kickstart version you have? If you are getting new workbench disks, probably worth seeing about also getting a 3.1 ROM and 3.1 Workbench.

A plain install of WB should be straightforward once you have full set of disks. Insert install disk, power on, follow the instructions. This will take care of setting up the ram disk and ENV:directories as part of the default startup-sequence. You should also take a look at the classicWB packs for masses of enhancements to the basic install.

bluegreengold 14 March 2012 13:17

I've got 3.0 roms. My goal is simply to get the video toaster working with as few snags as possible (though I've run into a few lol). I don't know if there is full compatibility with all the software with 3.1 -- I imagine so, but since I know everything was at one time working with 3, and the disks are not too dear, I've got some on order and will try with that first.

Is there a big stability boost with 3.1?

Jope 14 March 2012 14:41

It is just as stable, but you get some new features and a few bug fixes. I run WB3.1 on all my 3.x machines and always recommend it to anyone. :-)

S0ulA55a551n 15 March 2012 14:27


Originally Posted by Jope (Post 806488)
Just strip the machine of everything but the CPU board and the floppy drive. See if you can get it to come up like that first.

I wouldn't go to Amiga.org for Amiga help. ;-)

Really why not, some very helpful people use amiga.org. A lot of them also post here mind

Pyromania 16 March 2012 03:06


Originally Posted by Jope (Post 806488)
Just strip the machine of everything but the CPU board and the floppy drive. See if you can get it to come up like that first.

I wouldn't go to Amiga.org for Amiga help. ;-)

Oh behave! There are some nice chaps at Amiga.org.


I run openvideotoaster.org so know a little bit about it. Let me know if I can help.

All times are GMT +2. The time now is 18:17.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04912 seconds with 11 queries