English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   A1200 SDE+ issue (http://eab.abime.net/showthread.php?t=97751)

webmany 17 June 2019 00:41

A1200 SDE+ issue
I am running into an issue with the SDE, but not sure if its me or a hardware issue. I ordered from AoL and added on the network SPI adapter. When the card starts up I have a link and everything looks fine (memory recognized). I setup miami using 3 different drivers I have managed to find, and they all cause miami to freeze when it tries to talk to the network. The mac address is also all 0s in miami, which looks like it can't talk to the adapter.

Any ideas what I should check?

I also tried roadshow and the 1200 will not boot to workbench when it auto starts the network on boot.

indigolemon 17 June 2019 10:03

This sounds very odd, do you have any pictures of the setup (SPI module/cable)? Where did you download the drivers from?

webmany 19 June 2019 06:48

The drivers are from mike-stirling.com and another location that I can't remember (was supposed to be optimized for 020).


solidcore 20 June 2019 14:47

Not much to say about this really, check with multi-meter that pins on your Ethernet module have continuity with your sde, could have a cold solder joint. IF you followed the basic guide to setting up correctly then could it be a DHCP issue at your end, use static ip for dns etc.

webmany 20 June 2019 17:31

Don't think it has anything to do with the IP as the system freezes and the link light on the ethernet port goes out when trying to talk to the port to see the mac address (before the IP part).

patrik 20 June 2019 18:20


I compiled the driver and test programs a while back for the following thread: http://eab.abime.net/showthread.php?...82#post1288882

The repo/code also contained a test-utility for the network interface called spinet-test. This is included in the archives in above thread.

Have never tried spinet-test, as I don't have the hardware, but running it might give you some more insight to why it doesn't work.

webmany 21 June 2019 05:38

I tried running the test and received the following:

Expansion board found at 0x00e90000
Allocated signal 31

At this point the link light goes out and the system freezes.

webmany 28 June 2019 18:29


Kipper2k said you might be able to help track down the problem with the networking. Any ideas?

FREEMILK 28 June 2019 19:30

Sorry it took me so long to get here.
few questions, is the Eth module a 3.3v or 5V, there are many many versions of these things.
With Roadshow, the amiga can seem to hang if it cant get an IP, it take like 1 minute of hang then continues to boot.
i dont like miami, it never works for me.

check the VCC and GND at the eth module see if you are getting 3.3v

webmany 29 June 2019 02:05

No problem.

As mentioned above, when the Ethernet is initialized the link lite on the ethernet port goes out. It does not reach the point where it tries to get an IP.

I believe the module is 3.3 volt but will have to check. This is the included module when ordered from amiga on the lake.

FREEMILK 02 July 2019 18:29

Can you take a pic of both side of the ether module, i will compare it to my pile of them, and see. i have about 12 versions of the thing, from when i was making the vampire SDNET.

webmany 09 July 2019 20:36

Here you go:


indigolemon 10 July 2019 10:55

Ah! I think I see the issue, on the back you have a voltage regulator for 5v to 3.3v (middle left - black with three pins bottom, one big pin top), which means this is a 5v adaptor. I had the same problem with the first one I bought, but since I bought a 3.3v one it's been fine.

FREEMILK 17 July 2019 16:22

yes thats exactly what i thought.
that voltage reg can be desoldered and you can jumper 2 pins and it will be a 3.3 v unit. i will check what pins and post back,
sorry for the delay.

webmany 18 July 2019 18:29

Thanks. While my soldering skills stink, this sounds like something I could do.

webmany 30 July 2019 17:12

Any luck finding what pins to jumper?

All times are GMT +2. The time now is 19:11.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04323 seconds with 11 queries