English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   CD32 FMV cartridge fault (http://eab.abime.net/showthread.php?t=55547)

AmigaFun 03 October 2010 17:21

CD32 FMV cartridge fault
 
Hi everyone.
I have an FMV cartridge here and it has developed a problem. What happens is that the picture will loose most of the colour, except the blue. One of the pins in the loop through card I have noticed gets stuck in, and I think it's one of the 12V pins that feeds the regulator in the cartridge. So, maybe this is part of the problem? I don't know, but is this symptom of a blueish picture a common issue?
Does anyone know of a place that can repair this and the connector?

Thanks all

Cosmos 03 October 2010 17:37

I have repaired an FMV module only with changing capacitors !

With old caps, I can't get a boot...

AmigaFun 03 October 2010 17:46

Quote:

Originally Posted by Cosmos (Post 705454)
I have repaired an FMV module only with changing capacitors !

With old caps, I can't get a boot...

Ah, thats a good point! I forgot about the cap issues. I should look into those then

Cosmos 04 October 2010 09:48

And clean the connectors : http://cosmosamiga.blogspot.com/2010/02/gomme.html

AmigaFun 04 October 2010 19:44

Quote:

Originally Posted by Cosmos (Post 705626)

Yea, done that with electronic cleaning solvent on the CD32 connecter. But not so much on the FMV passthrough card, the connecters for that are well small and as mentioned, one on pin 183 (I think) is stuck in. However, the caps will be changed soon and hopefully bring this fab unit back to working order.

By the way, those connecters on the website link came up a treat didn't they!

AmigaFun 09 October 2010 21:36

Thought I was getting somewhere with this. I replaced all but 3 caps (I ran out, but more on order) There was some residue around the SMD caps and cleaned up well. But after a while the picture turns blue again. This has to be heat related though. Anyway, when I get the new caps delivered and fitted I will hope for the best!

Toni Wilen 09 October 2010 21:59

Use cold spray to find heat-sensitive components.

AmigaFun 09 October 2010 22:09

Quote:

Originally Posted by Toni Wilen (Post 707221)
Use cold spray to find heat-sensitive components.

Not a bad idea! will do that after new caps fitted if problem persist's. I also noticed that the regulator was not fixed to the PCB (it is now though), but I this is also the case on the A4000 I have as well, so what's going on with that I don't know.

AmigaFun 16 October 2010 19:31

1 Attachment(s)
Quote:

Originally Posted by Toni Wilen (Post 707221)
Use cold spray to find heat-sensitive components.

Ok, all but two caps have been replaced. It's still doing it. However, I think I have found the issue. The STV8438CV Triple 8-bit DA Converter is getting very warm and if I use freezer spray, the colours return to normal and look great.
I have used Google to try and find a replacement but seem to hit a brick wall with me being sent to brokering sites (I think thats what they are). Does anyone know what else the IC is used in? or how to get a new one??

Also, here is a picture of one of my CD32's that I had to modify in order to run the card and get access to it when it was active. It broke my heart to have to do that but it was for a good cause!

Cosmos 17 October 2010 06:45

>It broke my heart to have to do that

...and to replace SMT by electrolytics... :crazy

AmigaFun 17 October 2010 10:42

Quote:

Originally Posted by Cosmos (Post 708977)
>It broke my heart to have to do that

...and to replace SMT by electrolytics... :crazy

They are the same qualilty ones I used in my A4000, I did not skimp on the cost of them!

xArtx 13 July 2016 11:45

Hi Guys :)
I pushed this old thread rather than start a new one to show the common problem.
It's also is talked about on other forums with Google search for something like:
“CD32 FMV colour problem”.

Probably too late for the OP, but he was correct, and the video DAC is now
available from eBay as I write, and will potentially be difficult to find after that.
The chips I received are dated ’94, only a year after the original in the FMV cart.
http://www.ebay.com.au/itm/271735859...%3AMEBIDX%3AIT

This eBay link has nothing to do with me, other than I have purchased
24 of the chips from the seller, and done the repair.

Rework ST Microelectronics:
http://img.photobucket.com/albums/v1...pslebhjtyf.png

Bonus points for finding the error on the PCB! :D

What happens when an FMV cart is installed, is a pin is pulled on the edge connector to enable external video.
Any video made by the CD32 is routed through the foldback edge connector,
into the FMV cart’s video DAC, and back to the CD32 through the foldback
connector again so the CD32’s S-Video and Composite mux will output the
Amiga’s video through the usual connectors.
This is so the CD32 can switch to the video produced the the FMV cart MPEG
decoder and back at any time. For example the menu you see at the start of
a video is produced by the Amiga, and switched to MPEG when you press play.
This is how the same video DAC which has the switching functionality (or a dud edge connector)
can mess up the CD32 video as well just by being installed.

Mine was missing green in the FMV video, and overpowered by blue.
When the same FMV was installed and the Amiga was in use, the blue colour was missing,
but you can see in the MPEG, Luke’s sabre is now green :)

Why does the video DAC commonly go faulty? Because it’s made by ST Microelectronics.

Luke's Sabre:
http://img.photobucket.com/albums/v1...psbmiwhgwp.png

Cheers, Art.


Quote:

Originally Posted by AmigaFun (Post 708877)
Ok, all but two caps have been replaced. It's still doing it. However, I think I have found the issue. The STV8438CV Triple 8-bit DA Converter is getting very warm and if I use freezer spray, the colours return to normal and look great.
I have used Google to try and find a replacement but seem to hit a brick wall with me being sent to brokering sites (I think thats what they are). Does anyone know what else the IC is used in? or how to get a new one??

Also, here is a picture of one of my CD32's that I had to modify in order to run the card and get access to it when it was active. It broke my heart to have to do that but it was for a good cause!


Pyromania 14 July 2016 00:45

You are lucky to have the CD32 FMV card. I looked for one for years then gave up.

xArtx 14 July 2016 05:32

No luck involved :D Just the last year I’ve seen 5 on eBay, one in FB Amiga group, and one on Amibay.
One could possibly still be for sale in the FB group.


All times are GMT +2. The time now is 00:50.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04376 seconds with 11 queries