English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   A4000 Mediator green screen - dead? (http://eab.abime.net/showthread.php?t=85580)

trixster 15 January 2017 18:32

A4000 Mediator and Voodoo 3 problems - losing the will to live
Hi all,

I finally had chance this weeked to have a go at installing my new Mediator 4000Di. It's brand new and the latest 2015 revision of the daughter-board and logic card.

Installation went well, the early boot menu showed that the board was recognised. I installed the software off the cd, installed the update. pciinfo would recognise my Voodoo3 and I had a go at installing the Ratte switch and the Picasso96 drivers off my OS3.9 cd.

I was getting a black screen following this which caused a few headaches until this morning I re-read the ratte instructions and realised i hadnt installed the little piece of software in C: to do the switching.

With this in mind I turned the A4000 on this morning only to be greeted with a flashing green screen and a reboot loop. I can't access the boot menu. I assumed there's a problem with the hardware so powered down, took the mediator out and re-seated it. Unfortunately the green screen will not go away. I've tried re-seating several times.

If I remove everything, reflash my SD card to a known good config, put the cbm zorro daughter-board back in then the A4000 springs back to life perfectly.

I have nothing else installed in the A4000 (other than Indi AGA, CDROM and SD card) and i did not try any other PCI cards - i wanted to get the Voodoo3 working first.

So there's a problem with either the Mediator zorro card, or the logic board or both. :( I've checked and double checked that it's not shorting on anything. It's close to the Indi AGA but there's space, and I've place electrical tape on the top of the Indi to provide further assurance that's there's nothing touching.

So has my Mediator killed itself? I've contacted my reseller by email for advice


Galahad/FLT 15 January 2017 18:53

Green refers to memory, so check your SIMMS are in properly, take them out, wipe, and replace.

hooverphonique 15 January 2017 18:55


Originally Posted by Galahad/FLT (Post 1134931)
Green refers to memory, so check your SIMMS are in properly, take them out, wipe, and replace.

Yes, and chipmem specifically, IIRC..

trixster 15 January 2017 19:22

I'll give that a try, but why do I only get the green screen with the Mediator board installed, and not when the original zorro board is in?

hooverphonique 16 January 2017 14:06


Originally Posted by trixster (Post 1134936)
I'll give that a try, but why do I only get the green screen with the Mediator board installed, and not when the original zorro board is in?

Could be a bus loading or power supply issue. Have you checked psu rails with the mediator installed? Is the A4000 mobo re-capped?

trixster 16 January 2017 17:45

Hi there, thanks for the reply.

The mobo was recapped by the previous owner but I can't rule out an issue with the psu. It's the original as far as I can tell but I don't know if it too has been recapped. I'm not sure how to check psu rails I'm afraid :(

One thing I've noticed is that with the cbm zorro daughter board in place I get no id in the Expansion Board Diagnostic. Should I? I don't recall the board ever having its own ID.

Pat the Cat 16 January 2017 18:12


Originally Posted by trixster (Post 1134936)
I'll give that a try, but why do I only get the green screen with the Mediator board installed, and not when the original zorro board is in?

The self tests the Amiga does first thing are a little bit slapdash and hurried.

To test the chipRAM, the processor tries to write a few values out to the chipRAM, testing the bits and the address access. It doesn't test the whole lot. It then tries to read the values back, and if the values are wrong, it warns there is a problem with accessing chip RAM.

So, a green screen can be a bad RAM chip, but can also be a problem with the databus being scrambled by something.

My guess is, the Mediator wasn't burn tested - you are supposed to leave electronics running for 24 hours or more, to make sure that the components do actually work with consistently under load. This is not easy to do properly unless you have LOTS of A4000s to test on.

However, even if it was burn tested like that, a component could still have failed in the meantime, and is now scrambling the databus when the Mediator is plugged in.

My 0.02 cents worth - that's a LOT of expansion for a desktop Amiga. Checking power rails is pretty much measuring with a multimeter, checking that voltages are corect (5 volts really is within 10% of 5V, and not 6V or 4V). You do that with the PSU unplugged, so you CAN'T damage the Amiga while doing it. Checking voltages is usually enough to tell if a PSU is dying. Pros will do things like, ideally, measuring with the board plugged in - to see if the voltage drop caused by powering the device is bringing the system down, or whether the PSU is chunky and butch enough to supply the amps needed. Don't try measuring amps unless you have a very robust multimeter, and the experience to use it properly.

Multimeters are very cheap nowaday, even extortionate places like Maplin stock them for less than £15. Also very handy for checking fuses without plugging them in. So it is worth getting one just for checking voltages and resistance. Don't go into measuring amps unless you really understand power rails.

The logic chips on A3/A4 Amigas daughterboards are not too tricky to find. They are generic components, not custom chips like Agnus. So if there's a problem there too, it should not be too much of a bother to fix.

It's a pain in the behind for you in the meantime, but it's all fixable.

trixster 16 January 2017 23:18

I have swapped the chip ram 2mb sim with another known good simm and the problem with the Mediator remains - a green screen continual reboot loop. As soon as I put the original board in all is ok.

Pat the Cat 17 January 2017 00:29

Not surprising then, that means the databus is scrambled for some reason when it's plugged in.

Could be power, could be a fault with the Mediator, could be a fault with the A4000.

Start with checking power. Any electrical device gets screwy power, it won't work properly.

hooverphonique 17 January 2017 15:12


Originally Posted by trixster (Post 1135118)
Hi there, thanks for the reply.

The mobo was recapped by the previous owner but I can't rule out an issue with the psu. It's the original as far as I can tell but I don't know if it too has been recapped. I'm not sure how to check psu rails I'm afraid :(

One thing I've noticed is that with the cbm zorro daughter board in place I get no id in the Expansion Board Diagnostic. Should I? I don't recall the board ever having its own ID.

Check the rail voltages (particularly 5V) using a multimeter, with the psu connected to the amiga - loading down the rails will be essential to get usable measurements..

The daughter board is just a "dumb" riser, and your A4K should work without it installed...

trixster 17 January 2017 15:16

Right, so taking out the mediator and putting the cbm zorro board in does not prove the mediator is broken because there might be a problem with the motherboard, or the psu, or both. I see. So even if elbox were to send a replacement mediator, at the moment we don't know whether that would work either.

trixster 29 January 2017 11:38

Right, there's a bit of progress at a last.

I've been away for a week so upon getting home last night I thought I'd give this one last try before sending it back as faulty.

lo and behold it worked. No green screen, both id's showing correctly in Expansion Boards. I've no idea why, I've not changed anything, but now the mediator and logic card seem to be fine. Very odd but good!

trixster 29 January 2017 12:08

However....... I now cannot for the life of me get my Voodoo 3 to display anything I set in Picasso96prefs.

I am pulling my hair out because half the time when I interrogate pciinfo I get the voodoo3 showing up, the other half of the time I just get No PCI card reported. And I'd say 80% of the time the machine will crash either when I double click the voodoo monitor driver or try and load picasso96prefs. If I do get into p96prefs successfully and attach the voodoo card to some settings, no matter what freqs I put in (I'm using the suggested freqs in my monitor manual) I always get a grey screen from the voodoo even though the screen is getting a signal from the card.

Steps I've taken so far:

1. Install mediator and logic board, check working in Expansion Boards
2. Install Voodoo card (I've tried all slots, top seemed best).
3. Run Install program off elbox cd, just install gfx and system stuff for now (but on occasions when I've installed sound and network drivers this has caused no issue)
4. Run the 2.5 update install
5. Updated pci.library to the latest version (11 I think)
6. Checked that voodoo.card is in LIBS:picasso96/
7. Run pciinfo - voodoo card shows up ok
8. Run MedConfig (version 2.something) and set buster to 11, set voodoo ram to 13 (all recommended settings basically).
9. Installed Picasso96 from the OS3.9 cd. I've also tried 2.0 off aminet and 2.1b. I've selected CVision3d as instructed in the elbox docs.
10. Run picasso96 install again (as instructed in the docs) and selected 31khz as I know my monitor is capable of this. Not sure if this is e right thing to do though - help here please?!
11. Changed the cybervision monitor driver to "Voodoo" and changed the BOARDTYPE to Voodoo, as instructed.
12. At this point it's a lottery if clicking on the voodoo monitor and then the picasso96prefs icon will crash the computer. If it doesn't and I can get into P96prefs I can attach the voodoo and a bunch of predefined resolutions comes up. Testing any of these just produces a grey screen on the voodoo output. Tweaking the settings to match the suggested frequencies in the dell 2001fps docs also only produces a grey screen. I've tried a second monitor - a viewsonic and this also does not display a correct test screen.

If I now save and reboot then the WB will load but I get a grey screen. The monitor is getting a signal because it doesn't go into standby. The only way to get into WB is either to reboot and hold down the right mouse button to stop p96 running or move the Voodoo monitor type out of Devs:monitors/

If I go into Screenmode having had a rare success at getting p96prefs to run and save, I can see the Voodoo Screenmode options, but selecting these to be used instead of HighGfx for the Indi will result in a grey screen. The voodoo is just not displaying anything

Some points to note:

1. I have an Indivision AGA installed which at the moment uses HighGfx. This is the only other monitor driver in Devs:monitors/ other than Voodoo.

2. Half the time pciinfo shows no voodoo card. It's a lottery if it'll show. Changing the slots sometimes works, sometimes not.

3. I have no other pci cards installed, but if I do try a network card and soundblaster then these show up 100% of the time with pciinfo, it's just the voodoo that's intermittent.

4. I have tried disabling things like fblit, Ftext, mcp, Tlsfmem etc to see if they are crashing Voodoo and/or p96prefs. I have tried removing HighGfx so the indivision is not getting In the way on boot.

5. I'm using an a3640 with 060 installed but it's at 50mhz, not overclocked. The kickstart roms are ones that have thr patch exec.library to allow the 060 to be used.

6. I have boingbags 1 and 2 installed. I'm using BlizKick to load updated libraries like PeterKs icon.library, hsmathslibs machine runs perfectly before I try any messing with Mediator.

7. I am reluctant to start a fresh 3.9 install but will have a go at that as a last resort.

8. A3640 and mboard have been recapped. I do not know if the psu has been recapped but that could be an issue - perhaps lack of power to the voodoo?

9. The Voodoo 3 was sold to me as working having come from a Prometheus setup but quite honestly there could be a problem with the card itself. I will try and buy a Radeon card and give one of those a try instead.

10. I have tried this with and without the ratte switch installed, so I don't think it's a problem with that. SwitchControl is in c: and is run during startup-sequence.

Please help! Am I missing anything obvious? Are there known conflicts which cause lock ups when using the Voodoo monitor driver or p96prefs? Can anyone see a crucial step in setup that I might be missing? Why does the machine crash when trying the voodoo driver or loading p96prefs? Why does it sometimes not crash?

After the problems I've had getting the mediator itself to work I'm seriously considering ditch a Mediator setup all together, it's just too frustrating!

Daedalus 29 January 2017 13:51

It still sounds like there might be some sort of poor connection somewhere, or bus noise or power supply issues. Have a look and see if any of the chips on the Mediator are loose. Maybe removing and reseating them will help, though don't remove them unless you have the proper PLCC puller. The power supply can be checked with a multimeter, but that won't show any noise on the power rails.

Also have a look for any dirty or bent contacts in the slots for the logic board. In particular, slight damage to contacts on the PCI side can be hard to see. I have an issue with corrupted graphics and random lockups on an A1 once that turned out to be a slightly bent pin in the slot used for the graphics card.

Not that it helps much, but it's normal for the AGA output to be grey when the Mediator graphics card is in use, so it might actually be sending the data to the Mediator, but just not displaying it. Do you have an old PC anywhere that you could try it in, to rule out problems with the card?

On the software side, it looks like you have everything covered, but is it a fresh P96 install or did you have an older Zorro graphics card in there before?

The Mediator is excellent hardware once it's up and running. Don't give up yet!

trixster 29 January 2017 14:00

New install of p96. I saved an image of my HD immediately before installing anything to do with the mediator, so I've been going back to that known good config when I've been starting again from scratch.

I'm convinced it's a connection or power issue too, else why would the voodoo keep dropping in and out of pciinfo? Plus the sound and net cards show fine in pciinfo when installed, which makes me think it's a voodoo issue. Detaching the CD-ROM does not help things though so that migh be something against a low power problem. I'm still not confident about checking psu rails, might ask a mate to come and help with that.

Doesn't explain why I get the voodoo double click or p96prefs crashes when the voodoo shows up with pciinfo though. Or why I can't get p96prefs to show a test screen on the occasions the voodoo is playing nicely in pciinfo....

I've tried removing PeterKs icon.library in case that was the issue - still no joy.

No old PC to try the voodoo in sadly. So I think the next plan is either to buy or borrow a spare voodoo or Radeon to rule out a gfx card problem

So annoying! I really don't want to have to spend yet more cash on this as its cost a bomb to get this far already!

And now the a4000 appears to be caput. Booooo

trixster 30 January 2017 12:57

I've managed to find another cheap voodoo 3, so when the A4000's back up and running I may muster up energy and enthusiasm to give this nonsense another try.

grelbfarlk 31 January 2017 02:00

As someone said upthread the fact that things work with the original daughterboard connected doesn't tell you much since you don't have any Zorro-3 devices installed. When you have the Mediator in it will initialize a Zorro-3 device which is the Mediator bridge. The Voodoo disappearing/reappearing act I have seen myself and heard others mention happening to them.

I have found a weird thing with the Mediator that the IDE controller sometimes causes havoc with the Mediator, thought mine was dead when all I did was plug in an IDE drive, which had a very large single partition on it when I had no updated scsi.device installed.

So anyway my advice since you're saying the A4000 alone seems to have problems now, I ask do you have a socketed Buster-11? If so give it a gentle push or remove it and clean it and the socket with some Isopropyl Alcohol. See if that changes the symptoms at all.

trixster 05 March 2017 18:57

1 Attachment(s)
I spent this afternoon trying again to get the mediator and voodoo to work.

Since last time I've had the buster taken out of the socket and mounted onto the m'board. The psu has been checked and is absolutely fine.
The motherboard has been recapped, the ram issues have been fixed.

So installing the hardware and everything seems fine. The mediator is always found in the early boot menu.

With pciinfo the voodoo 3 (this is a second card ive purchased to rule out voodoo problems) is always seen correctly. Previously it would come and go, so this suggests to me the psu/recap was a good thing to have done.

I've install the mediator drivers and p96 in accordance with the instructions on the mediator cd and with the various guides available.

However, as soon as I double click the voodoo monitor driver the machine will crash once i initiate any harddrive activity. I've tried disabling a load of stuff in my startup-sequence to see if there's a conflict but no matter what I do double clicking on voodoo prompts a crash.

Changing various settings in med_config makes no difference. The memsize jumper being open or closed makes no difference.

Any idea what might be causing this lockup? There must be a software conflict somewhere. I can't even begin to use p96prefs to see if I can start assigning Modesto the voodoo because of this lockup.

This is what snoopdos sees when voodoo is loaded:

Kin Hell 05 March 2017 19:31

Aside from the blurr, your Pic was upside down. :D


trixster 05 March 2017 19:32

Damn iphone!

All times are GMT +2. The time now is 16:39.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04586 seconds with 11 queries