English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   CF card not saving partitions? (http://eab.abime.net/showthread.php?t=103088)

scotchegg78 14 July 2020 12:09

CF card not saving partitions?
 
Hi all

UPDATE ***
NEED WINUAE SETTINGS OR RECOMMENDED PC COMPACT FLASH READER.

First time poster, new to the group as I am getting my Amiga all set for the my young lads education :)


I have an issue with 4GB CF card, I run disk clean, follow numerous online tutorials but always seem to get the point where the instructions are to reboot winuae and into workbench install again seeing the DF0 and DF1 drives on the desktop. However they are never there, so I again go into HD tools and all the partition work is gone, as if the save to drive did nothing?


I get no errors no messages and all appears to working fine untill this point?



Has anyone seen this before



Thanks
Pete

Juz400 14 July 2020 13:26

Have you started WinUAE with -disableharddrivesafteycheck?
I make a shortcut to winuae with
`D:\WinUAE4400_x64\winuae64.exe -disableharddrivesafteycheck` as the Target in properties

EDIT: Welcome to the forum, enjoy your stay!

Toni Wilen 14 July 2020 15:24

That option was removed years and years ago..

Make sure WinUAE has admin privileges. Some systems require it, some don't when accessing CF cards.

MattBOM 14 July 2020 15:32

Hi, new forum user here too. Used Commodore computers from age 4 to 18, mostly the beloved Amiga. Inherited my late uncles A1200 and want to give it the 21st-century treatment.

I have the same issue as Pete.

Running as Admin and using the shortcut switch -disableharddrivessafetycheck both make no difference.

The CF Card is seen each time can be partitioned using the PFS3 file system successfully but refuses to show the new partitions on reboot.

I have tried it using a 4GB card as well as a 32GB card. With both cards it is the same.

Completely bamboozled.

Any further ideas anyone? :confused

The process I am using is the same as this guide - https://johan.driessen.se/posts/Sett...miga-600-1200/

PS. Pete has commented on this guide too! Hi Pete! :great

scotchegg78 14 July 2020 15:42

Hey Matt

While sad for you I am happy to see I am not the only one with this strange issue.
I also start winuae in admin mode.

Could it be anything to do with the previous format disk type? As it turns out I am using a CF card in SFS format which I didn realise was already good to go with WB.31 already before I used disk clean on :).

MattBOM 14 July 2020 16:31

I would think that removing the CF partitions by using the clean command in DiskPart would just mean they are blank cards ready to use regardless of the original format.

I am wondering whether is has anything to do with how the CF is attached to the PC.

How is yours attached? I am using a USB 3 UGREEN multi-card adapter. Is your similar? Probably not relevant but curious if there are any similarities.

scotchegg78 14 July 2020 20:07

It seems we can both sleep easy tonight Matt.


I am also using the UGREEN USB3 card reader :banghead


Ok this is great news, so we need to get a reader we know works? Unless there are WinUAE configurations we need to to tweak for the card reader?

MattBOM 14 July 2020 20:17

OK. Good, and bad I guess.

Is it the reader or the controller? My setup is completely static and fixed together at the moment (cable tied and in trunking etc.) so I can't easily try the USB 2 controller for instance.

Can you access yours and see if there is any difference Pete?

Our findings will help other future Amiga fans with their CF woes!

UAE Devs might shed some light on it too.

scotchegg78 14 July 2020 23:09

I have tried both the USB 2.0 and USB 3 laptop ports, same issue.

Hopefully someone will re visit this page and help us with a PC compatible CF reader?

Toni Wilen 15 July 2020 10:24

I have never used (or bought) any PC hardware that is not manufactured by some known company. (Except when I had to confirm some reported issue. Not going to do it in this situation :))

My current reader is Transcend USB 3.1/3.0 but similar Kingston is also working fine. In my experience almost all USB 3 readers are based on some common chip and are almost identical (and none so far support ATA over SCSI = can't read CF card's identity data = card info and "geometry" can't match what real Amiga can read. Fortunately it isn't that important). Not sure why some readers work but some don't.

Unfortunately I can't help with these kinds of problems because WinUAE simply opens the device and uses normal Windows read/write commands to access it. It is almost same as accessing normal files. Perhaps the device firmware gets confused if write is too small or too large or tells Windows that "yes I support that" for feature that old Windows versions didn't even ask but now it does.. I have no idea.

You can check if winuae log shows any weird errors when writing partition data (-log command line parameter).

MattBOM 16 July 2020 23:44

Thanks for the reply Toni.

I have received another card reader today from Integral and I still have the same issue.

I will add the -log switch next time I try it and see if there is an error I can report back with, resolved or not.

thomas 17 July 2020 09:42

There are some more things to try:

1. disable your antivirus software
2. in diskpart after CLEAN enter CREATE PART PRIMARY followed by DELETE PART
3. after leaving diskpart use the remove device safely menu, unplug the reader and plug it back in
4. make sure that you always right-click winuae and select run as administrator

AMIGASYSTEM 17 July 2020 09:54

@MattBOM
On PC with a HardDisk management program tries to delete all existing partitions and make CF "raw".
On WinUAE after activating "RDB Mode" don't forget to tick "Lock".

MattBOM 20 July 2020 00:07

Still no joy I have followed all thje advice so far and still can't get the partitions to show. I have tried two different CF cards and two readers.

The only thing the log shows when I add the CF cards as a hard drive in UAE is the following -

IOCTL_DISK_GET_LENGTH_INFO returned size: 32019111936 (0x7747ce000)
IOCTL_SCSI_PASS_THROUGH_DIRECT: A1.08.0E.00.01.00.00.00.00.EC.00.00.
SENSE: 70.00.05.00.00.00.00.0A.00.00.00.00.20.00.00.00.00.00.
SAT: ATA PASSTHROUGH(12) failed
hd accepted, not empty and not mounted in Windows
HDF ':Generic STORAGE DEVICE 1206 000000001206' 0000000000142AA8 opened, size=31268664K mode=1 empty=0

Is that normal? Is the ATA passthrough failure causing the issue or is it always there?

:banghead:banghead:banghead

Toni Wilen 20 July 2020 13:18

It is normal. I don't know any CF USB readers that support ATA passthrough. WinUAE tests if it is supported and if it is supported, "read identity" button would read actual real data (This usually only works with real IDE/SATA/etc drives). It is not required for normal read/write access.

scotchegg78 28 July 2020 19:59

Hey Matt
Same issues here. However i noticed i can do very little with the CF card at the moment.
Windows when i plug it in does not pop up that annoying format message, and i cannot even format it. I trie cloning another CF card i image onto it and that also fails?

Is there something I can do to restore the CF card back to windows working order again and then try turning it back to amiga again incase the card is corrupt?

RichL 29 July 2020 13:17

Hi Scotchegg78.

I have sent you a pm to see if I can help you.

Rich

Gribnitz 29 July 2020 16:09

Same issue, but mine was trying to use a SD card using 3.1.4 with one 2GB and one 25GB partition. It did not like the 25GB, so finally gave up and accepted two 12GB partitions which it was defaulting too.

woodbino 30 July 2020 01:02

Hi all. I too am having very similar issues, but with SD cards. Have tried multiple cards of various sizes and from various manufacturers. Have now tried three different card readers. I am able to partition drives with HDToolbox, but on restart they disappear, as does all partition information. I get some luck very occasionally when they do appear, but when I create a bootable workbench and restart again... nothing.

I have tried the tool 'killpart' that amends the first 4 blocks on the assumption that there is a bug in FFS that results in the first four bytes of the first block of the partition contain 0xffffffff. This does then display the first partition (DH0) but the size is incorrect. Able to format it, but again on reboot it disappears.

At a complete loss now. Any help would be much appreciated.

scotchegg78 25 August 2020 12:45

Just a quick update, so RichL took hold of my CF card and gave it a firm talking too. Then returned it back to me in full working order :) What a superstar.

I have am not entirely sure what he did to get it working, but I do recall he mentioned he made one partition, saved it, then exited/back/save and returned and made the 2nd, rather than both at the same time?

Thanks again Rich.


All times are GMT +2. The time now is 20:41.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.06160 seconds with 11 queries