English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   project.MAGE (http://eab.abime.net/forumdisplay.php?f=76)
-   -   Gamebase and more WHDLoad problems :-/ (http://eab.abime.net/showthread.php?t=55106)

Hercules 12 September 2010 15:44

Gamebase and more WHDLoad problems :-/
Hello Im having problems getting WHDLoad installs working with Gamebase. I 've read the following threads, but they don't apply to my problem:- http://eab.abime.net/showthread.php?t=51665

I'm using Gamebase Amiga 1.6 (with the non beta version of James' Gamebase). Firstly, everything is working (apart from the WHDLoad installs). I followed the post setup guide, I can scroll down the games, screenshots are displayed, and I can launch adf images for A500 and A1200 games. All sets I verified from the Tools menu of gamebase, and their are no missing files!

The only problem is WHDLOAD installs are not working.
Install paths:

WinUAE is installed to: C:\Program Files\WinUAE
Gamebase is installed to: C:\Program Files\Gamebase
Gamebase Amiga 1.6 is installed to: C:\Documents and Settings\Gamebase Amiga Files

Winuae Configurations are installed to: C:\Documents and settings\All Users\Documents\WinUAE

^ I Chose the above install path to install gamebase Amiga 1.6 to the above location as that is where WinUAE stores it's configurations here by default, and since it is shared, it can be accessed by all users who log onto my XP machine via different user accounts.

WinUAE has been setup as followed (In WinUAE's settings -> paths I have defined are as follows):

System ROMs:
C:\Documents and Settings\All Users\Documents\WinUAE\ROMS\ Configuration Files:
C:\Documents and Settings\All Users\Documents\WinUAE\Configurations\ Screenshots:
C:\Documents and Settings\All Users\Documents\WinUAE\Screenshots\ State Files:
C:\Documents and Settings\All Users\Documents\WinUAE\Savestates\ Videos:
C:\Documents and Settings\All Users\Documents\WinUAE\Videos\ SaveImages:
C:\Documents and Settings\All Users\Documents\WinUAE\SaveImages\

If I select to list all WHDLoas games [2229], and press the Extras button and select 'WHDLoad', the WHDRun GUI program launches - I then click 'start game', and WinUAE then displays a box with the message 'The selected system ROM requires a 68020 or higher CPU'.

At this point, I click OK to this message, and then I see a dos window (of which in the title bar of the dos window is written C:\Program Files\WinUAE\winuae.exe - This WinUAE window is then displayed in front of the dos window, and highlighted is the Configurations tab, but yet their are no configurations listed within the configuration tab of WinUAE

Their are no WinUAE configurations listed, even despite settings the paths in WinUAE corrently for everything. I once got this working ages ago, but cannot for the life of me figure out why now it doesn't want to launch whdload games. If somebody can shed some light on this, I would be entirely greatful. I'm eager to get gamebase running on my HTPC I have just built for use in my lounge. Thanks all !

TCD 12 September 2010 15:57

Have you made sure the WHDLoad games are in the correct folder (http://eab.abime.net/showthread.php?t=30070) ?

Hercules 12 September 2010 16:14


Originally Posted by TheCyberDruid (Post 699619)
Have you made sure the WHDLoad games are in the correct folder (http://eab.abime.net/showthread.php?t=30070) ?

@TheCyberDruid Thanks for the quick response. Still no luck in getting this working. I've Checked the aforementioned thread you recommended I look at, and still the same problem: whdload games don't want to work (as I detailed in my above post).

WHDLoad installs are in my Extras directory, i.e. GameBase Amiga Files\Extras\WHDLoad so they are indeed in the right place.

Im using Winuae, since this version is used in the postsetup guide, so it has to work :)

I also have all the necessary kickstart files, i.e. kick 12.rom, kick13.rom, kick 31.rom and kick205.rom. WinUAE confirms the roms are found, so puzzled as to why things still don't work. :-/ If anyone wants me to upload some screenshots of whats going on, then let me know and I'll be happy to upload them to help deal with my query. Thank you.

TCD 12 September 2010 16:25

If your Extras path points to the WHDLoad subfolder that might be the problem. Set it to just 'Extras'. If that's already set it would be great if you could make a screenshot of the error.

Hercules 12 September 2010 17:14

3 Attachment(s)
Here are the screen grabs describing the problem (see attached files).
Screens have the filenames screen 1.png, screen 2.png and screen 3.png and are displayed in numerical order from left to right when I uploaded them....

screen 1.png
I selected 'Extras' and then chose 'WHDLoad'. This brings up whdrun. I then clicked 'WHDRun's 'Start Game' button. This then displays what is in screen2 (below)...

Their is some disk activity, then WinUAE displays an error message: 'The selected ROM requires a 68020EC or higher. When this error message is displayed, I click 'OK', which then displays screen3.png...

Then WinUAE's interface pops up with a black DOS window in the background. As you can see from this screenshot, their is not configurations listed in WinUAE's config menu, which has me somewhat puzzled.

Hopefully these screengrabs shed some light as to what on earth is going on. I have merely followed the Gamebase Amiga postsetup guide and haven't fiddled with anything, so am very confused why this is not working?!

TCD 12 September 2010 17:37

Strange. Can you attach your 'WHDLoad.uae' ?

Hercules 12 September 2010 19:12

1 Attachment(s)

Originally Posted by TheCyberDruid (Post 699637)
Strange. Can you attach your 'WHDLoad.uae' ?

Here is WHDLoad.uae. Gamebase Amiga installs WHDLoad.uae to the default path of C:\Program Files\Gamebase\Gamebase Amiga\

Hope the config helps to find a solution to my problem, as it's been driving nuts :D

TCD 12 September 2010 19:24

Also nothing wrong with that. I can't reproduce the error and I made a fresh install today. No idea if it'll help, but you could try a newer version of WinUAE (using 2.2.0 here).

You're on XP right?

Hercules 12 September 2010 19:41

Yep Im on XP with service pack 3 installed.

Guess I'll just have to try again and see what happens.

Thanks for trying to replicate the error CyberDruid. I will repost once I've reinstalled and retested again.

TCD 12 September 2010 19:42

You're welcome and good luck :)

Hercules 12 September 2010 23:41


Originally Posted by TheCyberDruid (Post 699664)
You're welcome and good luck :)

It appeared the spell of good luck worked... I installed the latest WinUAE release (2.2.0), then I stumbled upon a problem. Gmenu's setup wizard doesn't cater for newer releases of WinUAE. I overcome this using this method:- when the Gmenu's Setup wizard popped up, I simply selec the latest winuae version from the available list, by chosing 'select file', and then selected the path of the winuae executable. Once that was done, I could launch whdload games perfectly. Tip for getting games to launch in full screen using latest winuae.

The next problem was getting games to launch in full screen mode, rather than in a window. To do this, I exited gamebase, and launched WinUAE. In WinUAE's configuration page, I selected 'Load from' and loaded the WHDLoad.uae file into WinUAE, clicked the display tab, and changed native mode to 'full screen'. Once this had been done, I chose 'Save As' and rewrote over the WHDLoad.uae file in C:\Program Files\Gamebase\Gamebase Amiga\
Repeat the above paragraph for Gamebase Amiga.uae to get adf's to launch in full screen mode (and not windowed mode) and the jobs done. :)

Their was some discussion about editing gmenus script to get multi disk games to work when using newer releases of WinUAE under gamebase. This doesn't seem to be necessary in my instance, since upon launching the adf disks for gunship 2000, I can see all disk icons on the workbench. Thanks for the help!

TCD 12 September 2010 23:45

Good to hear it's sorted. Those hints about the newer version select and the config change method are here somewhere, but good to have it in one post :) Hopefully other people with the same problem(s) will find this thread :great

All times are GMT +2. The time now is 06:41.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.04336 seconds with 11 queries