English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   AmigaOS and AFAOS guide and suggestions (http://eab.abime.net/showthread.php?t=93221)

White 01 July 2018 20:51

AmigaOS and AFAOS guide and suggestions
 
Hi,
In recent times I have tried to make AmigaOS 4.1.1 work better.
I believe I have achieved everything I had set myself.
Thanks to the help and suggestions of many people. Thanks again!

I open this thread to start using the latest version of winUAE 4
The system that I will use will be AFAOS in its basic version and then proceed in the various game configurations and various applications.
There are many guides and videos on Youtube and also posts dedicated to the purpose.

But after a long time, thanks to the work of Toni, I have in my hands the most powerful amiga you can have.
A few years ago "AmigaSystem" introduced me to AFAOS I did not believe in my eyes when I started using it.
Having had a real amiga a long time ago, I finally got my hands on AmigaOS :-)

I hope this thread is useful for those who approach AmigaOS or those who already use it.
So any advice or improvement and always appreciated by me, because there is always something to learn :-)

A special thank you goes to Toni for your patience for my many questions
and for his great work, thanks to you I can use again amiga :-)

Ad AmigaSystem for introducing me to AFAOS :-)

And many thanks to Bernd Roesch for AFAOS :-)

This is just a base trying to avoid any initial blocks for those who start using it.
And then make all the changes you need.

Here there are many experienced people the purpose is to get the most out of AFAOS.

I hope the post is useful, if it's not a good idea I apologize, delete the post. Thank you

I will start with a basic installation to get this, I hope it will be useful

here the link:
https://youtu.be/GkWnLi8ctYA

DamienD 01 July 2018 21:03

Quote:

Originally Posted by White (Post 1251566)
I hope the post is useful, if it's not a good idea I apologize, delete the post. Thank you

...this thread will auto-delete in 30 minutes from now :cheese

No, well done and great that you are sharing your experience / knowledge with others who may be interested in AFAOS ;)

White 07 July 2018 19:41

1 Attachment(s)
Hi DamienD,
thanks, I hope the guide is useful.
This is the forum where Amiga remains alive even on PC x86 x64 and where there are experts and less experienced people.
The guide is aimed at both categories.
When it comes to AmigaOS 3.9, speech becomes difficult because there are many variations.
So the guide is to install AFAOS (version 4.8) on a system based on AmigaOS 3.9
There are many schools of thought on the type of installation that can be done.
This little guide is created to be as compatible as possible with the software and games and video you use.

I hope it is useful. Indeed I hope that anyone can modify and suggest the necessary improvements that can be made to this mini-guide.

Because AFAOS deserves to be used.

At the end of the guide we will have installed 3.9 with boing 1-2-3-4 with AFAOS 4.8 libraries necessary to run most games and software with WHDLoad using a 040 or a 060 with JIT etc.
Without encountering installation problems and system blockages.
Eventually each person can then make the changes he prefers with the system started up and running.
Making your own experience.
On the contrary, it would be nice to further improve this guide with the experience of the most experienced AFAOS users for a long time.
Alleghero 2 configuration files for winUAE one for the first installation in order to avoid system blockages.
And another for the use of the definitive system once everything is installed.

For those who prefer can download a compressed 30gigabyte .hdf blank ready to be used in the size of 1.6 gigabytes with SFS / 02 compatible with 3.9 / AFAOS.

Or use a personal .hdf with the filesystem you prefer.

Ok I hope it's useful, it would be nice to improve it further together.
I prefer videos, these are much clearer and simpler.

Thanks, the time to post the videos, unfortunately I do not have a video camera to make a single video, so I will divide it into several parts.
The important and that it works.
:-)

White 10 July 2018 00:07

Hi,
First complete part of the AFAOS installation guide with the latest version 4.8
Installation done with OS3.9 boing 1-2-3-4 and other libraries.
Test carried out with winUAE 4 beta 3.
I hope it's a good start, to better investigate this system.
The variants are many, this is the basis to start using all the software and games in whdload etc.
For those interested this is the basis.
Every single application can be updated, removed, or start making an idea.
Thanks, every suggestion is always appreciated.
In the next guides, we will see how to optimize everything etc.
Later I post the configuration etc.
I changed a few things, the configuration file is only one.
It works.
here the video, I hope it's interesting
Thank you!
see the next video in this post

seb132 10 July 2018 05:48

I’m exactly in the process of installing AfaOS and I’ve already prepared OS3.9 + BB1 to 4 all good on WinUAE4.
So your thread is great! I’m delighted to follow it. I’ll let you know how I went.
Ultimately I want to use the CF cards on a 060 A1200 desktop (AGA only) and on a high end A4000T with all the goodies (PIV all modules, Toccata, Deneb...).
Hope it works well. ;)

White 10 July 2018 12:35

1 Attachment(s)
Hi, seb132
I'm happy, which is useful.
here is the configuration file, if it can be useful, I noticed that using the 4000
you get some errors while with 1200 everything is fine.
But it depends on the libraries probably ??
It would be nice to have the opinion of other people.

And maybe even open a specific post to support the apps dedicated to AFAOS
this to improve everyone's experience.

Although there are many posts open, it would be useful to dedicate one directly to the support of AFAOS with all the updates and dedicated solutions, such as netsurf 68k
to watch videos on youtube etc.
This is to keep up to date with bug-fixes and new software updates.
(I read that there were problems with long names etc.)
But I can not find the post anymore, to document me :-)



The intervention of more experienced people would be useful to improve this emulation.
But this remains my idea :-)

If needed I can put as I said a 30gigabyte .hdf or a 2gigabyte in SFS / 02

But maybe there is no need.

At the moment this configuration is the best for AFAOS for me.
Just change the paths of your .hdf, rom .adf and .iso image of AmigaOS 3.9.

I attach it so that it can be used and eventually improved for 3.9 and AFAOS

Thanks again for every possible suggestion.
I hope that what I write is useful to improve the experience of all the people who use AFAOS.

Amigaos and always Amigaos :-)

seb132 11 July 2018 08:44

Okay, all works but when I use your config file AfaOS freezes in the middle of the WBStartup loading. Everytime.
I just changed the processor from 68040 to 68060 and it worked!
Cool. :spin

White 11 July 2018 10:15

Hi, seb132
Good :-)
If you can make the latest version of netsurf work with youtube let me know.
I still have not tried. I should do it today.
I'm creating backups to add AFAOS to real partitions.
Thank you!

seb132 11 July 2018 12:33

So you will use this setup on real hardware?

White 11 July 2018 17:26

@seb132
Excuse me, I do not have any real hardware.
I wrote badly, I meant this, I only use the dedicated partitions with the various AmigaOS.
Unfortunately, the hardware broke down many years ago :-)

https://www.youtube.com/watch?v=20KPrIuHMPE

White 12 July 2018 12:21

1 Attachment(s)
Hi,
It was a long time since I was using AFAOS.

Today I realized I was wrong the little tutorial during installation on real partition.

"I used version 1.3 of the AFAOS package instead of version 1.4"
The procedure is the same for the installation but some things change.

I apologize for this, it is right to clarify it, I do not like to make the wrong guides!

Here is the right post with the right advice.
http://eab.abime.net/showpost.php?p=...3&postcount=69
:-)

As soon as I have time I will make a new video always updated to version 4.8 and add other things.
:-)

White 20 July 2018 19:10

Hi,
This guide is right. :banghead :crazy

I thought there was a new version of the 1.4 package
Actually I realized that 1.3 is the right one to be then updated to 4.8
as in the tutorial I created.

DamienD, thank you for your patience, if you think it is right, delete the post and forgive me again.
:D

DamienD 20 July 2018 19:12

Quote:

Originally Posted by White (Post 1255584)
DamienD, thank you for your patience, if you think it is right, delete the post and forgive me again.
:D

It's your thread, do what you like ;)

AMIGASYSTEM 20 July 2018 19:44

Nice work Paolo, if you need a nice utility for AfA-OS style AmiDock try PolyNet NG, i talked about it HERE

White 20 July 2018 20:29

Hi AMIGASYSTEM,
thanks for the advice, I will certainly follow your suggestions,
these days I was understanding what was wrong.
In the end I realized that the 1.4 package was not good for me.

I hope you can suggest your experience with AFAOS in this post.
Hello and thanks.
Thanks also to you DamienD

gulliver 20 July 2018 23:48

Since you are talking about PolyNet NG, I made a simple tutorial about it:

http://lilliput.amiga-projects.net/P...NG/polynet.htm

I hope you find it handy.

James 21 July 2018 02:28

Quote:

Originally Posted by White (Post 1255584)
I thought there was a new version of the 1.4 package
Actually I realized that 1.3 is the right one to be then updated to 4.8
as in the tutorial I created.
:D

1.4 already includes 4.8.

Quote:

Originally Posted by White (Post 1255599)
In the end I realized that the 1.4 package was not good for me.

Why? 1.4 is just 1.3 with updates and a few extras.

AMIGASYSTEM 21 July 2018 09:37

Quote:

Originally Posted by gulliver (Post 1255638)
Since you are talking about PolyNet NG, I made a simple tutorial about it:

http://lilliput.amiga-projects.net/P...NG/polynet.htm

I hope you find it handy.

Thank you gulliver, only problem encountered is that i can not save "without" the DraBar, after saving when restarted, the DraBar returns

gulliver 21 July 2018 18:38

Quote:

Originally Posted by AMIGASYSTEM (Post 1255661)
Thank you gulliver, only problem encountered is that i can not save "without" the DraBar, after saving when restarted, the DraBar returns

I have the exact same issue.

It seems it is a bug.:(

I will try to contact its author.

AMIGASYSTEM 22 July 2018 13:23

Thank you gulliver ;)


All times are GMT +2. The time now is 17:39.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.04571 seconds with 11 queries