English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Guide: WinUAE PPC OS 4.0 Classic Install Guide (Beta 12+) (http://eab.abime.net/showthread.php?t=74776)

BinoX 19 August 2014 16:15

Guide: WinUAE PPC OS 4.0 Classic Install Guide (Beta 12+)
How to install OS 4.0 Classic on WinUAE PPC

Please Note: PPC Emulation is in Beta. The quality of your OS 4.0 Classic installation under emulation in no way reflects on how it runs on REAL Amiga/AmigaOne hardware.
As a previous AmigaOne owner, I can assure you that Amiga OS 4.0 runs extremely smoothly and with a lot more stability than it does under emulation, where there are quite a few features that do not work as they do on real hardware.

This installation guide is written using MY experience of installing OS 4.0 Classic. There are probably many ways of getting this to work, but this is the method that I have used and know that it is possible. This method (At least part 1 and 2) will probably work for OS 4.1 Classic as well, but I do not own a copy to try it out.

I have gone through this guide step-by-step and done an additional setup myself, so I know that it works. If you are having problems, please check that you have followed ALL the numbered steps detailed below before asking any questions. I will try to get back to people as soon as I can about any issues.

Details about my computer system: (in case it matters)
Core i7 2700K
Nvidia GeForce GTX 560

Emulation runs at a fairly reasonable speed considering what is being done, but don't expect a mega fast, use-for-everyday-tasks system.

The parts are going to be divided up into seperate posts in this thread.

Preparation, Configuration and Installation are the main 3.

I will reserve a post below that for OS 4.0 configuration (for things like networking) and tips and tricks that I have figured out. I hope to have this done in the next day or so. I doubt it will be done today, as I have work and a girlfriend to occupy my time as well.

The post below that will be reserved for FAQs

I give great thanks to Toni Wilen for making PPC emulation in WinUAE possible.

Updated Part 2 with a precautionary step (14a)
Replaced attached config file with correction (thanks to themamboman for pointing out that it was the wrong file)
Guide tested for Beta 13 and still working.
Added step 7a (thanks to AMIGASYSTEM for pointing out that this option was there)

BinoX 19 August 2014 16:16

Note: Part 1 is not needed since QEMU PPC core was added. The hard file can be partitioned and formatted using OS4 installer.

Part 1 - Preparing the hard file
Due to a few problems with emulation, the Partition Manager that comes with OS 4.0 does not function correctly. Also, due to reason I am not quite sure of (this may be my fault) I cannot get hdf to parition properly when PPC emulation is set up, so we'll go through the steps that I used to work around it. This will obviously be easier if you are installing OS 4.0 onto a real Amiga, as you can do everything from the boot disk.

These instructions may seem a little patronising in places, but I am being overly detailed as this is a step- by-step.

1) Launch WinUAE

2) On the quickstart page, select A1200 as the model and Basic non-expanded configuration.

3) Go to the CD and hard drives tab

4) Click "Add Hardfile"
5) At the bottom of the window there is a section titles "New hard disk image file". Type "2000" in the MB box
and click Create.

6) Naviagte where you wish to save the hdf file, give it a name and click save. (Remember where this is as you will need it later)

7) Change the "HD Controller" to IDE, 0

8) Click "Enable RDB Mode" and then click OK

9) Go to the floppy drives area and put the Workbench 3.1 install disk in DH0 (I'm assuming you know how to do this. If not, that is beyond the scope of this guide)

10) Click Start

11) Wait for Workbench to appear and then double click on the "Install 3.1" disk icon.

12) Go into the HDTools drawer

13) Launch HD Toolbox

14) Click "Change Drive Type"

15) Click "Define New..."

16) Click "Read Configuration" and then click "Continue" when the prompt appears

17) Click OK and then Click Ok again in the next window

18) Click "Partition Drive"

19) Click "Default Setup"

20) Click "Ok"

21) Click "Save Changes to Drive"

22) Click "Exit"

23) Press Ctrl + Amiga + Amiga to reboot the machine

24) Wait for Workbench to appear again. There will now be (possibly after a short delay) 2 NDOS devices.

25) Quick Format both of the NDOS devices. (I formatted UDH0 as DH0 and UDH1 and Work) - Explaining the formatting of drives is beyond the scope of this tutorial. I may follow up on that if there are enough questions.

26) Close down WinUAE

That is the end of Part 1 of the tutorial.

BinoX 19 August 2014 16:17

1 Attachment(s)
Part 2 - Configuring WinUAE Settings
Please Note: These are only the most basic of essential settings detailed here (plus the enabling of a network card) I will go back through this tutorial at some point and add some optional setting to improve the user experience.

1) Load WinUAE

2) In Quickstart, change the model to A4000 and the configuration to 68030, 3.1 ROM, 2MB Chip + 8MB Fast

3) In "CPU and FPU" change the cpu to 68060 and tick the PPC box.

4) In "ROM" make sure that the Main ROM file is set to KS ROM v3.1 (A4000) - I use the Cloanto ROMs from Amiga Forever

5) In "RAM" there is a dropdown box with a "-" in it. Change this to be Cyberstorm PPC, set the Accelerator board memory to 128MB. Set Motherboard Fast to 0mb (none). Also Untick "Autoconfig Z2 fast ram" and "JIT Direct compatible Z3 memory mapping".

6) Next to "Accelerator board ROM File" click the "..." and select the "cyberstormppc_44.71.rom"

7) In "Expansions" select the Picasso IV Zorro III card. Enable the A2065 Z2 (in the bottom right) and select "SLIRP + Open Ports"

7a) Still in "Expansions". Make sure "uaescsi.device" is unticked.

8) In the "CD & Hard drives" section click "Add hardfile"

9) For the path, set it to the location of the hard file you made in part 1 of this tutorial.

10) Set the HD Controller to IDE, 0 and then click "OK"

11) Click "Add SCSI/IDE CD Drive"

12) Change HD Controller to IDE, 1

13) Click "Add CD Drive"

14) Configure the CD Drive to either point to a physical CD Rom drive on your machine with the OS 4.0 Classic CD in it OR Select an iso image file. (I personally used the CD the first time and the ISO for this walkthrough, so I know that both work)

14a) Make sure ALL THE TICK BOXES in the options area are unticked.

15) In "Floppy Drives" insert the Amiga OS 4.0 boot floppy into the drive.

(I will attach my configuration file to this post also)

17) Click "Start" to begin emulation.

18) Wait (a long time) for the OS 4 setup workbench to display. During this you will see a brief blue screen, a flashing rainbow screen and a pink screen. It will then be black for quite a while.

This is the end of Part 2 of the tutorial. - Part 3 will be a basic guide to installation - but very very basic.

BinoX 19 August 2014 16:17

Part 3 - AmigaOS 4.0 Classic Installation.

This tutorial continues on directly from the end of Part 2

Please remember that PPC emulation is currently very basic and slow. So there may be quite a wait between some of these steps and there may be long waits before windows are responsive.

1) Click "Proceed"


2) Select your language from the displayed list. (I have only tried British English so far)

3) Go to the Country tab and select your country

4) Go to the Time zone tab and select your time zone.

5) Click "Use"


6) Click "Proceed"


7) Select your Keyboard type from the list and click "Use"

8) Watch a very basic workbench Window appear

9) Double Click "AmigaOS4-Installation"


10) Click "Next >"

11) Read the licence agreement and then tick the "I have read and agree to the license agreement" checkbox

12) Click Next

13) Select "Amiga 4000" (if it is not already selected) and then click next

14) Click Next.

15) If the drive you want to install to (Which should be UDH0 if you have been following this tutorial all the way through) is not selected, then select it.

16) Click Next

17) Change the graphics card from "AGA" to "Picasso IV" and click next

18) Select your desired resolution (I chose 800x600@60)

19) Untick the Load the "cybppc.device" and click next

20) Click Next

21) Click Next

22) Click Next

23) Watch OS 4.0 install. It may pop up with a box some time during install asking if you want to overwrite files. Click "Always overwrite"

24) Continue to watch... (Or go and get some food, or sleep, or do something other than watching progress bars for a while)

-- very long wait--

25) Click Next

26) Click Finish

27) In the UAE menu click "Restart" and then reload your configuration - there seems to be a problem with doing a soft reset under emulation

28) Eject the CD and OS 4.0 Boot floppy.

29) Start the emulation

--long wait--

30) Enjoy your OS 4.0 classic emulated installation

BinoX 19 August 2014 16:18

Part 4 - OS 4.0 Configuration

There instructions will be a lot more basic than the usual instructions and some knowledge of OS4 is assumed.

If you have any problems with these instructions, please do not hesitate to ask.

Link to supporting adf file: http://www.apidya.net/Guide-Files.adf

On the support floppy:
  • lha.lha - from OS4depot
  • wget-OS4 - from OS4 depot and extracted to fit on adf
  • Ethernet.lha - from Aminet

Installing Guide Support Files

1) Load WinUAE and boot to your OS4 installation.

2) Insert the supporting adf file (link above) into DF0:

3) Double click on the DF0 / "BinoX Guide Files" icon to get the listing of the drawer.

4) Double click on "lha.lha"

5) Set destination to C:

6) Untick lha.guide and lha_os4.readme

7) Click Start

8) Once extraction is complete, click quit

9) Copy "wget-OS4" to C:

10) Guide support files are now installed

Installing Network Card Support

1) Load WinUAE and boot to your OS4 installation.

2) Insert the supporting adf file (link above) into DF0:

3) Double click on the DF0 / "BinoX Guide Files" icon to get the listing of the drawer.

4) Double click on "Ethernet.lha"

5) Once UnArc has loaded, set the destination to "Devs:Networks"

6) Untick "readme.dev" and click start

7) Once the extraction is complete, click "Quit"

8) Open up your workbench drive and go into the "Prefs" drawer

9) Double click the "Compatibility" icon

10) Click "Add"

11) Navigate to "Devs:Networks", click "ethernet.device" and click "OK"

12) Click Save

13) Close all open windows.

14) Open up your workbench drive and go into the "Internet" drawer

15) Double click "New Connection"

16) Choose "Ethernet (Lan, Router, Cable modem)" and click Next

17) Select "Manual Configuration" and click next.

18) Scroll down until you see the "Commodore A2065" listing with the "ethernet.device" listed next to it, and then select it.

19) Click "Test this configuration"

20) It should say that the configuration test was passed. Click OK.

21) Click Next

22) Click Next

23) Untick "Store report in file"

24) Click Finish

25) You can close the console window now if you want

26) Networking is now set up. It is a little bit useless at the moment, as iBrowse currently doesn't work under emulation (written at time of Beta 13) but this will be solved in another step of the guide!

Installing a web browser (that works)

1) Complete the guide steps "Installing Guide Support Files" and "Installing Network Card Support" first

2) Open Shell

3) Navigate to the place that you want the browser to be installed to (e.g. "Work:" - It will automatically

create a subfolder)

4) Type "wget-OS4 -O aweb.lha http://www.os4depot.net/share/network/browser/aweb.lha" (not including quotes) and push enter/return

5) Wait for download to complete. (Occasionally, but rarely, this will fail. If it does, try again)

6) type "lha exa aweb.lha" (not including quotes) UnArc causes a divide by zero fault with some archives and

crashes the PPC atm - hence using lha from the shell

7) Wait for the extraction to complete

8) Close the shell

9) Open the Drive/Drawer where you extracted aweb.lha and go into the AWebPPC drawer

10) Double click "AWeb"

11) This will take a while to load - the "Loading fonts" part takes a long time

12) Enjoy using a browser on your emulated Amiga OS 4.0 - You can now use this to get whatever files you want from the internet and use UnArc (or lha from the shell if it crashes the emulation)

Tips and Tricks
  • UnArc sometimes crashes the PPC emulation - use lha from OS4 depot (or the support floppy linked above) for troublesome archives.
  • IBrowse does not work under emulation. I recommend using AWeb (from OS4depot) for general browsing. OWB does work, but is slow and runs out of memory quickly.
  • After following the Support files, Network Install and browser install guide you can easily download the OS 4.0 classic update from Hyperion and install it. - Tested and working fine.
  • AWeb downloads faster if you don't tell it the download location until after the download progress bar has finished

BinoX 19 August 2014 16:18

Reserved for FAQ

Nickman1200 19 August 2014 21:56

Thank you for this exellent guide. Worked right away without problem.

BinoX 19 August 2014 22:34

You are very welcome. Glad it's been useful :)

DarrenHD 19 August 2014 22:44


Originally Posted by BinoX (Post 970787)
[ OWB does work, but is slow and runs out of memory quickly.

You can add Zorro 3 memory to the emulation for OS 4.1 Classic (at least) will use it as a memory pager and help with OWB.

Use the "memstat" command from a shell it will tell you if the zorro memory pager is active. It showed up on my setup after I added 256MB of zorro 3 memory.

Note that 68K programs cannot use pager memory.

DDNI 19 August 2014 23:12

Thanks for this great guide.
It is worth highlighting that the best version of Classic AmigaOS4 is 4.1. It fixes many issues in AmigaOS4.0.
If anyone is going to buy AmigaOS4 then 4.1 is the only way to go.

themamboman 19 August 2014 23:25

I used the config file provided in this thread and I think it was still showing the Z3 JIT memory option checked in the RAM page. Is that okay? I turned it off as earlier versions said that was a problem.

Installing os4.1 took over 45 minutes.

BinoX 19 August 2014 23:36

Yeah, that's how it should be... I must have uploaded the wrong config file, I'll fix that when I get to my home pc next... Thanks for letting me know.

The Z3 jit causes the Picasso IV to usually not work

Update: Config file has now been updated

themamboman 20 August 2014 15:55

In Part 2, #7, it says to enable 2060 Z2 (that's A2065, right?) Is this for eventual network support? I can't get the internet wizard to detect/open Commodore A2065 network connection.

BinoX 20 August 2014 16:13

yeah, it is supposed to say A2065 :) Correcting that now.

No, the network card doesn't work straight away from a fresh install... It's quite awkward since you need to get a file from aminet to get it to work in the first place. Instructions on that are coming as soon as I get the chance. (Although if I have time when I get back home, I will put the file inside an adf to make it easier for people)

themamboman 20 August 2014 17:41

Thanks! Looking forward to the update.

I've never used the A2065 option in WinUAE. Does this map to a physical ethernet connection? I only use wireless on my desktop. For this to work, would I need to use a wired connection then?

Mad-Matt 20 August 2014 18:23

If you want to get ahead of the guide the information is here on general setup. http://eab.abime.net/showthread.php?...id=4&styleid=1

You may be able to set the a2065 to a dedicated connection, but if you set the slirp open ports option , the emulation will attach it self to your current network (putting it simply)

BinoX 21 August 2014 12:42

Network setting tutorial should be coming tonight. Girlfriend is working late, so I'll have a bit of time to sit down and work on it.

I may simplify it by adding an ADF with some required tools in it. Or would people like the full (and somewhat lengthy and complicated) instructions instead?

Also: Could a mod change the title of the thread to end in (Beta 12+) instead on Just (Beta 12) I change the post title, but the topic title stayed the same

prowler 21 August 2014 23:53


Originally Posted by BinoX (Post 971250)
Could a mod change the title of the thread to end in (Beta 12+) instead on Just (Beta 12) I change the post title, but the topic title stayed the same

Done. :)

Thanks for your sterling work on this guide. :bowdown

fitzsteve 22 August 2014 01:10

@Prowler, maybe you will finally get to try that OS4 Classic you bought all those years ago!

prowler 22 August 2014 01:17

You must have read my mind, Steve! :)

All times are GMT +2. The time now is 03:25.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.

Page generated in 0.07515 seconds with 12 queries