English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   SCSI2SD v6 and large drives (http://eab.abime.net/showthread.php?t=94530)

Englyst 05 October 2018 20:21

SCSI2SD v6 and large drives
 
Hi folks.

I've been sitting here playing with my new SCSI2SD v6 and I really like it. But unfortunately not everything is rosy in regards to utilizing a 32 GB Sandisk Extreme card.

SOLVED!
A bug in the USB interface made a hard limit of 4 GB across drives. That has been fixed and I bet the new firmware will be released soon.

I'm happy .... :crazy :D

My setup is as follows:

Amiga 2000
Oktagon 2008 Rev. 7 controller (with no memory added and OctaPussy driver saved in RDB)
Commodore A2091 (with 2 MB memory)
Gotek Floppy drive as DF0:
Normal Amiga floppy drive as DF1:
32 GB Sandisk Extreme SD card
SCSI2SD V6 firmware 6.1.4
Workbench 3.1.4 (using the ROM on WinUAE and LoadModule on the A2000)
FastFileSystem 46.13 on all drives (no long filenames with DH0:)
Using WinUAE 4.0.1 (2018.07.16) 64-Bit for the PC part of the setup.

The brilliant thing is when the SD card has been setup on the Amiga 2000, then I can directly attach all three 'physical' drives via WinUAE and boot my configuration there and setup some of the heavier stuff where performance is better. Just by shutting off the A2000 and connectiong the USB cable to my PC, running WinUAE with administrative rights I can see all three drives with RDB.

Large drive definition:
http://www.polkabrothers.dk/amiga/SC...Definition.jpg

WinUAE HD setup:
http://www.polkabrothers.dk/amiga/WinUAE-HDSetup.jpg

Oktagon WinUAE setup:
http://www.polkabrothers.dk/amiga/Ok...nUAE-Setup.jpg

I cannot use the OctaPussy ROM file withing WinUAE - no drives are shown, so I still use the 6.12 ROM file and the RDB driver takes care of the update.

Drives after they're corrupted:
http://www.polkabrothers.dk/amiga/Dr...corruption.jpg

PFS3AIO Error when copying:
http://www.polkabrothers.dk/amiga/PFS3-Error.jpg
http://www.polkabrothers.dk/amiga/PFS3-Error2.jpg

Drives:

1st SCSI Drive Unit 0:
DH0: 1024 MB (Direct SCSI Transfer ON, Identifier: 0x444F5303, Mask: 0xFFFFFE, MaxTransfer: 0xFFFFFF)
Status: Works well

2nd SCSI Drive Unit 1:
SCSI CD-Rom

3rd SCSI Drive Unit 2:
DH1: 2044 MB (Direct SCSI Transfer ON, Identifier: 0x50445303, Mask: 0x7FFFFFE, MaxTransfer: 0xFFFFFF)
Status: Works well

4th SCSI Drive Unit 3:
DH2, DH3 and DH4 split up in the 26 GB space, tried one big partition as well, and tried PFS3AIO (latest version). Everything eventually gave me issues.
Status: Wonky

HDD Report from my Amiga 2000:
http://www.polkabrothers.dk/amiga/hddreport.txt

The SCSI2SD utility has been used to setup the options according to another thread here at the board and it works.

So every time I try to copy something onto the large drive of any substantial size (a lot of WHDLoad stuff) I suddenly get errors and the drives disappear. When I tried PFS3AIO I got several out of bounds messages and the drive would then be corrupt. I had to save the drive definitions onto the drive again, repartition and try again. So far no luck. It seems I'm hitting a barrier at some point (4 GB?) and when I partitioned the drive into 3 partitions, the last drive would cease to work entirely.

The reason for the 3 partitions on the large drive with FastFileSystem is that it cannot validate the drive when I'm using it as one big partition - ran out of memory. PFS3AIO gets around that issue but is has the same fundamental problems with my setup.

Can anyone here see what I'm missing to get this to work?

I'll happily supply more information if needed.

Thanks :)

EDIT: Added PFS3 error image and HDD Report.

Englyst 07 October 2018 17:27

Just a note - I've updated the SCSI2SD v6 to firmware 6.2.0 and have exchanged my old 32 GB SD card to a brand new 64 GB Sandisk one.

So no one got any suggestions for me to try? I'm about to give up on this. :(

trixster 07 October 2018 17:50

I gave up on the Scsi2sd v6 on my a3000 and went back to the v5. V6 in both async and sync modes caused all sorts of problem even with the latest firmware. Better off with slow but reliable. The v6 now resides in my parts bin as I don’t trust it with anything.

Englyst 07 October 2018 17:57

Thanks. That's not encouraging :( Guess I have to shelf it for now. I am in contact with Michael McMasters and hope that it will work at some point.

I'll probably get a V5 then instead.

Once again, thanks for the feedback - been fighting this for days :D

trixster 07 October 2018 18:40

I’d love to get my v6 working but I tried everything I could. I hope it was user error on my part!

/edit you have inspired me to try again with my v6 :)

Englyst 07 October 2018 19:36

I hope Michael McMaster will be able to understand the problem and hopefully come up with something that can fix it. It is a great piece of kit - just a pity it doesn't work.

I have tried sooo much this last week :p For now I'm keeping under the 4 GB total limit for now so it works.

Englyst 08 October 2018 03:52

Trixter - there might be a light at the end of the tunnel. Just heard from Michael McMaster - nothing concrete yet but he had an idea as to what might be wrong. :)

I'll let you know as soon as I have something to report back.

AMike 08 October 2018 08:21

Look at my thread on a1k. It's in german but I think the screenshots with the settings are helpful. The SD card only works reliably if it is initialized and partitioned in the SCSI2SD on the Amiga. Setting it up via USB (also on real Amiga) led to read errors.

https://www.a1k.org/forum/showthread...hlight=SCSI2SD

Englyst 08 October 2018 11:08

Unfortunately I don't have an account st a1k.org ??

trixster 08 October 2018 12:04

Unfortunately i dont seem to be able to update the firmware anymore. The update process ends in failure with the pop-up stating "no dfu capable usb device available". I've tried installing the drivers from the codesrc.com website but the install process does not seem to actually take place. I've tried this on two different W10 pcs. I dont recall having such problems before... There's some poor instructions in the scs2sd quickstart guide about using a program called zadiag to remove "STM32 BOOATLOADER" device but no actual instructions on what to do.

Any advice? I'm currently stuck on firmware 6.1.2

I've actually installed the scsi2sd into my A3000 and am testing it now. This is using async 3.3mb, scsi2. It seems ok at the moment. No read or write errors so far on the sd card.

Englyst 08 October 2018 15:48

I had to install Linux to get the firmware upgraded. Had a spare HD laying around that I used for it. Windows 10 is b0ll0cks for that.

But just heard from Michael McMaster - he has no issues in writing above the 4 GB limit so back to the drawing board.

Englyst 08 October 2018 15:52

Quote:

Originally Posted by AMike (Post 1274947)
Look at my thread on a1k. It's in german but I think the screenshots with the settings are helpful. The SD card only works reliably if it is initialized and partitioned in the SCSI2SD on the Amiga. Setting it up via USB (also on real Amiga) led to read errors.

https://www.a1k.org/forum/showthread...hlight=SCSI2SD

Thanks. I have done all the setup of the card directly on the Amiga 2000. Basically I wanted to use WinUAE for large transfers and occasional installation of programs and such.

But I'm not giving up on it. There has got to be a proper way of setting this up so it works.

Englyst 08 October 2018 15:59

Quote:

Originally Posted by trixster (Post 1274991)
Any advice? I'm currently stuck on firmware 6.1.2

Try downloading an Ubuntu ISO and use Rufus to throw it onto a USB stick and boot it. Should be enough and you can download the firmware and utility once you're booted up.

I'm keeping that harddrive if I need to upgrade again. It's just a swap away.

trixster 08 October 2018 16:49

I've tried it on a raspberry pi (debian) and it still wont update, alas.

Englyst 08 October 2018 17:48

That's weird. Did you install the dfu-util with "apt install dfu-util"?

Englyst 08 October 2018 18:27

So I did another HDDReport and it came out different. Now the large drive says "Data at risk".

You can see it here:
http://www.polkabrothers.dk/amiga/hddreport-v2.txt

So why did that change? The drive contains 800 MB data so it's close at the 4GB total limit for all drives.

I've redone the partition, made sure that pfs3aio is installed as filesystem, clicked 'Direct SCSI' to avoid controller issues. All done on the Amiga and not WinUAE.

How can I make sure that the card is wiped so I can start from scratch? Put it in the PC and wipe it? I want a clean slate this time and then I'll reinstall Workbench 3.1.4 from scratch.

trixster 08 October 2018 20:40

A3000 has started having read errors when booting windows. I think the experiment might be over, time to reflash the backup image.

Englyst 08 October 2018 21:11

Strange, I never had read errors, I just had problems with large partitions. Did you get it flashed to 6.2.0?

trixster 08 October 2018 21:36

No joy on updating it.

Englyst 08 October 2018 22:48

Contact Michael McMaster for some help. His site it here - just use the contact details:

http://www.codesrc.com


All times are GMT +2. The time now is 03:54.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.06015 seconds with 11 queries