English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Apps (http://eab.abime.net/forumdisplay.php?f=8)
-   -   What files represent OS 3.5/9's icon support? (http://eab.abime.net/showthread.php?t=22139)

MethodGit 01 March 2006 00:21

What files represent OS 3.5/9's icon support?
 
Apart from newicon.library that is?

I ask because I want to see if it's possible to transfer OS 3.5 icon support over to 3.1-based setups like ClassicWB. Apparently copying the library alone won't work for some reason. So I thought I'd ask anyone here with 3.5/9 knowledge for help on this one if possible.


Cheers!

Frog 01 March 2006 01:31

newicon is ONLY for newicons, it doesn't have anything to do with OS3.5+ icon.
Basically you need icon.library of OS3.5+

It's a bit complicated to display OS3.5 icons on 3.1 by yourself, i'd suggest to use latest Scalos which handle to display OS3.5+ icons under 3.0

MethodGit 01 March 2006 01:41

Latest Scalos? I thought it wasn't capable of displaying OS 3.5+ icons so far.

I think ClassicWB uses Scalos, and that can't display them properly!

Frog 01 March 2006 14:30

from Scalos webpage history :

--- glowiconobject.datatype (V40.3) ---
V40.6
Bugfix: CoerceMethod() in OM_NEW could lead to enforcer hits if object could not be created
V40.5
Improvement: Reworked icon saving code, now it is possible to correctly save a modified icon image
V40.4
Bugfix: Added size checking for icon BitMaps, to fix a major memory trashing bug triggered by thumbnailed icons
Improvement: icons can now be scaled
V40.3
Bugfix: saving of interior window offsets (dd_CurrentX/dd_CurrentY) didn't work
V40.1
Bugfix: Datatype now calls "UpdateWorkbench" function after saving glowicon data.
Bugfix: Relaxed strict image size checking - some icons could not be read.
Initial version. This datatype adds support for OS3.5+ GlowIcons even when running under OS3.1.

MethodGit 01 March 2006 18:38

Hmmmm, I tried copying the datatypes from the newer Scalos beta into ClassicWB, and it still won't display 3.5+ icons! Maybe I need to use 3.5's SetPatch and PatchFile as well?

Mad-Matt 01 March 2006 19:55

why not get rid of classicwb and use 3.5/3.9 and one of the few workbench mod packs ? youll have full coloricon support and a nicer system to boot. Classicwb really does look abit naff compared to any upgraded amiga still in use today.

Retro-Nerd 01 March 2006 20:39

Use AmiKit or Amiga Sys 3, the best solution for emulated amigas.

http://amikit.amiga.sk/

http://amigasys.fw.hu/

Bloodwych 01 March 2006 20:57

Quote:

Originally Posted by Mad-Matt
why not get rid of classicwb and use 3.5/3.9 and one of the few workbench mod packs ? youll have full coloricon support and a nicer system to boot. Classicwb really does look abit naff compared to any upgraded amiga still in use today.

Yes it does! :laughing You've got me there!

A bit of a copy paste job from the other thread, but it's silly to write out again:

Quote:

To be honest, the ClassicWB isn't made to look "good". It's a base install for real and low end Amiga's (2MB RAM and above) with 3.0 or 3.1 ROMS. It's meant to look like an Amiga workbench from the A1200 era for retro/nostalgia reasons. Also "look" is very subjective so I let the end user customize to their taste rather than force patches and hacks upon them that often cause incompatibility issues. I simply provide the fundamental building blocks of a very user friendly accessable system.

It's certainly not or ever will be an eye candy Winuae beast; that would kind of defeat it's objectives. The P96 version was done only because it could be done and again only as a base install, not a complete eye candy package like AIAB, AmigaSYS or AmiKitt.
Method G, as mentioned in your other thread, I'd go along with everyone's suggestions if you're not interested in the classic theme or have no need for these workbenches on real Amiga's.

The new AIAB (updated recently), AmigaSYS or AmiKitt make more use of WinUAE power AND USE OS3.5+ for that icon support you need so badly!

MethodGit 01 March 2006 22:24

You sound a bit annoyed there! :shocked

I apologise if I seem to make myself look hard to satisfy.... it's not intentional!

You are right though, you are aiming mostly for the "oldskool WB with Real Amiga" fans after all, hence the name ClassicWB. I guess I felt like customising your P96 version too much and wanted to see these extra icons out of interest! Of course it'd be helpful if someone could work out a way to build a Windows/multi-platform app that examines .info files and displays pictures/info accordingly without you having to boot up WinUAE and an OS, but that'll probably remain a mere dream for the time being.

I'll give AmigaSYS and AmiKit a try though. I do have 3.5 at least.... I hope AmigaSYS in particular will still accept that!

Bloodwych 01 March 2006 22:29

I'm not annoyed at all MG! :D

Just tend to use a serious tone now and again. Honestly, I was being serious - those other packages are the choice for OS 3.5+ support and modern eye candy!

thomas 02 March 2006 08:25

Quote:

Of course it'd be helpful if someone could work out a way to build a Windows/multi-platform app that examines .info files and displays pictures/info accordingly without you having to boot up WinUAE and an OS, but that'll probably remain a mere dream for the time being.
DirOpus8 does display .info files.


All times are GMT +2. The time now is 09:51.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.03938 seconds with 11 queries