English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.Hardware (http://eab.abime.net/forumdisplay.php?f=20)
-   -   Power Tower A1200 with BPPC and other stuff not working properly. (http://eab.abime.net/showthread.php?t=91236)

Capeview 12 March 2018 23:07

Power Tower A1200 with BPPC and other stuff not working properly.
Hi All, New to the Board but not to Amigas as had them since the beginning in various forms, but would very much appreciate some assistance.

I've been looking around for somewhere to post and came across this Board which seems to get a good name from various places I've looked.
I am a member of ANT in North London and hoping to go to SWAG later this year as well, so hoping to get help there as well if there is a hardware problem that needs engineering work. :bash

Anyway, I have a Power Tower with a Mediator 1200 PCI installed. The 4 slot PCI model not the later ones, an Elbox Fast ATA IDE controller, an eyetech keyboard adaptor, CD Drive, 3.5Inch HDD and depending on how it wants to play a Blizzard 060 PPC 603e with 8meg(woo hoo back in the day). I also have a 3d GFX card, Sound Card and Network card that also all worked.

This machine has been sat in my old bedroom back at the parents for about the last 10 years and wanted to get it up and running again but something just isn't playing ball.

I've checked all the Capacitors and from what I can tell none are doming but I will be getting my two 1200's recapped soon, so hoping they aren't the cause of the problem or maybe they are??

In the meantime I've just been trying to work out what might be the issue. I have pulled everything out bar the Keyboard adaptor. The 1200 I have in the tower will power up without the FastATA(seem to be having issues with it even though it was working the other day) now having to plug my 2.5inch in the normal ide connector and connecting up the Mediator with my Blizzard 060 which works with the 2.5inch fine as that and the 060 are installed in my other 1200 and they work fine.

However, the card I want to get running is my Blizzard 060 604e. It was working before it was all set on the floor and left for 10 years or so, and for whatever reason it just won't boot up with the card in the Mediator. The machine just powers on and nothing. remove the card and it boots up fine. Plug my 060 in and it works fine. The PPC fan does spin so there does appear to be power getting to it when it is plugged in but the screen just shows grey and nothing else. Can't even 2 Finger the Mouse to get the Boot Screen up.

And the reason I would love to get this all working again is I want to have fun using it all once again but also to give the new Amiga OS 4.1 a go as the PPS has seriously needed something worth using it for.

Am I missing something?

At the moment I can't track down my manuals so I'm hoping I haven't forgotten to put a cable back in from the power supply somewhere as they are all stored somewhere also at my parents house. Maybe I have forgotten to plug a cable back into the motherboard that needs to come from the PSU?

If I need to check the PSU power ratings, how do I go about checking those. I have a fluke which I'm desperate to use for something, so any advice for testing much appreciated.

My tower PSU is what came with the Tower when I originally bought it, so could well be fault and not giving the correct Voltages?
It's a Meridian Technology Corp 250W(Peak Output 135w)

If there is anything else that may help with resolving this, I would appreciate any help you guys could give.


MigaTech 13 March 2018 15:35

Nice set-up. As you are probably aware PPC driven hardware requires good PWR. So you would be correct to check the PSU.

I found that on the 603e PPC 240MHz 040 25MHz I own, it doesn't like 500w PSU, yet it does except 350w standard. Unusual don't you think. Anyways you can press ESC key to enter a submenu for further PPC set-up. They also take some time and several attempts to stabilize. This is standard on all PPC units that have either sat for sometime without PWR, and/or if you have removed them from the motherboard.

Once you have them stable DO NOT attempt to remove or change PWR unit again.

You can disable the 68060 using the "2" key during reset/boot. The "S" key switches the entire card off.

Use a process of elimination to render you issue. I am sure though that there is nothing wrong with your PPC. Because mine did the same thing after standing and removing. It took a little effort and after a 3 to 5 Minute boot, before all was stable again.

Try entering the sub menu when powering up and then you should see some options that may help to speed up booting.

Your Fast ATA shouldn't cause any issues but you could by pass it just until you get things back on track.

Do you have the correct PPC software installed? Also what Rev is your 1200? I have found that 1D4 works best with 603e units.

Capeview 13 March 2018 18:19

I tested the Fan connector that another user said to try for 5v reading and it gave me a 5v reading for a good few minutes before dropping to 4.75v or just above. He said that shouldn't be a problem, but I don't know enough about these things.

So no idea if the PSU i've got is any good or giving a clean supply, but if I can, I will test my PC's new PSU which is pretty good and has a solid rate and see if that helps at all. I'll take your point about high W into account too if it doesn't like it.

I will also give the various options you suggested a try as well. Without the manual to hand I had forgotten the options you could try. Will also test the Cell Battery once it's been on and see if it's keeping it's 3V charge or if it's even charging in case that is an issue?

With regards to the fast ATA, i've removed that for now so will test with the basics and then get that back in when I can get it working. Although my 1200's will be going of for recapping, because once I have all this in place, I do intend to get back to using it all again.

Really appreciate your help. I will update you guys further if and when I get this working or if still no joy.

Oh, and yes, it's why I'm using this motherboard because of the 1d4 issue, which I think was something to do with timings??

Daedalus 13 March 2018 18:41

Okay, so to summarise: the machine boots fine with an 060 board, but not with the PPC. I don't have a PPC card myself but the first thing you should check in a situation like this is if the power LED is going from dim to bright a second or so after powering on. If that's not happening, your 68K CPU isn't running, and without that you don't get any boot attempt or any form of early startup menu (either from Kickstart or the PPC card). The problem could indeed be power related with a noisy or underperforming PSU, but its ratings are plenty for such a system.

Capacitors are unlikely to be causing the issue either, but should be changed anyway, and in a situation where the PSU is noisy, might be enough to get it running until the PSU is repaired or replaced. The SMT capacitors in the A1200 don't dome or bulge when they're failing like THT capacitors. Instead they just quietly spill their guts on the PCB beneath them, corroding the traces where you can't easily see.

The 3V cell shouldn't be causing any boot issues as it's only used for the real-time clock. It's probably dead at this stage anyway, but nothing to worry about for now. What could be an issue is the on-board ROM or GALs getting corrupted over the years, in which case they would need to be replaced or reprogrammed.

Finally, it could all be as simple as damaged contacts on the accelerator's connector. Have a careful look at all the contacts, and make sure they're all straight and even. It's not unheard of for them to get bent while connecting to a board edge...

Capeview 13 March 2018 19:10

Daedalus, just looked at my BPPC for the light dim as you suggested and there was none. Just to get an idea of what you meant, I put my 060 card in and get a slight dip before it goes bright again and that happily boots away.

If power is an issue I think next call might be to try another power supply and see if that fixes anything.

Will have to wait on the Caps to see if that fixes anything.

With regards to the on Board Rom and GALs(Whatever that is) are they located on the BPPC card, and if so, how easy are they to fix or not at all?

I am going to check the contacts now. If they are slightly out, what is the easiest way to move them back without damage or causing further disrepair?

Update: Have checked the contacts and as far as I can tell they all look good and straight with what I presume is a decent space from the center of the slot and nothing that looks bent or sideways of the plastic separators. Comparing to my 060 card they look pretty similar.

MigaTech 13 March 2018 19:57

Something else you could try, Boot the A1200 holding down both mouse buttons. Then in the ROM menu, select boot with no start-up sequence. Report back what you get .It shall either be a RED screen or PPC enabled.<At a guess.

Can you remember if you had the MapRom feature enabled last time you used the 603e? You need to get into PPC boot menu to make further changes.

One other thing you could check is your 8MB ram, On my 603e I have X2 128MB units installed both @ 70ns, giving a total of 256MB. Timing is important. Just in case you are using X2 4MB units of different NS ratings. If you are not and only using X1 8MB, still check that the RAM is functioning correctly, maybe place it in another card or something.

Not saying it is the RAM, just trying to eliminate everything. Trying another PSU is a good move and if you have one, a 350w is a good rating to start with. Has your card ever had any overclocking? Check your PPC cooler, make sure it isn't clogged with dust!!

@Daedalus, I think he can reconfigure the card once he gets into the PPC boot menu. There he can change RAM timing and even 060 supervisor mode. I know the ROM can definitely be flash updated. Also do you think that because my 603e PPC has the 040 is why it could be more power demanding? 5v against 3v.

trixster 13 March 2018 20:37

Wasn't Daedalus's point that if the power led does not dim with the ppc board in place then he will not be able to get to any early boot menu and as such will not be able to try any of what you have just suggested.

MigaTech 13 March 2018 20:46

Yes that is correct but PPC cards do not act like other Amiga accelerator cards, in that they can act like they are completely off-line, when really they are not. My 603e acted like it was not functioning correctly after left without power and removed from system.

As stated in a post further up, it took a good 3 to 5 minutes to get the card back on-line. Trust me Blizzard PPC cards are temperamental at the best of times, they take quite a bit of starting up and then even more fun in software set-up in OS.

Hence why I also mentioned that, once you do get it booting and with stable power, do not disturb it again and leave it alone.

Capeview 13 March 2018 20:46

Hi MigaTech, can't get any menus with the BPPC card installed. I can with my Blizzard 060 though no problem such as the Kickstart boot menu.

I was thinking memory module could be an issue but having tried the one from my 060 board it still doesn't work and I know that Module works.. Can't test other module as it's too big for my 060 as it's double sided.

As for remembering what I set anything to last time, it was ten years or more ago. Probably when I first got it closer to 20 maybe. lol

I will try an old PC power supply if I've got one around that looks good just to see if it is that. Will either have to butcher a PC or try my new PSU from my new machine. Don't really fancy doing that. They will probably be a lot newer and better to run. Not sure my current PC PSU will be any good though as I think its a Corsair 750W unit. But it's one of there good models with control systems and all the other stuff they bung in them now. So who knows??
Could be why another guy who mentioned about the 500W unit he tried not working. I read somewhere that over kill on the Watts can actually cause you to use more power or something funky like that with the components?

Another couple of things I've noticed. My keyboard which is an Amiga 3000 hooked up using some sort of Key adaptor on the control chip i think, can't remember the adaptor now. If i press the Caps Lock multiple times eventually it does nothing when doing the boot. Works fine with my 060.
Also, the Drive light doesn't come on straight away, but after the initial few seconds it just stays on.

It sounds like Daedulus could be right that the 060 chip on the BPPC just isn't waking up or being allowed to communicate with anything. I have no idea what the GALs are and assuming if the rom can be reprogrammed somehow then that could work too. As it stands now, can't do anything with the machine with the BPPC in the Mediator slot which is a real bummer.

I do appreciate all the help I'm getting though as there are things I've never thought of trying coming through.

Update. Ok, just read last few posts. Going to hunt for another PSU. Will keep you guys updated, because if I can get into the boot menu, that is definitely something.

MigaTech 13 March 2018 21:00

Make sure the memory RAM you are using is 60 or 70ns. Also PWR is everything with PPC cards, I would try a 350w if you can get hold of one.

Try just the Blizzard PPC with a bare A1200 and see if you can get it to boot. Like I said my 603e wasn't booting and then after several changes and attempts it just booted, as if nothing was wrong. PPC cards are extremely complicated compared to standard Amiga Accelerators and do not act the same. Not from my experience anyways.

2B board was what I used for a while with this 603e. Now its on a 1D4 with timing fix.

Keep us posted and keep trying, you shall get there eventually.

Capeview 13 March 2018 21:20

I'll give it another go with my other 1200. I did get it hooked up the other day but didn't know about some of these other options then.

If I remember right I did get a red screen I think using the BPPC, I was doing so much with things everywhere I forget what it was I had hooked up and with what. I'll see if I can get back to that again and I'll let you know.

Two of the PSU's I have aren't usable. One doesn't have the right connectors, just a four pin for the motherboard, and the other was a custom fit for a DELL tower so no chance with that.

I may have a few more lying around, but will need to go through the loft to find them.

Daedalus 13 March 2018 23:47


Originally Posted by trixster (Post 1226592)
Wasn't Daedalus's point that if the power led does not dim with the ppc board in place then he will not be able to get to any early boot menu and as such will not be able to try any of what you have just suggested.

Indeed. If the power LED doesn't change brightness, there's no 68K CPU running, and therefore you can't possibly access the menus (yes, even the Blizzard menu). It might work differently to other cards, but there's no escaping the need for a working CPU to execute ROM code and transfer data to the screen.

Capeview 14 March 2018 11:20

Daedalus, is it something that can be fixed by someone who knows how to solve the problem by the Rom or GALs(Still don't know what they are?). As don't really want to keep moving it back and forth trying this and that if there is the potential to cause more damage??

Other than a new PSU, which i'm not sure is going to solve it, as everything else seems to power up fine and run well.

It's about the only thing I wonder how it occurs seeing as it's just been sat there for years??

Update - Just to add, should the card be solid when attached to the adaptor? My card does wobble back and forth where as the 060 card is rock solid?

Daedalus 14 March 2018 12:12

GALs are arrays of configurable logic gates, a type of programmable logic device (PLD). It's a chip that can be programmed to perform different low-level functions, and are often used on accelerators and other devices as glue logic - circuitry for connecting different systems together. It's possible for chips like that to lose their programming over time, although difficult to diagnose without replacing or reprogramming them. There are people who possess the skills and equipment to do such repairs - Chucky and Stachu are two that come to mind.

You're right, it's probably a good idea to minimise the number of times these cards are disconnected and reconnected, those connectors aren't made to take too much abuse.

As for the wobbling card, it's not a guarantee that it should be rock solid, the connectors aren't particularly positive and aren't meant for "floating" mounting like they are in a tower - the A1200 desktop case and trapdoor cover provide additional support to accelerator cards. My Blizzard 1260 wobbles back and forth quite a bit in my tower when unsupported for example.

Capeview 14 March 2018 12:58

Thanks Daedalus for the info. Something new I now know.

I'll look into getting in touch with these guys and see what they can do and how and hopefully that will resolve the issue.

trixster 14 March 2018 14:07

I would certainly recommend stachu for a blizzardppc repair. he's on here and on amibay (i think he uses amibay most).

Capeview 14 March 2018 14:36

Thanks Trixster. Is there any issues with sending stuff across Europe for repairs. Never done it before and wouldn't mind hearing from people with personal experience?

Going to also wait on my 1200's to be recapped so I can test on return and see if problem is still there, but in the meantime try and gather as much info as possible.

Also, just something I've noticed and can't remember if this is normal for 1200's, but if you have an empty board with just a floppy, no HDD, but it does have all the normal 1200 stuff connected, it seems to take a while to get to the insert Floppy screen?

Daedalus 14 March 2018 14:58

Not really any problem, so long as it's packaged well enough to survive the courier handling. There are no duties or customs (for now...)

Recapping can be done by a lot of people in the UK so that's a little easier.

And yes, that's pretty normal. 3.1 ROMs include a ~30 second delay to allow old, slow hard drives to spin up and respond. Without a hard drive connected, you have to wait the full length of the delay before it tries the floppy drive.

Capeview 14 March 2018 15:07

Iffy looking Lisa chip on my non towered 1200
1 Attachment(s)
Just wanted to add this too as just noticed something not quite nice on my non towered 1200 Lisa chip. Some of the pins look like they are either corroded or collapsing, but can't tell for certain.

I'll attach a picture and maybe someone can give me advice. Is it something that can be repaired, replaced or no point and board is gonna fail?

Only reason I ask, because would it be worth getting that 1200 recapped?

Trying to work out how it would even have been affected, as nothing connects to it, unless of course its that silver item to the left that has leaked?

Thanks daedalus.

MigaTech 14 March 2018 16:00

You really need to try another PSU before even thinking about sending this BPPC off. Most of the members offering information are comparing these cards to normal Amiga accelerators, Although they might know their stuff, these BPPC cards are totally different. They DO NOT act the same. I have owned 2 of them, both have acted strange and totally different to any of the many normal Amiga accelerators, I have owned.

My first one which I bought in 1998 for over £400, did this the day I got it! I thought it was broken then. I have never owned a BPPC card which as ever worked straight away. Even my friend who owned one said how awkward they can be. I had good technical at the time and eventually it booted.

I left my 1st BPPC without power for many years. It took a little time to get back up and running but eventually worked.
That is why I stated do not disturb once you have it stable. Because then it should be OK every time you switch on.

The second BPPC which Had only been disconnected from a stable set-up also stopped responding. This one showed a black screen and the system would just hang for ages. It took about 20 minutes and at least 5 minutes of booting to eventually get working.

Now check this: Same computer with the same BPPC card just a new 500w PSU change from a 350w and black screen non functioning. Changed it back to the 350w and it worked again.

Even in software when switching from 68K to 603e the BPPC card can act strange. Running the quake engine, it would sometimes run and other times wouldn't.

I really thought my BPPC was faulty and I just keep trying and it eventually worked again. Your card might just of gone faulty but at least convince yourself before risk losing it in the post or paying to have it fixed, when there is nothing wrong with it. Try a 350w PSU and just the bare A1200 you have nothing to lose.

All times are GMT +2. The time now is 17:04.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2018, vBulletin Solutions Inc.

Page generated in 0.04845 seconds with 11 queries