English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Bug in Input Config Saving [ForTony] (http://eab.abime.net/showthread.php?t=6491)

gowronnie 19 September 2002 14:10

Bug in Input Config Saving [ForTony]
 
Using the Latest version.

WinXP / DirectX 8.1a / USB Boom PSX Adapter / Genuine PSX Dualshock Pad.

Run WinUAE for the first time setup all the options and set the input to "Configutation #1" and set it up like so:

___________________________________________
input.config=1
input.joymouse_speed_analog=20
input.joymouse_speed_digital=10
input.joymouse_deadzone=33
input.joystick_deadzone=33
input.autofire=1
input.1.joystick.0.axis.0=JOY2_HORIZ.0
input.1.joystick.0.axis.1=JOY2_VERT.0
input.1.joystick.0.button.0=JOY2_3RD_BUTTON.0
input.1.joystick.0.button.1=JOY2_2ND_BUTTON.0
input.1.joystick.0.button.2=JOY2_FIRE_BUTTON.0
input.1.joystick.0.button.3=JOY2_FIRE_BUTTON.1
input.1.joystick.0.button.7=JOY2_UP.0
______________________________________________

which I then save.

Problems:

1) Auto Fire status doesn't save when selected for a button
Solution: Edit config file manually which then loads the option correctly.

2) Auto fire speed doesn't save to anything other than 10
(I want it at 1)

Solution: Set it manualy in the config file, But it doesn't read it in properly and just sets it back to 10m, have to change it manually every time load UAE.

3) When I Load UAE and this Config and then change any setting and save it the input options are then saved as:

__________________________________________

input.config=1
input.joymouse_speed_analog=20
input.joymouse_speed_digital=10
input.joymouse_deadzone=33
input.joystick_deadzone=33
input.autofire=10

# This is the bit I want >

input.1.joystick.0.axis.0=JOY2_HORIZ.0
input.1.joystick.0.axis.1=JOY2_VERT.0
input.1.joystick.0.button.0=JOY2_3RD_BUTTON.0
input.1.joystick.0.button.1=JOY2_2ND_BUTTON.0
input.1.joystick.0.button.2=JOY2_FIRE_BUTTON.0
input.1.joystick.0.button.3=JOY2_FIRE_BUTTON.0
input.1.joystick.0.button.7=JOY2_UP.0

# But it bloody loads this bit!!

input.1.joystick.1.axis.0=JOY1_HORIZ.0
input.1.joystick.1.axis.1=JOY1_VERT.0
input.1.joystick.1.button.0=JOY1_FIRE_BUTTON.0
input.1.joystick.1.button.1=JOY1_2ND_BUTTON.0
input.1.joystick.1.button.2=JOY1_3RD_BUTTON.0

____________________________________________

which is really annoying!!

Solution: have to edit configs manaully to stop the being messed up! , Only the First "clean" setup will save the options correctly.


All times are GMT +2. The time now is 16:45.

Powered by vBulletin® Version 3.8.8 Beta 1
Copyright ©2000 - 2017, vBulletin Solutions, Inc.

Page generated in 0.09330 seconds with 10 queries