English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Driver for test Cybervision64 3D under WinUAE (http://eab.abime.net/showthread.php?t=104143)

Zilog 30 September 2020 21:17

Driver for test Cybervision64 3D under WinUAE
 
Hi to all,
for test Cybervision64 3D under WinUAE how driver/lib to use for test Warp3D , Games, Demo, Program

----------------------------------------------------------------
68K Winaue Config and Library (in order to install)
Amiga 4000 + Cybervision 64 3D
Os 3.1 or More
1: htt*p://aminet.net/package/driver/other/040_060Libs
2: htt*p://aminet.net/util/libs/MathLibsUAE.lha - v45.881 r14
3: htt*p://aminet.net/package/util/boot/StackAttack2 - v2.9
4: Picasso96 or CyberGraphX - v4.3rc6 (Dont't install Picasso96 driver, both not working, with Picasso96 use v2.0) - Important NOTE 4
5: Warp3d - v4.2a (Dont'use Wazp3D, not use CV64 /3D Virge Acceleration)
6: htt*p://aminet.net/util/libs/StormMesa2010.lha - v2.5b
7: htt*p://aminet.net/package/driver/audio/ahiusr_4.18 (Require fore some demo, program, game...)

----------------------------------------------------------------

68K+PPC Winaue Config and Library (in order to install)
Amiga 4000 + Cybervision 64 3D
Os 3.1 or More
1: htt*p://aminet.net/package/driver/other/040_060Libs
2: htt*p://aminet.net/util/libs/MathLibsUAE.lha - v45.881 r14
3: htt*p://aminet.net/package/util/boot/StackAttack2 - v2.9
.....

----------------------------------------------------------------
_Benchmark
Work in Progress...

_Games
Work in Progress...

_Demo
__Warp3D 68K :
____gears-68k-small (JIT indirect and NO JIT)
____gears-68k-windows (JIT indirect and NO JIT)
____Engine (JIT indirect and NO JIT)
____glSokoban (JIT indirect and NO JIT)
____htt*p://aminet.net/dev/src/Cow3D.lha (JIT indirect and NO JIT)
____htt*p://aminet.net/demo/mag/the_vague_1.lha -v1.1 (JIT indirect and NO JIT)

__StomMesa 68K (OpenGL):
____htt*p://aminet.net/dev/src/CollidingStars.lha - v1.0

**NOTE
4)_For Picasso96 Driver
__A) Download htt*p://aminet.net/driver/video/Picasso96.lha - v2.0
__B) For active 15Bit resolution open Prefs:PVS->Environment->Show Mode set "ALL", save and restart Amiga.
__C) Reset WinUAE
__D) Set resolution 15Bit (S3 Virge in 3D Accelerator support only 15 resolution)

4) _For CyberGraphX v4 from cd, when ask this option must be:
__A) NOPASSTHROUGH=NO (disable card monitor swtich)
__B) ToolType "PASSTHROUGH=YES" In this mode active native / rtg switch from driver. (Piccasso96 is set for default)
__C) Set Dragging=NO (something todo with being compatible with v39 multibuffering)
__D) Before reboot install update CyberGraphX v4.3rc6
__E) Close Winuae and Reopen

Update 2020.11.01

Thanks for Help.

James 01 October 2020 03:08

Get the StormMesa2010 libs, that will enable you to run a lot more 3D demos and games:

http://aminet.net/package/util/libs/StormMesa2010

thellier 01 October 2020 11:38

Beware that most things only run in 16 bits screen mode with the CV64/3D ( even 3d progs in a windows wont run on a 24 bits wb)
There was also a command or env variable (dont remenber the name) to set how much memory will be reserved for 3d textures or screen display
Depending on the values some progs may not work ( if want bigger scren or want more textures)

thellier 01 October 2020 11:45

If someone obtain benchmarks for the CV64/3D+Warp3D emu vs WaZp3D I am very interested

White 01 October 2020 12:02

I tried doing a clean install from a clean workbench.
No way. ( for me )
Warp3D opens the screen and freezes.
It would be interesting for me to understand the order of the installations.
eg:
1) picasso96 which version?
2) CyberGraphX 4.42.0 cd version and after the update to CyberGraphX_4.3rc6?
3) or directly CyberGraphX_4.3rc6 with only the cd inserted?

in which order should the drivers be installed, thanks
a video would be even better from someone with good will ;-)

Zilog 01 October 2020 14:36

Quote:

Originally Posted by White (Post 1431144)
I tried doing a clean install from a clean workbench.
No way. ( for me )
Warp3D opens the screen and freezes.
It would be interesting for me to understand the order of the installations.
eg:
1) picasso96 which version?
2) CyberGraphX 4.42.0 cd version and after the update to CyberGraphX_4.3rc6?
3) or directly CyberGraphX_4.3rc6 with only the cd inserted?

in which order should the drivers be installed, thanks
a video would be even better from someone with good will ;-)


@White
1) Picasso driver i don't install
2/3) Before i have install 4.42.0cd and after update 4.3rc6


The rtg dispay Ok.
WarpTest. Ok.


Quake GL don't run, i think the cv643d aren't don't power for it.
Now i searching to run Descent for warp3d; in past with pentium 75 + S3virge function corretly. I thing that run also on amiga.

Zilog 01 October 2020 14:39

Quote:

Originally Posted by thellier (Post 1431137)
Beware that most things only run in 16 bits screen mode with the CV64/3D ( even 3d progs in a windows wont run on a 24 bits wb)
There was also a command or env variable (dont remenber the name) to set how much memory will be reserved for 3d textures or screen display
Depending on the values some progs may not work ( if want bigger scren or want more textures)


@Thellier
But with this little 3d card, cv64/3d how benchmark or game is possibile to run?


I don't very sure ,but i thing cv64/3d it possible run only program/games than use Warp3d v3


Thanks for help.

Zilog 01 October 2020 15:32

Quote:

Originally Posted by James (Post 1431089)
Get the StormMesa2010 libs, that will enable you to run a lot more 3D demos and games:

http://aminet.net/package/util/libs/StormMesa2010


Very Thanks for info!

Add to Main thread.

AMIGASYSTEM 01 October 2020 15:50

Quote:

Originally Posted by Zilog (Post 1431173)
Quake GL don't run, i think the cv643d aren't don't power for it.
Now i searching to run Descent for warp3d; in past with pentium 75 + S3virge function corretly. I thing that run also on amiga.

I think it's still early to test Games with the CV43D, probably you can do it later, at the moment on WinUAE the best choice is UAE Zorro III where most of GL and Warp3D Games and Applications work very well:

Quake 2 GL
https://drive.google.com/file/d/1XbL...kBZE6gHKX/view


Quake 3 Warp3D
https://drive.google.com/file/d/14fs...ew?usp=sharing


Descent
https://youtu.be/xoqMcOuGa8o

Toni Wilen 01 October 2020 19:31

OP asked for CV643D help, your reply isn't very useful..

It also isn't "too early". From my point of view it is done. PCem emulation has been integrated and it seems to work. (Except some crashes when switching resolutions but that is not specific to CV643D)

White 01 October 2020 20:37

@all
i'm working on a clean install and trying various configurations.
If I complete the standard one without touching anything
therefore:
picasso96 2.0 <- here I select only CV643D (aminet)
CyberGraphX Cd-Rom <- standard CV643D installation
I disable only the CV643D logo
start the boot in this way and any option I select remains the gray screen and I can no longer go on even if I put the logo on CV643D boot the screen stays still at the CV643D logo

do you have to choose particular options during installation?
Thank you

thellier 01 October 2020 20:45

I had an 4040 with CV64/3D a long time ago and I think it supported the latest Warp3D for 68k : It was 4.2 or something like that.
Certainly several GL/Mesa demos can run on this config but with stormmesa2010 and if they dont use too much textures (original stormmesa got bugs that make it render as soft so not using warp3d)
I mean vertices count unlimited but texture size/count very restricted

Zilog 01 October 2020 21:04

Quote:

Originally Posted by White (Post 1431284)
@all
i'm working on a clean install and trying various configurations.
....


When install Cybervision select a driver a monitor 80Khz.

White 01 October 2020 21:12

@Zilog
thanks, now I try
I try to do a standard installation, I'm not doing anything special but every time something is wrong :-)
but I'm stubborn if something interests me ;-)

Toni Wilen 01 October 2020 21:42

Also don't install both Picasso96 and CGX. They can't work together.

Zilog 01 October 2020 21:47

Quote:

Originally Posted by Toni Wilen (Post 1431305)
Also don't install both Picasso96 and CGX. They can't work together.


Right Toni!

Thanks a lot.





ugprade the main theread.

Zilog 01 October 2020 21:49

Quote:

Originally Posted by thellier (Post 1431287)
...


Thanks for info!

White 01 October 2020 22:17

@Zilog
are you currently able to boot with the logo activated?
or did you turn it off?
it seems that when I update with the CyberGraphX_4.3rc6 package the CV643D proprietary screen is no longer recognized.
thanks for any suggestions :-)

Zilog 01 October 2020 22:35

Quote:

Originally Posted by White (Post 1431316)
@Zilog
are you currently able to boot with the logo activated?
or did you turn it off?
it seems that when I update with the CyberGraphX_4.3rc6 package the CV643D proprietary screen is no longer recognized.
thanks for any suggestions :-)


The logo i have not install.
In my conf, for now i have disable jit, i have a problem..i wait next beta.

Rom Winuae set original
Cpu Set 68060 (but work too 68040 warp3d)

White 01 October 2020 22:50

@Zilog
thanks, currently with the logo it hangs with the JIT and also without JIT.
thanks again for your suggestions.
I have to understand how it works :-)
It will take some time :-)
the MathLibsUAE.lha and 040_060Libs libraries etc. did you install them before CyberGraphX?


All times are GMT +2. The time now is 08:12.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2021, vBulletin Solutions Inc.

Page generated in 0.05746 seconds with 11 queries