English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   Coders. Releases (http://eab.abime.net/forumdisplay.php?f=115)
-   -   DosBox 0.74 and ScummVM 1.8.1 for Classic Amiga WarpOS (http://eab.abime.net/showthread.php?t=95389)

Hedeon 15 December 2018 02:10

Quote:

Originally Posted by grelbfarlk (Post 1290931)
On the K1 system, build 400 DisSigBounce and Enstackpatch.
I left a bunch of engines out, and this has the AmigaOS FS stuff instead of the Posix FS stuff, I guess I'll go back to Posix FS.

Maybe the AmigaOS stuff needs WarpOSification. Anyway, going to try with your settings.

Regarding small, I was just commenting it was not really small (21 MB vs 19.5 MB or something like that).

grelbfarlk 15 December 2018 02:16

Smallerlier version up now, ~15MB or so, even more engines disabled.

I did pragma pack on the os-includes, not that it was any different than when I didn't do that.

AMike 15 December 2018 14:25

2 Attachment(s)
With a CyberVisionPPC I get strange GFX errors. I've tested R11 and R13. A4000PPC OS3.9. (Tested with different games - always the same error)

grelbfarlk 15 December 2018 17:05

Quote:

Originally Posted by AMike (Post 1291001)
With a CyberVisionPPC I get strange GFX errors. I've tested R11 and R13. A4000PPC OS3.9. (Tested with different games - always the same error)


Looks like it's running in BE when it's expecting LE. And it's the same if you run in a window with a 16bit workbench?

AMike 15 December 2018 19:20

Yeap, I tried different resolutions and colourmodes/fullscreen/window.

jurassicman 15 December 2018 20:11

I tried the latest version with Monkey Island 1 and 2 Talkie edition.

When I start the first Monkey the program crashes but the second starts and works quite well at least for a few minutes.
During the second dialog, though, initially the voice disappears, then the music and at the end the game hangs.

Even when works the audio is a bit chunky but not too bad. It would be great if these issues could be fixed.

Let me know if you want me to test more games.
Thanks for your time and keep up the good work!

grelbfarlk 15 December 2018 20:38

Quote:

Originally Posted by jurassicman (Post 1291061)
I tried the latest version with Monkey Island 1 and 2 Talkie edition.

When I start the first Monkey the program crashes but the second starts and works quite well at least for a few minutes.
During the second dialog, though, initially the voice disappears, then the music and at the end the game hangs.

Even when works the audio is a bit chunky but not too bad. It would be great if these issues could be fixed.

Let me know if you want me to test more games.
Thanks for your time and keep up the good work!


How about non talkie versions or are these talky versions with MP3 audio? Or are they a straight copy from the CD? Also what AHI mode 0 are you using, Paula 8-bit DMA is the fastest, start with that and 22050 audio rate. Also unless you have a really fast PPC, make sure you're using Adlib not MT32.

Hedeon 15 December 2018 21:06

I also would try with R11. R13 seems messing up sound

jurassicman 15 December 2018 22:26

I've already tried the first r13 version but it didn't work. I'll try as soon as possible the r11 version.
The talkie edition I'm using has ogg files, I could try to convert them in mp3 and see if it works but I'm not sure about that.
I'm using AHI mode 0 SB128: HiFi 16 bit stereo++ 8000 Hz and my PPC is just a 603/180 MHz

grelbfarlk 16 December 2018 00:02

Quote:

Originally Posted by jurassicman (Post 1291098)
I've already tried the first r13 version but it didn't work. I'll try as soon as possible the r11 version.
The talkie edition I'm using has ogg files, I could try to convert them in mp3 and see if it works but I'm not sure about that.
I'm using AHI mode 0 SB128: HiFi 16 bit stereo++ 8000 Hz and my PPC is just a 603/180 MHz


Ogg is supported, and from what I've seen on my other ports OGG is about the same as MP3 for CPU load, so that's probably not going to help.



Though HiFI 16 bit Stereo++ is going to be very very demanding. I noticed just by setting this mode and sitting at the menu the 68k CPU load went up by 2x-3x, this is even worse if you do not set a compatible mode in ScummVM, so you're also doing rate conversion in AHI as well-bad recipe.



Try Paula 8-bit DMA for AHI Mode 0, then in ScummVM set 11025 or 22050, see if that's any different.

grelbfarlk 16 December 2018 01:44

Small versions of R11 uploaded to the Zone. Amike give the *BE version a try, doubt it will work for you, but who knows.

AMike 16 December 2018 03:24

Great - thanks :) Will test it asap. :)

jurassicman 17 December 2018 08:48

I've tried all the version with Monkey 2 Talkie Edition.

All work pretty well on my system except for the full R11 that hangs when I try to start the game.

I can't see big differences among the ScummVM versions, all are pretty good and seem to work properly (I've played just a few minutes wit each version) but all have the same "issue" with the sound.

I've tried Paula 8-bit DMA for AHI Mode 0 and 11025 or 22050 KHz on ScummVM but the sound is always good in the dialogs but the music is a bit off-set and you can ear many annoying "pops". If I play without music the game is much more enjoyable.

Unfortunately I didn't have time to test other games, I've tried Monkey 1 (the game with the ogg files, Monkey 2 has only a big .001 file) and it crashes with all versions.

Hope this helps!

jurassicman 17 December 2018 08:49

I've tried all the version with Monkey 2 Talkie Edition.

All work pretty well on my system except for the full R11 that hangs when I try to start the game.

I can't see big differences among the ScummVM versions, all are pretty good and seem to work properly (I've played just a few minutes wit each version) but all have the same "issue" with the sound.

I've tried Paula 8-bit DMA for AHI Mode 0 and 11025 or 22050 KHz on ScummVM but the sound is always good in the dialogs but the music is a bit off-set and you can ear many annoying "pops". If I play without music the game is much more enjoyable.

Unfortunately I didn't have time to test other games, I've tried Monkey 1 (the game with the ogg files, Monkey 2 has only a big .001 file) and it crashes with all versions.

Hope this helps!

grelbfarlk 18 December 2018 05:01

I don't want to say that it doesn't work but it may be that the CD soundtrack + digital speech is too much for your PPC or AHI to handle. I don't have these versions to test with. See if the speech and music are different sound rates like 22khz speech and 44khz music.





How about just trying the plain Jane DOS VGA versions with Adlib sound? See if those basically work. I do have a version of Monkey Island with MP3 soundtrack and that works for me, but I have a much faster PPC.



Thanks to Hedeon and Wrangler it's possible I could add CD-Audio support, which doesn't do much good unless it's an original CD, the benefit of this being-in theory-that it would do the soundtrack in hardware (via the CD audio cable on the CD drive to whatever mixer you have, Paula CD-in for example). But then you'd have to deal with CDs.

amigoun 22 December 2018 22:29

I have tried LOL with the WOS port and keyboard movement works here, good.
I also experienced false graphics colors like AMike in Fullscreen or windowed mode on cybervisionppc and cybergraphics4 at my friends A4000. Only with 15bit or 24bit screemode and windowed mode colors are correct.

Hedeon 22 December 2018 22:52

False colors will be soon fixed by wrangler. It's a mediator artifact where the mediator has hardcoded swapped address lines. The current wos sdl library is tailored for the mediator.

amigoun 22 December 2018 22:54

Sounds good, looking forward :great

AMike 23 December 2018 01:33

Quote:

Originally Posted by AMike (Post 1291131)
Great - thanks :) Will test it asap. :)

Sorry for the late response - sadly the gfx errors still exists in the last "BE" version.

Hedeon 23 December 2018 01:42

Quote:

Originally Posted by AMike (Post 1292397)
Sorry for the late response - sadly the gfx errors still exists in the last "BE" version.

SDL needs an update. See previous post.


All times are GMT +2. The time now is 07:34.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04817 seconds with 11 queries