English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   Help installing workbench onto a hardfile (http://eab.abime.net/showthread.php?t=29900)

mexon 20 May 2007 17:50

Help installing workbench onto a hardfile
Sorry to ask such an utter newbie question. I have never used an Amiga
before in my life. I bought a catweasel card because I want to read
some old Macintosh 800k disks. The website said that the card could
read these disks: but it turns out it can only do so inside an Amiga
emulator. So my first step is to get UAE working to the point where it
will run programs. But what little documentation exists seems to be
written on the assumption that you own or owned a real-life Amiga and
already know what you're doing. I don't.

I'm guessing that I need to install workbench. And that seems to
require a hard disk. I've tried making a hardfile, and also using a
Windows directory. Neither seems to work.

Bug report: click "Add directory". Fill in a device name, e.g.
"Blah". Choose a path. Click "OK". It complains "You must select a
name for the volume!" But I *have* selected a name - "Blah". In fact,
it's trying to say that I have to type a volume label. The error
message is wrong.

When using a windows directory, I've gone for a volume label of "DH0",
on the grounds that other things seem to use something like that. Is
there anything wrong with that? Can it really be anything I like?
Because it sounds like Linux's "hda1", which you can't just go around
renaming willy-nilly.

When using the hardfile, I've read here:


...that I have to clear the parameters "sectors", "surfaces" and
"reserved". So I did that. I also tried it with the defaults for those
parameters. In all cases, hardfile or windows directory, I get the same

When the install disk boots, I get an icon for a ramdisk and an icon for
the install disk. I don't know if I would get an icon for the hard disk
if this was working. Inside the install disk is HDTools, and inside
there is HDToolBox, which I'm trying to use. But it never shows me any
hard disks.

I also read here:


...that I have to modify the HDToolBox icon to read:


This I did by dragging the HDToolBox icon into the Ram Disk window,
which made a copy, and then getting the equivalent of the properties
window with "Icons/Information..." This has:


So I change the SCSI_DEVICE_NAME, and leave the others as they are.
Then double-clicking brings up the "Hard Drive Preparation, Partitioning
and Formatting" screen, which has an empty table at the top and all the
buttons greyed out, so all I can do is Exit.

Some extra info. I got my workbench images from a bittorrent that seems
to have every workbench disk ever made, and then some. On the grounds
that later is better, I'm trying to work with the 3.1 disks (along with
a 3.1 kickstart ROM). There are Boot, Extras, Fonts, Install and Locale
disks, and so I'm inserting the "Install" disk. I have all of these

Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m]-01.ADF
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m2]-01.adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m2].adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m3]-01.adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m3].adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m4]-01.adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m4].adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m5]-01.adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m5].adf
Amiga Workbench 3.1 (40.42) - Install (Commodore) (1994) [m].ADF

I have no idea what they're all for, so I'm going for the last of those.
I'm making my emulator pretend to be an A1200.

Anyone got any help for me?


Toni Wilen 20 May 2007 19:39

Click "RDB mode"-button if you want to use hdtoolbox (no need to play with reserved etc. values)

mexon 21 May 2007 16:34

OK, I just tried that. Am I right in thinking that RDB mode is just an alias for putting "0" in those fields? Because having done it, when I edit the properties of the hardfile, I can't disabled RDB mode or enable it again or anything, the button is just greyed out.

It makes no difference though, I have the exact same effect. I change the SCSI_DEVICE_NAME setting to uaehf.device and launch it, and it comes up with an apparently empty list of available hard disks.

Calgor 21 May 2007 18:12

When installing workbench to a hardfile(s) recently, I used the great Paul's guides:

The guides are really good, and you can get it working by following the instructions exactly, as it doesn't leave anything out.

Note that they use WinUAE GUI to create the RDB stuff, hence it is an alternative to setting up the RDB using HDToolBox discussed above.

mexon 22 May 2007 19:55

Hey, thanks for those links, that was exactly what I needed. Weirdly, I don't have the "storage" disk for 3.1. I guess that's what you get for relying on bittorrent. So my initial attempt failed. But I'll have a go with one of the other versions, and I think I've got everything I need. Thanks again!

All times are GMT +2. The time now is 23:42.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.05181 seconds with 11 queries