English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   News (http://eab.abime.net/forumdisplay.php?f=29)
-   -   IBrowse 2.5.6 + AmiSSL v5 Released (http://eab.abime.net/showthread.php?t=110715)

AMIGASYSTEM 23 May 2022 23:37

Quote:

Originally Posted by jurassicman (Post 1546782)
On my configuration lemonamiga does work without brotli compression enabled.

Maybe you are missing the unpacker?

nikosidis 23 May 2022 23:38

I have this wired problem.
I have a Vampire with PiStorm and 4 Zorro cards.
IBrowse will not run on the Vampire. Is it cause the Zorro, Vampire conflict or is it since I use OS 3.1.2.3.5 :P

Jokes aside and off topic but what a mess Amiga is in.

Most of the threads now got some kind of complains about a game or program not running on some emulator or accelerator card.

AMIGASYSTEM 23 May 2022 23:42

Unfortunately all Accelerator Boards lose compatibility, the Emulator does not suffer much from this problem because it allows you to make targeted Hardware fixes.

Akiko 24 May 2022 00:38

@npagonis73

I have updated my V1200 v2 setup, installing AmiSSL v5, IBrowse 2.5.6 with key / 68040 binary, It runs perfectly and I can't replicate any of the HTTPS issues you mention.

Configuration:

V1200 V2
Gold2.15 x12
3.10 ROM 45.64
Coffin R59 with registered Roadshow
Ethernet Module / Vampire
Vampire IDE / 64GB SanDisk Extreme SD card

Have you tried the Apollo Discord and support forum to see if any others are experiencing this issue?

Futaura 24 May 2022 00:54

Quote:

Originally Posted by AMIGASYSTEM (Post 1546788)
Maybe you are missing the unpacker?

??? No, there is an issue with new built-in Brotli decoding in IBrowse 68K on real 68060 processors, at least. I've confirmed that this is the case and seems not to be AmiSSL related. I'm currently unsure what the problem is and why it does not happen when running under emulation on OS4 or WinUAE. I will find the root cause and fix it sooner or later though!

npagonis73 24 May 2022 01:02

Quote:

Originally Posted by Akiko (Post 1546792)
@npagonis73

I have updated my V1200 v2 setup, installing AmiSSL v5, IBrowse 2.5.6 with key / 68040 binary, It runs perfectly and I can't replicate any of the HTTPS issues you mention.

Configuration:

V1200 V2
Gold2.15 x12
3.10 ROM 45.64
Coffin R59 with registered Roadshow
Ethernet Module / Vampire
Vampire IDE / 64GB SanDisk Extreme SD card

Have you tried the Apollo Discord and support forum to see if any others are experiencing this issue?

Hello Akiko

Thanks for your message. My Coffin 59 also run without problem as well as 58 and even 54. Coffin 60 on the other hand is having issues. I have similar setup as yours with the exception of using a PCMCIA ethernet card instead of the vampire's one.

In coffin 60 after updating AMISSL and ibrowse i get just access only to non https sites. No crash or anything else but it just doesn't open those sites

Rotzloeffel 25 May 2022 12:03

Quote:

Originally Posted by npagonis73 (Post 1546572)
Any ideas on why is happening and how to fix it?


Sounds like you have an old amissl.library directly in libs: !


Delete it :)

npagonis73 25 May 2022 13:48

Quote:

Originally Posted by Rotzloeffel (Post 1546992)
Sounds like you have an old amissl.library directly in libs: !


Delete it :)

Do you mean these 2 in AMISSL folder or do you mean in System:libs? The attached are in AMISSL folderhttps://uploads.tapatalk-cdn.com/202...1132274fa7.jpg

MikeB 25 May 2022 15:05

@ npagonis73

You know how to take some crappy screenshits! ;-)

@ Futaura

Thanks for your ongoing efforts! :-)

blade002 25 May 2022 15:14

After buying the full version of iBrowse about 1 year ago and having f@#k all success getting it to function without a billion SSL errors, this latest update rectified EVERYTHING! excellent work!! :great:great:great:great:lol:lol:lol:lol:spin:spin:spin:spin

AC/DC HACKER! 26 May 2022 00:07

Quote:

Originally Posted by MikeB (Post 1547017)
@ npagonis73

You know how to take some crappy screenshits! ;-)

Whew! I wasn't the only one having a very hard time reading those.
Quote:

@ Futaura

Thanks for your ongoing efforts! :-)
Indeed!

Amiga4000 26 May 2022 01:43

After reading this post I was hesitant to update... just updated two a1200's from AmiSSL V4.12 to V5.1 (installed first) and IBrowse from V2.5.5 to V2.5.6. Now I can't browse HTTS sites. I turned off this brotli thing and no difference.

I've never had a problem updating before. Never! I just want to go back.... :(

I'm bummed for sure.

Unpacked the LHAs as usual with the command line. Both machines running OS3.5. Never a problem before! :sad

Damn sure not going to update my A2000 Blizz060 machine att!

BTW, both A1200 machines sport an ACA1233N w/FPU. I chose IBrowse install option 030 w/FPU on both.

Also, had I did a backup, would I have had to only copy the AmiSSL and IBrowse resident folders?

:p

AC/DC HACKER! 26 May 2022 02:57

A4000 with Cyberstorm PPC/060 here. I made a backup of my 2.5.5 IBrowse, as usual, and updated AmiSSL V5 an IB. So far, everything is going as expected. HTTP/S without problems. Other than IBrowse having some "multi-tasking jerking delays" which I first noticed, I think, with 2.5.5..but I'd have to go back versions to check... Otherwise, all is going well, So A4000 user not noticing the problems commented about here with connections.

Amiga4000 26 May 2022 03:27

Quote:

Originally Posted by AC/DC HACKER! (Post 1547116)
A4000 with Cyberstorm PPC/060 here. I made a backup of my 2.5.5 IBrowse, as usual, and updated AmiSSL V5 an IB. So far, everything is going as expected. HTTP/S without problems. Other than IBrowse having some "multi-tasking jerking delays" which I first noticed, I think, with 2.5.5..but I'd have to go back versions to check... Otherwise, all is going well, So A4000 user not noticing the problems commented about here with connections.


Good to hear that all went well Hacker! :)


And, welcome to the 060 club! :D

Futaura 26 May 2022 10:08

Blank pages on 68060 / Brotli compression
 
I've at last traced the issue that cropped up with Brotli compression - see http://www.ibrowse-dev.net/2.5/issues.php#blankpages

It only affects 68060 processors Rev 5 and older. Not all systems will be affected, but those that do need to disable the store/load buffer bypass on their 68060, as explained on the above page.

Brotli decompression will then work fine and need not be disabled.

Futaura 26 May 2022 10:17

Quote:

Originally Posted by Amiga4000 (Post 1547107)
After reading this post I was hesitant to update... just updated two a1200's from AmiSSL V4.12 to V5.1 (installed first) and IBrowse from V2.5.5 to V2.5.6. Now I can't browse HTTS sites. I turned off this brotli thing and no difference.

I've never had a problem updating before. Never! I just want to go back.... :(

I'm bummed for sure.

Unpacked the LHAs as usual with the command line. Both machines running OS3.5. Never a problem before! :sad

Damn sure not going to update my A2000 Blizz060 machine att!

BTW, both A1200 machines sport an ACA1233N w/FPU. I chose IBrowse install option 030 w/FPU on both.

Also, had I did a backup, would I have had to only copy the AmiSSL and IBrowse resident folders?

You do not need to backup AmiSSL - IBrowse 2.5.5 will continue to be stuck with the old AmiSSL 4.12, whilst IBrowse 2.5.6 requires AmiSSL 5.1. Both AmiSSL versions work fine installed together and installing AmiSSL 5.1 will have left 4.12 fully intact. IBrowse 2.5.5 can still be downloaded from http://www.ibrowse-dev.net/resources...5.5-020%2B.lha and you can install straight over your 2.5.6 install to downgrade.

What exactly are the symptoms you are experiencing? "Can't browse HTTPS sites" doesn't give me much information to go on :).

GadgetUK 26 May 2022 11:48

Very cool! Licensed owner here - Cannot recommend this enough. Yes its a bit pricey for what is free on any modern computer, but lots of work goes into keeping this alive (and useful) on the Amiga. Good to keep supporting companies that support the Amiga.

nikosidis 26 May 2022 17:52

Quote:

Originally Posted by gadgetuk (Post 1547150)
very cool! Licensed owner here - cannot recommend this enough. Yes its a bit pricey for what is free on any modern computer, but lots of work goes into keeping this alive (and useful) on the amiga. Good to keep supporting companies that support the amiga.


+1

Amiga4000 26 May 2022 18:56

Hi Oliver... thanks so much for the reply.


Here's a screen shot of the error plus a version window showing AmiSSL version 5.1 running and, as you can see, running IBrowse version 2.5.6.


Not much to go on but really hoping you can help.


Thanks again!


https://i.postimg.cc/KvvBz41z/IMG-0410.jpg

Futaura 26 May 2022 19:09

Quote:

Originally Posted by Amiga4000 (Post 1547200)
Here's a screen shot of the error plus a version window showing AmiSSL version 5.1 running and, as you can see, running IBrowse version 2.5.6.

Not much to go on but really hoping you can help.

Plenty to go on :)

Are you sure your system clock is set correctly, specifically the date it seems in this case? I think that's what is triggering "Certificate not yet valid".

(I'm also investigating why postimg URLs are being redirectly to an HTML container instead, resulting in an error placeholder, which was the case in previous versions too ;))


All times are GMT +2. The time now is 04:13.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2022, vBulletin Solutions Inc.

Page generated in 0.05780 seconds with 11 queries