English Amiga Board

English Amiga Board (http://eab.abime.net/index.php)
-   support.WinUAE (http://eab.abime.net/forumdisplay.php?f=5)
-   -   One crappy WHDLoad game misbehaves on newest Winuae (4.3.0) (http://eab.abime.net/showthread.php?t=101719)

Aardvark 13 April 2020 19:53

One crappy WHDLoad game misbehaves on newest Winuae (4.3.0)
 
1 Attachment(s)
SAS Combat Simulator no longer react to any keyboard inputs on game's start screen. Works fine when replacing 4.3.0 winuae64.exe with 4.2.1 version.
Only happens in WHDLoad version, no problem when booting from floppy.
Emulated OS is barebone WB3.1 with WHDLoad 18.5

Just reporting this because it's a thing that's only broken on 4.3.0, I don't care about the game.

StingRay 28 April 2020 23:25

This had nothing to do with WinUAE, keyboard interrupt patch was wrong (move.w $bfed01,d0 instead of the correct move.b $bfed01,d0) which caused this problem. Updated patch is available on the WHDLoad site.

Aardvark 29 April 2020 05:05

Sorry about that. I assumed it's a WinUAE bug since it worked fine on older versions.

StingRay 29 April 2020 11:02

All fine, it's good that you reported the problem on the Mantis tracker as otherwise I wouldn't have checked the patch at all.

Toni Wilen 29 April 2020 14:40

Also weird/invalid accesses to CIA space may not be 100% correctly emulated if CPU is 68020+.


All times are GMT +2. The time now is 15:49.

Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2020, vBulletin Solutions Inc.

Page generated in 0.04193 seconds with 11 queries